Ubuntu

[Aspire 7730G] Audio doesn't work with notepad's speakers, but only with headphones

Reported by Marco Gardini on 2010-10-28
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

10.010 - Maverick Meerkat

alsa driver: 1.0.23

I want to hear sounds from the mobile speakers.

I only hear sounds from headphones, if plugged-in, but when I unplug the headphones nothing happens, and still no sound comes out from the speakers.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gardo 1501 F.... pulseaudio
 /dev/snd/pcmC0D0p: gardo 1501 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0500000 irq 47'
   Mixer name : 'Nvidia MCP77/78 HDMI'
   Components : 'HDA:10ec0888,10250142,00100202 HDA:11c11040,10250142,00100200 HDA:10de0006,10de0101,00100000'
   Controls : 40
   Simple ctrls : 22
Date: Thu Oct 28 18:49:21 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC888] ALSA test tone not correctly played back
dmi.bios.date: 09/17/2008
dmi.bios.vendor: Acer
dmi.bios.version: v0.3509
dmi.board.name: Mammoth
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv0.3509:bd09/17/2008:svnAcer,inc.:pnAspire7730G:pvrNotApplicable:rvnAcer,Inc.:rnMammoth:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 7730G
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Marco Gardini (mportnoy90) wrote :

Solved

I found online the solution..

with the command:
gksudo gedit /etc/modprobe.d/alsa-base.conf
I opened the alsa-base.conf file, then added at the end the line:

options snd-hda-intel model=auto

it worked... thanks anyway!

Daniel T Chen (crimsun) wrote :

Is there a subwoofer on this laptop?

Also, please try linux-alsa-driver-modules after removing the model=auto quirk. There is an automatic quirk for your laptop's manufacturer, and we need to verify that it works on your laptop. If you have a subwoofer in it, we also need to verify that the new driver does not break it.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Daniel T Chen (crimsun) on 2010-10-30
Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
tags: added: patch
Daniel T Chen (crimsun) on 2010-10-30
tags: removed: patch
Daniel T Chen (crimsun) wrote :
tags: added: patch
sord1 (sord1) wrote :

The use of the latest daily build does not seem to solve the problem for me. The sound from the headphones does not work anymore, too.
The 7730g does have a subwoofer.

sord1 (sord1) wrote :

Oh, sry the headphones are working. I set the volume on the headphones itself to 0 ;)

Denis (dener-kup) wrote :
David Henningsson (diwic) wrote :

Hi,

A lot of things has happened in the driver since this issue was reported. Acer Aspire 7730G is now using the auto model and has pin fixes to enable subwoofer. Is this still an issue on Ubuntu 12.04, and/or Ubuntu 12.04 with DKMS modules installed ( https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS )?

summary: - Audio doesn't work with notepad's speakers, but only with headphones
+ [Aspire 7730G] Audio doesn't work with notepad's speakers, but only with
+ headphones
Changed in alsa-driver (Ubuntu):
status: Triaged → Incomplete
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.