Soundcard not detected (workaround: add "pci=use_crs" to GRUB)

Bug #662299 reported by Anish Asokan on 2010-10-17
114
This bug affects 27 people
Affects Status Importance Assigned to Milestone
ALSA driver
Fix Released
Medium
alsa-driver (Ubuntu)
Medium
Unassigned
grub2 (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I was using Ubuntu 10.04 64 bit with sound enabled. After I updated to Ubuntu 10.10 64 bit its saying no sound cards detected.

Report generated by alsa-info.sh : http://www.alsa-project.org/db/?f=6fd7c2b5363fb860fbfdf2fcbce5af440562f0a1

Name of my Sound Card (onboard)

anish@logika:~/Downloads$ sudo lshw -c sound
[sudo] password for anish:
  *-multimedia
       description: Audio device
       product: VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
       vendor: VIA Technologies, Inc.
       physical id: 1
       bus info: pci@0000:80:01.0
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=HDA Intel latency=0
       resources: iomemory:fd0-fcf irq:17 memory:fd00000000-fd00003fff

anish@logika:~/Downloads$ lspci | grep -i audio
80:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
AlsaDevices:
 total 0
 crw-rw----+ 1 root audio 116, 3 2010-10-17 23:01 seq
 crw-rw----+ 1 root audio 116, 2 2010-10-17 23:01 timer
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices: aplay: device_list:235: no soundcards found...
Architecture: amd64
ArecordDevices: arecord: device_list:235: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Sun Oct 17 23:36:06 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Title: Soundcard not detected
dmi.bios.date: 05/10/2007
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: V1.11
dmi.board.name: 0A88h
dmi.board.vendor: Board Manufacturer
dmi.chassis.asset.tag: INA74206SB
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.11:bd05/10/2007:svnHewlett-Packard:pnHPdx2255MT(RL028AV):pvr:rvnBoardManufacturer:rn0A88h:rvr:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: HP dx2255 MT(RL028AV)
dmi.sys.vendor: Hewlett-Packard
---
AlsaDevices:
 total 0
 crw-rw----+ 1 root audio 116, 3 2010-10-19 22:29 seq
 crw-rw----+ 1 root audio 116, 2 2010-10-19 22:29 timer
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Oct 17 2010 for kernel 2.6.35-22-generic (SMP).
AplayDevices: aplay: device_list:235: no soundcards found...
Architecture: amd64
ArecordDevices: arecord: device_list:235: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/10/2007
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: V1.11
dmi.board.name: 0A88h
dmi.board.vendor: Board Manufacturer
dmi.chassis.asset.tag: INA74206SB
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.11:bd05/10/2007:svnHewlett-Packard:pnHPdx2255MT(RL028AV):pvr:rvnBoardManufacturer:rn0A88h:rvr:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: HP dx2255 MT(RL028AV)
dmi.sys.vendor: Hewlett-Packard

---
AlsaDevices:
 total 0
 crw-rw----+ 1 root audio 116, 3 2010-10-20 22:10 seq
 crw-rw----+ 1 root audio 116, 2 2010-10-20 22:10 timer
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Oct 20 2010 for kernel 2.6.35-22-generic (SMP).
AplayDevices: aplay: device_list:235: no soundcards found...
Architecture: amd64
ArecordDevices: arecord: device_list:235: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/10/2007
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: V1.11
dmi.board.name: 0A88h
dmi.board.vendor: Board Manufacturer
dmi.chassis.asset.tag: INA74206SB
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrV1.11:bd05/10/2007:svnHewlett-Packard:pnHPdx2255MT(RL028AV):pvr:rvnBoardManufacturer:rn0A88h:rvr:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: HP dx2255 MT(RL028AV)
dmi.sys.vendor: Hewlett-Packard

Anish Asokan (asokan-anish) wrote :
Daniel T Chen (crimsun) wrote :
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Anish Asokan (asokan-anish) wrote :

Hi,

Not resolved. Still having the issue. I added the ubuntu-audio-dev ppa, then installed linux-alsa-driver-modules-$(uname -r)
and restarted it.

aplay -l
aplay: device_list:235: no soundcards found...

Please run apport-collect 662299.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

Download full text (3.2 KiB)

[ 8.865854] HDA Intel 0000:80:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 8.865859] hda_intel: position_fix set to 1 for device 1106:3288
[ 8.865904] HDA Intel 0000:80:01.0: setting latency timer to 64
[ 8.865916] BUG: unable to handle kernel paging request at ffffc900101c8000
[ 8.866064] IP: [<ffffffffa015a011>] azx_probe+0x401/0x969 [snd_hda_intel]
[ 8.866171] PGD 1d897067 PUD 1d898067 PMD 1ce3a067 PTE 800000fd00000173
[ 8.866407] Oops: 0009 [#1] SMP
[ 8.866547] last sysfs file: /sys/devices/pci0000:00/0000:00:0f.0/host0/target0:0:0/0:0:0:0/block/sda/sda2/alignment_offset
[ 8.866609] CPU 0
[ 8.866657] Modules linked in: snd_hda_intel(+) snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer edac_core k8temp edac_mce_amd snd_seq_device i2c_viapro snd psmouse soundcore snd_page_alloc shpchp ppdev parport_pc serio_raw lp parport 8139too 8139cp mii pata_via sata_via floppy
[ 8.868185]
[ 8.868234] Pid: 792, comm: work_for_cpu Not tainted 2.6.35-22-generic #35-Ubuntu 0A88h/HP dx2255 MT(RL028AV)
[ 8.868294] RIP: 0010:[<ffffffffa015a011>] [<ffffffffa015a011>] azx_probe+0x401/0x969 [snd_hda_intel]
[ 8.868401] RSP: 0018:ffff88001caf3e60 EFLAGS: 00010282
[ 8.868454] RAX: ffffc900101c8000 RBX: 0000000000000000 RCX: 0000000000000000
[ 8.868509] RDX: 0000000000000000 RSI: 0000000000000282 RDI: 0000000000000282
[ 8.868564] RBP: ffff88001caf3eb0 R08: 0000000000000001 R09: 0000000000000040
[ 8.868620] R10: 0000000000000008 R11: 0000000000000003 R12: ffff88001cf02000
[ 8.868675] R13: ffff88001c240c28 R14: 0000000000000005 R15: ffff88001c242028
[ 8.868731] FS: 00007ff6918e6700(0000) GS:ffff880001e00000(0000) knlGS:0000000000000000
[ 8.868806] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 8.868869] CR2: ffffc900101c8000 CR3: 00000000166ee000 CR4: 00000000000006f0
[ 8.868933] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 8.868998] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 8.869063] Process work_for_cpu (pid: 792, threadinfo ffff88001caf2000, task ffff88001a6e2dc0)
[ 8.869138] Stack:
[ 8.869196] 000000001caf3fd8 ffff88001cf02090 0000000000015980 ffff88001c242028
[ 8.869396] <0> ffff88001caf3fd8 ffff880016a2bc68 ffff88001caf3ef8 ffffffff8107ad10
[ 8.869695] <0> ffff880016a2bc68 0000000000000000 ffff88001caf3ec0 ffffffff812d6ee7
[ 8.870011] Call Trace:
[ 8.870011] [<ffffffff8107ad10>] ? do_work_for_cpu+0x0/0x30
[ 8.870011] [<ffffffff812d6ee7>] local_pci_probe+0x17/0x20
[ 8.870011] [<ffffffff8107ad28>] do_work_for_cpu+0x18/0x30
[ 8.870011] [<ffffffff8107f0b6>] kthread+0x96/0xa0
[ 8.870011] [<ffffffff8100aee4>] kernel_thread_helper+0x4/0x10
[ 8.870011] [<ffffffff8107f020>] ? kthread+0x0/0xa0
[ 8.870011] [<ffffffff8100aee0>] ? kernel_thread_helper+0x0/0x10
[ 8.870011] Code: 01 00 00 ef 31 f6 4c 89 ef e8 6c d1 ff ff 85 c0 0f 88 c4 03 00 00 4c 89 e7 e8 ec a9 17 e1 41 8b 7d 40 e8 83 0d f7 e0 49 8b 45 38 <66> 44 8b 30 31 c0 ba ef 09 00 00 45 0f b7 c6 48 c7 c1 d0 b2 15
[ 8.870011] RIP [<ffffffffa015a011>] azx_probe+0x401/0x969 [snd_hda_intel]
...

Read more...

Anish Asokan (asokan-anish) wrote :

Hi Daniel,

Is this a problem related to my kernel 2.6.35? Is there any way to downgrade my kernel? Will that work for me?

Anish Asokan (asokan-anish) wrote :

I am daily updating my ubuntu 10.10 desktop with linux-alsa-driver-modules. Still no luck.
Will this be fixed in next kernel version?

Anish Asokan (asokan-anish) wrote :

hi,

Today I built a new custom amd64 kernel from 2.6.36 sources.
I Installed it on my Ubuntu 10.10. I restarted my Ubuntu with new custom kernel and checked "aplay -l" still it was showing.

device_list:235: no soundcards found...

Even inside the new kernel (2.6.36) I am getting some kernel messages like : https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/662299/comments/13

So, I decided to downgraded myself to Ubuntu 10.04 LTS AMD64. Now my sound card is getting detected.

anish@logika:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: VT82xx [HDA VIA VT82xx], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I don't know whats happening wrong here in Ubuntu 10.10. Going back into Ubuntu 10.04 feels like little old... but I am happy everything is working fine here.

But some day I would love to be back in Ubuntu 10.10 or higher... Please don't ignore my sound-card in next release. :-)

greetings!

I also have VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller). Same problem here ... I tried with kernel 2.6.37-rc7 same hda-intel: ioremap error.
alsa-info - http://www.alsa-project.org/db/?f=7e6825d88c98f2be1062f5943ef33cc1bd9180c7

Changed in alsa-driver (Ubuntu):
status: Incomplete → New

AlsaDevices:
 total 0
 crw-rw----+ 1 root root 116, 3 2010-12-25 02:16 seq
 crw-rw----+ 1 root root 116, 2 2010-12-25 02:16 timer
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices: aplay: device_list:235: no soundcards found...
Architecture: i386
ArecordDevices: arecord: device_list:235: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 10.10
NonfreeKernelModules: nvidia
Package: alsa-driver (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Tags: maverick
Uname: Linux 2.6.35-24-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lp lpadmin netdev plugdev powerdev sambashare scanner vboxusers video
dmi.bios.date: 01/25/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: V1.2
dmi.board.name: MS-7253
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.00
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrV1.2:bd01/25/2007:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7253:pvr1.00:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7253:rvr1.00:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr:
dmi.product.name: MS-7253
dmi.product.version: 1.00
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD

apport information

apport information

apport information

apport information

I learned 3 things...

1] Try the live CD before installing.
2] Check if the basic hardware is working from the live cd.
3] If yes go ahead installing it, if not then don't install.

Only trust the Ubuntu LTS versions.

10.10 Live CD has the same problem... The 10.04 LTS kernel works only with some apps choosing OSS. I'll try the live cd when I get home and report ... I guess it will work.

Brăete Marius (braete-marius) wrote :

Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)

10.04 with 2.6.32 sound ok
10.04 with 2.6.35 no sound card detected
10.10 with 2.6.35 and .37 no sound card detected
10.10 with 2.6.32 sound ok

also, #664785, #682185, #700562

Matt Caswell (frodo-baggins) wrote :

Same problem here :-(
alsa-info attached.

Anish Asokan (asokan-anish) wrote :

I installed ubunto 11.04 (amd64) today.
Same problem, VT1708/A [Azalia HDAC] using snd-hda-intel (driver)

aplay -l
was showing no soundcards detected.

I searched through many forums and ended up on this page.
https://bugzilla.kernel.org/show_bug.cgi?id=16921#c5

go read the Comment #5 (its like:)
Finally got sound using pci=use_crs on the grub boot line. Don't know what the
hell this does but at least sound works and no kernel oops at boot.

so what I did:

I took a backup of /etc/default/grub to /root/etc_default_grub_backup

then

opened the file /etc/default/grub with my favorite editor vi.

find the line

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

modify it like

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

save the file (/etc/default/grub)

after saving the file I ran update-grub like

sudo update-grub

then I restarted my ubuntu 11.04.

yes.... perfect the sound is there!!

now if you check "aplay -l"

**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: VT82xx [HDA VIA VT82xx], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

thats it.

if you want to know more about the bug follow: https://bugzilla.kernel.org/show_bug.cgi?id=16921

Thanks

Anish

summary: - Soundcard not detected
+ [solved] Soundcard not detected

Anish Asokan's solution works for me too.

card 1: VT82xx [HDA VIA VT82xx], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: VT82xx [HDA VIA VT82xx], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
summary: - [solved] Soundcard not detected
+ [workaround] Soundcard not detected
summary: - [workaround] Soundcard not detected
+ Soundcard not detected (workaround: add " pci=use_crs" to GRUB)
summary: - Soundcard not detected (workaround: add " pci=use_crs" to GRUB)
+ Soundcard not detected (workaround: add "pci=use_crs" to GRUB)
Changed in grub2 (Ubuntu):
status: New → Invalid
Changed in alsa-driver:
importance: Unknown → Medium
status: Unknown → Confirmed
Matt Caswell (frodo-baggins) wrote :

I upgraded to 11.04 and tried Anish's solution today. It worked!

Yay! I have sound again after 2 months! Thanks Anish!

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 662299

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Carlos Luna (caralu1974) wrote :

I have the same problem I have a motherboard MS-7253 and the solution given up work for me.
As well i follow this bug reports:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5533
https://bugzilla.kernel.org/show_bug.cgi?id=42567
https://bugzilla.kernel.org/show_bug.cgi?id=42619

Changed in alsa-driver:
status: Confirmed → Fix Released
zeugma (sunder67) wrote :
Download full text (4.6 KiB)

I can not get sound.

turgay@turgay-S:~$ aplay -l
aplay: device_list:252: ses kartı bulunamadı...
turgay@turgay-S:~$ lspci -k
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 836d
        Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 836d
        Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 836d
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 83f2
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
        Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
        Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM,P5LD2-VM Mainboard
        Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM,P5LD2-VM Mainboard
        Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM,P5LD2-VM Mainboard
        Kernel driver in use: uhci_hcd
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM,P5LD2-VM Mainboard
        Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
        Subsystem: A...

Read more...

Raymond (superquad-vortex2) wrote :

         use_crs [X86] Use PCI host bridge window information
                                from ACPI. On BIOSes from 2008 or later, this
                                is enabled by default. If you need to use this,
                                please report a bug.
           nocrs [X86] Ignore PCI host bridge windows from ACPI.
                                If you need to use this, please report a bug.

Bjorn Helgaas (bjorn-helgaas) wrote :

"pci=use_crs" is a workaround but not a fix. If anybody who has this problem can attach a complete dmesg log, we should be able to fix the kernel so it works without having to boot with "pci=use_crs".

Bjorn Helgaas (bjorn-helgaas) wrote :

For Micro-Star MS-7253 systems, this should be fixed by:

  http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=841137170961
  http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a97f4f5e524b

which appeared upstream in v3.3. This should fix the problem seen by Dimitar, Matt, and Carlos, so they shouldn't need "pci=use_crs" any more.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.