Ubuntu

[Acer Aspire 8943G] Subwoofer don't mute/unmute on plugging external acoustics

Reported by RussianNeuroMancer on 2010-10-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
David Henningsson

Bug Description

Exactly same bug like here http://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/611803

Subwoofer PIN is NID 0x15.

summary: - [Acer 8943G] Subwoofer don't mute/unmute on plugging external acoustics
+ [Acer Aspire 8943G] Subwoofer don't mute/unmute on plugging external
+ acoustics
tags: added: regression-release
removed: amd64 apport-bug maverick
tags: added: maverick
Daniel T Chen (crimsun) on 2010-10-11
Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
status: New → In Progress
tags: added: patch
David Henningsson (diwic) wrote :

Hi RussianNeuroMancer,
I have taken Daniel's patch and wrapped it into a DKMS package. Can you please do the following:
1) Uninstall ALSA driver overrides, if any
2) Download and install http://people.canonical.com/~diwic/temp/alsa-hda-diwic-acer-8943g-dkms_1.0.23.diwic_all.deb
3) Reboot
4) Verify that it works

Given your positive response I'll send the fix upstream. Thanks!

Changed in alsa-driver (Ubuntu):
status: In Progress → Incomplete

Daniel and David, thanks!
This is correct fix.

Changed in alsa-driver (Ubuntu):
status: Incomplete → New
David Henningsson (diwic) wrote :

Patch sent to stable and upstream. Thanks for reporting!

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: New → In Progress
David Henningsson (diwic) wrote :

Upstream accepted the patch.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
description: updated

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Brad Figg (brad-figg) wrote :

This patch was taken via a stable-upstream update.

tags: added: verification-done
removed: verification-needed
Andy Whitcroft (apw) on 2011-02-10
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers