installed easycap driver, when testing with mplayer my soundcards disappeared

Bug #631885 reported by kjartani on 2010-09-06
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Installed easycapdriver.
sound worked, listening to internet radio.
Then when starting mplayer to test easycap. I had video on mplayer for a few sec then the video froze and the audio hardware was disappeared.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:235: no soundcards found...
Architecture: amd64
ArecordDevices: arecord: device_list:235: no soundcards found...
CheckboxCommand: gst_pipeline_test -t 2 'audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink'
CheckboxDescription:
 Click the Test button to play a sound on the automatically detected playback device.

 Do you hear a sound?
CheckboxTest: playback_auto
Date: Mon Sep 6 21:47:40 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=nb_NO.utf8
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
SourcePackage: alsa-driver

kjartani (kjartan-iverstek) wrote :
Mike Thomas (rmthomas) wrote :

Which EasyCAP driver was in use? The driver at

http://sourceforge.net/projects/easycapdc60/

requires OSS for audio. It works satisfactorily on Ubuntu 10.04 LTS but is known to have problems on Ubuntu 10.10, as discussed here:

http://www.linuxquestions.org/questions/linux-software-2/easycap-viewer-problem-820456/page2.html

kjartani (kjartan-iverstek) wrote :

Thats correct.
Using version 0.8.3 from
"http://sourceforge.net/projects/easycapdc60/"
Will take a closer look at the discussion you mentioned

kjartani (kjartan-iverstek) wrote :

After reading a hole lot of articles about this problem I can conclude with the following:
Problem occures when trying to implement OSS in any way.
/dev/dsp is missing because of a not installed oss so I tried to install "oss-compat" package.
Then ALSA installation was corrupted.....
Reinstalled Maverick
I tried even to select OSS as audio system and install OSS packages but the same occured.... no sound... and when trying to select ALSA back it didnt work.
Reinstalled Maverick
Visited OSS' homepage and found out that the newest software version 2.6 were released in 2003.......
So I'm staying far away OSS until an oss-revolution occurs.

Best regards
Kjartan

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers