[ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back, don't get any audio

Bug #619439 reported by Dennis Bell on 2010-08-17
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Daniel T Chen
Lucid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Lucid
Low
Steve Conklin

Bug Description

Ubuntu 10.04 LTS

There is no audio working at all, I have just installed Ubuntu on this machine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dennis 1325 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with AD1981B at irq 11'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 26
   Simple ctrls : 18
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 1QHT16WW-1.03'
   Mixer name : 'ThinkPad EC 1QHT16WW-1.03'
   Components : ''
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 14
   Mono: Playback 5 [36%] [off]
Date: Tue Aug 17 20:37:34 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SelectedCard: 0 I82801DBICH4 ICH4 - Intel 82801DB-ICH4
SourcePackage: alsa-driver
Symptom: audio
Title: [ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back
dmi.bios.date: 09/22/2005
dmi.bios.vendor: IBM
dmi.bios.version: 1QET97WW (3.02 )
dmi.board.name: 2673C27
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1QET97WW(3.02):bd09/22/2005:svnIBM:pn2673C27:pvrThinkPadX31:rvnIBM:rn2673C27:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2673C27
dmi.product.version: ThinkPad X31
dmi.sys.vendor: IBM

Dennis Bell (dennis-bell) wrote :
Daniel T Chen (crimsun) wrote :

Does muting 'External Amplifier' resolve the symptom? Please use "alsamixer" from a Terminal.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete

Hi,

I'm pleased to be able to say it is now working.

Thank you for the prompt and efficient reply.

Regards,
Dennis.

 mailto:<email address hidden>

________________________________
From: Daniel T Chen <email address hidden>
To: <email address hidden>
Sent: Tue, 17 August, 2010 21:09:27
Subject: [Bug 619439] Re: [ICH4 - Intel 82801DB-ICH4] ALSA test tone not
correctly played back, don't get any audio

Does muting 'External Amplifier' resolve the symptom? Please use
"alsamixer" from a Terminal.

** Changed in: alsa-driver (Ubuntu)
       Status: New => Incomplete

--
[ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back, don't get
any audio
https://bugs.launchpad.net/bugs/619439
You received this bug notification because you are a direct subscriber
of the bug.

Status in “alsa-driver” package in Ubuntu: Incomplete

Bug description:
Ubuntu 10.04 LTS

There is no audio working at all, I have just installed Ubuntu on this machine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
USER PID ACCESS COMMAND
/dev/snd/controlC0: dennis 1325 F.... pulseaudio
Card0.Amixer.info:
Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with AD1981B at irq 11'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 26
   Simple ctrls : 18
Card29.Amixer.info:
Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw
1QHT16WW-1.03'
   Mixer name : 'ThinkPad EC 1QHT16WW-1.03'
   Components : ''
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.values:
Simple mixer control 'Console',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 14
   Mono: Playback 5 [36%] [off]
Date: Tue Aug 17 20:37:34 2010
PackageArchitecture: all
ProcEnviron:
LANG=en_GB.utf8
SHELL=/bin/bash
SelectedCard: 0 I82801DBICH4 ICH4 - Intel 82801DB-ICH4
SourcePackage: alsa-driver
Symptom: audio
Title: [ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back
dmi.bios.date: 09/22/2005
dmi.bios.vendor: IBM
dmi.bios.version: 1QET97WW (3.02 )
dmi.board.name: 2673C27
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias:
dmi:bvnIBM:bvr1QET97WW(3.02):bd09/22/2005:svnIBM:pn2673C27:pvrThinkPadX31:rvnIBM:rn2673C27:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:

dmi.product.name: 2673C27
dmi.product.version: ThinkPad X31
dmi.sys.vendor: IBM

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/619439/+subscribe
k

Daniel T Chen (crimsun) on 2010-08-18
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: Incomplete → Triaged
Steve Conklin (sconklin) on 2010-08-31
Changed in linux (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Incomplete
Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Lucid repo are:

2afb9e9 ALSA: intel8x0: Mute External Amplifier by default for ThinkPad X31

Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Steve Conklin (sconklin)
milestone: none → lucid-updates
Changed in linux (Ubuntu):
status: Incomplete → Invalid

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brad Figg (brad-figg) wrote :

We need some testing of the proposed kernel to see whether this has been resolved - please see comment #6 for information about how to get the proposed kernel.

Thanks

I'll have a look at this in a couple of days. Hope that is OK.

Cheers,
Den.

________________________________
From: Brad Figg <email address hidden>
To: <email address hidden>
Sent: Wed, 15 September, 2010 18:04:00
Subject: [Bug 619439] Re: [ICH4 - Intel 82801DB-ICH4] ALSA test tone not
correctly played back, don't get any audio

We need some testing of the proposed kernel to see whether this has been
resolved - please see comment #6 for information about how to get the
proposed kernel.

Thanks

--
[ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back, don't get
any audio
https://bugs.launchpad.net/bugs/619439
You received this bug notification because you are a direct subscriber
of the bug.

Status in “alsa-driver” package in Ubuntu: Fix Committed
Status in “linux” package in Ubuntu: Invalid
Status in “alsa-driver” source package in Lucid: New
Status in “linux” source package in Lucid: Fix Committed

Bug description:
Ubuntu 10.04 LTS

There is no audio working at all, I have just installed Ubuntu on this machine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
USER PID ACCESS COMMAND
/dev/snd/controlC0: dennis 1325 F.... pulseaudio
Card0.Amixer.info:
Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with AD1981B at irq 11'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 26
   Simple ctrls : 18
Card29.Amixer.info:
Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw
1QHT16WW-1.03'
   Mixer name : 'ThinkPad EC 1QHT16WW-1.03'
   Components : ''
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.values:
Simple mixer control 'Console',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 14
   Mono: Playback 5 [36%] [off]
Date: Tue Aug 17 20:37:34 2010
PackageArchitecture: all
ProcEnviron:
LANG=en_GB.utf8
SHELL=/bin/bash
SelectedCard: 0 I82801DBICH4 ICH4 - Intel 82801DB-ICH4
SourcePackage: alsa-driver
Symptom: audio
Title: [ICH4 - Intel 82801DB-ICH4] ALSA test tone not correctly played back
dmi.bios.date: 09/22/2005
dmi.bios.vendor: IBM
dmi.bios.version: 1QET97WW (3.02 )
dmi.board.name: 2673C27
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias:
dmi:bvnIBM:bvr1QET97WW(3.02):bd09/22/2005:svnIBM:pn2673C27:pvrThinkPadX31:rvnIBM:rn2673C27:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:

dmi.product.name: 2673C27
dmi.product.version: ThinkPad X31
dmi.sys.vendor: IBM

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/619439/+subscribe
Vv

Denis Fertin (denis-fertin) wrote :

If I have understood correctly, there is a new linux kernel package
correcting the issue.
I can test it.
However I would like to install only this package from the proposed
repository.
I could not found the exact name of the package, I need it for the
command :

sudo aptitude install packagename/lucid-proposed

?

Cheers

I can test On 09/15/2010 07:04 PM, Brad Figg wrote:
> We need some testing of the proposed kernel to see whether this has been
> resolved - please see comment #6 for information about how to get the
> proposed kernel.
>
> Thanks
>
>

Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2011-02-10
Changed in linux (Ubuntu):
status: Invalid → Fix Released
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu Lucid):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in alsa-driver (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers