Ubuntu

[Realtek ALC269] ALSA test tone not correctly played back = no sound at all

Reported by Riccardo Masala on 2010-08-15
144
This bug affects 30 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
David Henningsson

Bug Description

No audio at all. Tried to install the correct version from ppa:ubuntu-audio-dev, but no success.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: abbasin 1457 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd4300000 irq 16'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104d4c00,00100100'
   Controls : 11
   Simple ctrls : 7
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd4210000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,104d4c00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Aug 15 17:33:21 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
SelectedCard: 0 SB HDA-Intel - HDA ATI SB
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC269] ALSA test tone not correctly played back
dmi.bios.date: 04/26/2010
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: R0140Z5
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsydeCorp.:bvrR0140Z5:bd04/26/2010:svnSonyCorporation:pnVPCEE2E1E:pvrC1049Q0A:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCEE2E1E
dmi.product.version: C1049Q0A
dmi.sys.vendor: Sony Corporation

Riccardo Masala (raggioscuro) wrote :
Riccardo Masala (raggioscuro) wrote :

I just noticed that audio is reproduced when inserting the headphones (obviously by the same headphones)

Riccardo Masala (raggioscuro) wrote :

Installed OSS and everything goes quite well.

David Henningsson (diwic) wrote :

Can you clarify the problem? Is there no sound out-of-the-box, and no sound in internal speakers - but sound in headphones (if plugged in, obviously) - unless you install OSS?

David Henningsson (diwic) wrote :

Ah. The daily builds are broken as of today, I believe they will be fixed again tomorrow. I believe this problem is fixed in the latest version of the modules, so can you please make a new attempt tomorrow? Remove OSS first, then install https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
Thanks!

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Riccardo Masala (raggioscuro) wrote :

I'll explain better..
fresh install of ubuntu lucid, no audio from the laptop speakers, very low from the earphones. Tried the tricks i could find to fix the problem, but no way to fix it. I red somewhere that OSS worked in a similar case, so I did this attempt.
The notebook is not mine, I will try when I'll get the hands on it again.

Riccardo Masala (raggioscuro) wrote :

Hello! I installed linux-alsa-driver-modules, my kernel is 2.6.32-24-generic.
Again, I only have audio from the earphones.
In alsamixer everything is at the maximum, and nothing is muted.

Next step? ;)

Riccardo Masala (raggioscuro) wrote :

Hello there!
Are there any possibilities for this problem to be fixed or is it better to reinstall OSS4?

thanks!

David Henningsson (diwic) wrote :

Sorry, I've been very busy with other tasks the last few days. Can you please try the following:
1) Uninstalling https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
2) Install the following package: http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-dkms_1.0.23_all.deb
3) Reboot
4) See if it helps?

Riccardo Masala (raggioscuro) wrote :

Excuse me, I didn't want to be rude, I only wanted more info :)

I obey! Downloaded and installed, but errors were detected. I reboot and test it anyway.

Selezionato il pacchetto alsa-intel-hda-update-dkms.
(Lettura del database... 216479 file e directory attualmente installati.)
Estrazione di alsa-intel-hda-update-dkms (da .../alsa-intel-hda-update-dkms_1.0.23_all.deb)...
Configurazione di alsa-intel-hda-update-dkms (1.0.23)...
Loading new alsa-intel-hda-update-1.0.23 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-24-generic
Building for architecture i686
Building initial module for 2.6.32-24-generic

Error! Bad return status for module build on kernel: 2.6.32-24-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/alsa-intel-hda-update/1.0.23/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 47, in <module>
    report['SourcePackage'] = apport.packaging.get_source(package)
  File "/usr/lib/python2.6/dist-packages/apport/packaging_impl.py", line 106, in get_source
    if self._apt_pkg(package).installed:
  File "/usr/lib/python2.6/dist-packages/apport/packaging_impl.py", line 66, in _apt_pkg
    raise ValueError, 'package does not exist'
ValueError: package does not exist
dpkg: errore nell'elaborare alsa-intel-hda-update-dkms (--install):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 10
Si sono verificati degli errori nell'elaborazione:
 alsa-intel-hda-update-dkms

Riccardo Masala (raggioscuro) wrote :

rebooted, no way.
upgraded kernel (as synaptic suggested), reinstalled the package and same error.

Nothing in this report suggests me a solution I can try.

David Henningsson (diwic) wrote :

Sorry, there was an error in the package. Can you download it again from http://people.canonical.com/~diwic/temp/alsa-intel-hda-update-dkms_1.0.23_all.deb , install and reboot?
To check that the package is actually in effect, run "modinfo snd-hda-codec-realtek", and check the filename path: it should include "dkms".

Riccardo Masala (raggioscuro) wrote :

Bingo!

That's OK!!
Is this a permanent fix or should I remove it when an official fix will be published?

You deserve a statue on the main square of the city!

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
David Henningsson (diwic) wrote :

> Bingo!
> That's OK!!

Glad it worked out for you!

> Is this a permanent fix or should I remove it when an official fix will be published?

Its upstreamed: http://mailman.alsa-project.org/pipermail/alsa-devel/2010-August/030952.html

Assuming upstream accepts it, an official fix is likely to reach both Maverick and Lucid, but I'm not sure how long it will take.

> You deserve a statue on the main square of the city!

Heh, these days one should be happy if one gets the proper credit in the kernel's commit log...

Riccardo Masala (raggioscuro) wrote :

the kernel's commit log... Boring reading, nobody reads that stuff! People who can do something thanks to your work has no price.

David Henningsson (diwic) wrote :

Maverick Beta 1 should have this fix in it, and upstream has just accepted it for future releases. No response from stable so far, but they are usually not that fast.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
madbiologist (me-again) wrote :

This fix has been released upstream in kernel 2.6.36-rc3

Andy Whitcroft (apw) on 2011-02-10
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers