Ubuntu

Internal mic not recording any audio

Reported by William King on 2010-06-17
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

http://www.alsa-project.org/db/?f=72f3aacfec7cd89b090d08acfd59c23c7a0fdb4d

I have tried checking the audio levels, with no luck. I have 3 Asus K50AB laptops that all have the same issue with Ubuntu 10.04, but in Windows 7 the mic works fine. So it is not a hardware issue.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: quentusrex 1692 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfbcf4000 irq 16'
   Mixer name : 'VIA VT1708S'
   Components : 'HDA:11060397,10431523,00100000'
   Controls : 19
   Simple ctrls : 12
Date: Thu Jun 17 11:38:10 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 09/25/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 216
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: K50AB
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.00
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr216:bd09/25/2009:svnASUSTeKComputerINC.:pnK50AB:pvr1.0:rvnASUSTeKComputerINC.:rnK50AB:rvr1.00:cvnASUSTekComputerINC.:ct10:cvr1.0:
dmi.product.name: K50AB
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer INC.

William King (quentusrex) wrote :
William King (quentusrex) wrote :

I am having multiple problems.

1. No mic audio 'captured'. Atleast it does not register on the audio level bar.
2. If I put headphones in, then the speakers never work until a reboot.
3. headphones always hear the built in mic. so the audio is always being taken from the built in mic, and piped to the headphone jack.

William King (quentusrex) wrote :

I have installed linux-backports-modules-alsa-2.6.32-22-generic 2.6.32-22.13 and this changes the issues. The mic is now always 'recording' and playing back through the speakers.

If I plug headphones in nothing changes. No audio through the headphones, and the speakers keep playing.

William King (quentusrex) wrote :

For anyone tracking this bug this could help:
quentusrex@quentusrex-asus:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: VIA VT1708S

Elly (elaineci37) wrote :

I upgraded to 1.0.23 and it doesn't make any difference!

What can I do to help assist here to help developers to get the bug fixed?

Incidentally I read somewhere that you can detect how many jacks you have when it is known as "stacks", is that right? Would this info be helpful to assist with this bug problem?

Cheers.

null (oshmelyov) wrote :

I have the same issue. If you need any information please just let me know.

Zijad Maksuti (zmaxuti) wrote :

Integrated Microphone on ASUS X5DAF laptop won't work although it is not muted in Sound Preferences. I tried different settings in alsamixer, but it did not help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers