Alsa not working properly on Fujitsu Siemens Amilo Xa 1526 with Ubuntu 10.04

Bug #587356 reported by Viktor Ilijasic on 2010-05-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Sound is not working properly on my Fujitsu Siemens Xa 1526 laptop with Ubuntu 10.04.

I used to be able to set "options snd-hda-intel model=3stack-dig" in /etc/modprobe.d/alsa-base.conf with Ubuntu 9.04 (and I had quite acceptable sound, both from internal and extermal speakers), but it no longer helps. I tried many other models as well, but to no avail.

Sound from built-in speakers now sounds like it's being played through tweeters (no mid-bass), or it is completely muffled, depending on the model I set in alsa-base.conf.

Currently I am using "options snd-hda-intel model=fujitsu-xa3530", but that's not any better than a lot of other models. Other models that dont emulate tweeters tend to provide louder sound from one channel (cant remember if it is left or right).

I played a lot with alsamixer, and I figured out that I have to set a model with a lot of speakers (5+), and then alsamixer can help my built-in speakers play make-believe-stereo sound. It's actually far from stereo, because, actually, I have to set mid and subwoofer to high gain to get left and right mid-bass sound, which is, btw spilling quite noticeably to the other channel.

So, I would have to say it is far from proper.

Also, microphone is not working at all. When I click the speaker in the indicator applet, and choose sound preferences, then select input tab, it shows no input hardware at all. When I use the old 3stack-dig setting, I cannot get any midbass sound, but I DO have input hardware, although I didn't test if it actually works. In 9.04 with 3stack-dig, microphone worked acceptably, both internal and external connected to the front mic jack.

Since my built-in speakers and microphone didn't work, I didn't even test the connectors.

Laptop has 3 sound jacks in the front, nothing else, no digital either.

Could someone try to do something about this situation?

Thanks,

Viktor

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: viktor 1749 F.... pulseaudio
 /dev/snd/pcmC0D0p: viktor 1749 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xc0000000 irq 19'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,17348405,00100101 HDA:14f12bfa,14f10001,00090000'
   Controls : 34
   Simple ctrls : 19
Date: Sat May 29 16:30:46 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LC_TIME=hr_HR.UTF-8
 PATH=(custom, user)
 LANG=hr_HR.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 10/24/08
dmi.bios.vendor: Phoenix
dmi.bios.version: 1.1S-4426-8A20
dmi.board.name: XTB70
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: 0.3
dmi.chassis.asset.tag: Tag 12345
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: AMILO Xa 1526
dmi.modalias: dmi:bvnPhoenix:bvr1.1S-4426-8A20:bd10/24/08:svnFUJITSUSIEMENS:pnAMILOXa1526:pvrREFERENCE:rvnFUJITSUSIEMENS:rnXTB70:rvr0.3:cvnFUJITSUSIEMENS:ct10:cvrAMILOXa1526:
dmi.product.name: AMILO Xa 1526
dmi.product.version: REFERENCE
dmi.sys.vendor: FUJITSU SIEMENS

Firstly, remove any model quirks you've added for speaker enablement. The
codec fixes are fast-moving, so one model on one Ubuntu release is not
guaranteed stable across upstream alsa-driver releases.

Secondly, try adding the LPIB quirk for your microphone and associated
(possibly audible) stutters, clicks, pops, etc.:

options snd-hda-intel position_fix=1

should appear in /etc/modprobe.d/alsa-base.conf (that quirk *is* guaranteed
stable across releases).

Thirdly, please try installing linux-alsa-driver-modules-$(uname -r) from
ppa:ubuntu-audio-dev.

On May 29, 2010 7:20 PM, "Viktor Ilijasic" <email address hidden>
wrote:

** Attachment added: "AlsaDevices.txt"
  http://launchpadlibrarian.net/49332029/AlsaDevices.txt

** Attachment added: "AplayDevices.txt"
  http://launchpadlibrarian.net/49332030/AplayDevices.txt

** Attachment added: "ArecordDevices.txt"
  http://launchpadlibrarian.net/49332031/ArecordDevices.txt

** Attachment added: "BootDmesg.txt"
  http://launchpadlibrarian.net/49332032/BootDmesg.txt

** Attachment added: "Card0.Amixer.values.txt"
  http://launchpadlibrarian.net/49332033/Card0.Amixer.values.txt

** Attachment added: "Card0.Codecs.codec.0.txt"
  http://launchpadlibrarian.net/49332034/Card0.Codecs.codec.0.txt

** Attachment added: "Card0.Codecs.codec.1.txt"
  http://launchpadlibrarian.net/49332035/Card0.Codecs.codec.1.txt

** Attachment added: "CurrentDmesg.txt"
  http://launchpadlibrarian.net/49332036/CurrentDmesg.txt

** Attachment added: "Dependencies.txt"
  http://launchpadlibrarian.net/49332037/Dependencies.txt

** Attachment added: "PciMultimedia.txt"
  http://launchpadlibrarian.net/49332038/PciMultimedia.txt

** Attachment added: "ProcCpuinfo.txt"
  http://launchpadlibrarian.net/49332039/ProcCpuinfo.txt

--
Alsa not working properly on Fujitsu Siemens Amilo Xa 1526 with Ubuntu 10.04
https://bugs.launc...

Ok, just for future reference, what is the proper way to reload new alsa option(s) that are changed/edited in alsa-base.conf? Besides restarting the machine? I used to know that in Ubuntu 9.04, but that way is obsolete now.

I just installed new alsa-drivers from ppa, removed model quirks and restarted. Currently, without position_fix=1, my sound now sounds like tweeters are playing it.

I just realized that I have to choose the "Analog Stereo Duplex" profile to see input hardware on the input tab. Those profiles are confusing, or at least unintuitively named.

If I choose my Microphone 2 from the dropdown on the Input hardware tab, I can see Input level rising when I tap the internal microphone, but no sound that microphone "hears" is coming out of the speakers.

I'm gonna add position_fix=1 and restart (which I'm sure is not the optimal way to reload stuff, please educate me), just to be sure everything gets reloaded. I'll report my findings.

Added position_fix=1 and restarted. Nothing changed at all. Input level in sound properties, input hardware tab is still reacting, no sound that got into internal microphone is coming out of speakers and speakers still sound like tweeters.

Also with or without position_fix=1, sound recorder does not record anything from the internal microphone. Interestingly, sound level displayed within sound recorder jumps when I start recording then drops _near_ bottom and stays there, without any change when I speak or tap internal microphone. It kind of dances _near_ the bottom regardless what I do to the microphone.

So, It would seem my hardware was never used to play decent sound with linux, and certainly not in the last month.

Lets fix that? :)

I AM happy to report that sound from the line-out jack on the front of the laptop is working properly. It is a workaround, but requires additional equipment. In essence, at the moment, my internal speakers are almost useless.

One more observation, though: balance starts to reduce output only at about 5-10% of slider end position.

All of this is without model specified.

No one has anything helpful to say?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers