Ubuntu

Compaq nx6110 needs an alsactl init entry to unmute Headphone Jack Sense

Reported by Antonio on 2010-05-26
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu 10.04 / Compaq nx6110 - New clean installation.

Workaround:
1. Install Gnome Alsa mixer.
2. Mark option "Headphone Jack Sense", which was unselected.

Also was an issue in 9.10.

Coming Ubuntu versions should fix this and make "Headphone Jack Sense" activated by default.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: antoniodavid 1294 F.... pulseaudio
 /dev/snd/pcmC0D0p: antoniodavid 1294 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with AD1981B at irq 21'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 25
   Simple ctrls : 18
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Package: alsa-driver (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm audio cdrom dialout dip fax floppy fuse plugdev tape video
dmi.bios.date: 09/16/2005
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DTD Ver. F.0B
dmi.board.name: 3088
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 39.1D
dmi.chassis.asset.tag: CNU5500KNH
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DTDVer.F.0B:bd09/16/2005:svnHewlett-Packard:pnHPCompaqnx6110(PY500ET#ABE):pvrF.0B:rvnHewlett-Packard:rn3088:rvrKBCVersion39.1D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq nx6110 (PY500ET#ABE)
dmi.product.version: F.0B
dmi.sys.vendor: Hewlett-Packard

Please use "apport-collect 585777" so that we can collect your hardware
information.

On May 26, 2010 6:10 AM, "Antonio" <email address hidden> wrote:

Public bug reported:

Ubuntu 10.04 / Compaq nx6110 - New clean installation.

Workaround:
1. Install Gnome Alsa mixer.
2. Mark option "Headphone Jack Sense", which was unselected.

Also was an issue in 9.10.

Coming Ubuntu versions should fix this and make "Headphone Jack Sense"
activated by default.

** Affects: alsa-driver (Ubuntu)
    Importance: Undecided
        Status: New

--
Headphones jack doesn't mute speakers
https://bugs.launchpad.net/bugs/585777
You received this bug notification because you are a member of Ubuntu
Audio Team, which is subscribed to alsa-driver in ubuntu.

Status in “alsa-driver” package in Ubuntu: New

Bug description:
Ubuntu 10.04 / Compaq nx6110 - New clean installation.

Workaround:
1. Install Gnome Alsa mixer.
2. Mark option "Headphone Jack Sense", which was unselected.

Also was an issue in 9.10.

Coming Ubuntu versions should fix this and make "Headphone Jack Sense"
activated by default.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hmm, it looks like this isn't an alsa-driver bug at all but a hardware quirk
for your specific PCI SSID. I haven't checked intel8x0.c yet, but there may
be a collision for your hardware, in which case it will be difficult to make
this change in alsa-utils's alsactl init db.

On May 26, 2010 7:16 AM, "Antonio" <email address hidden> wrote:

apport done.

--
Headphones jack doesn't mute speakers
https://bugs.launchpad.net/bugs/585777
You received this ...
---

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevice...

Daniel T Chen (crimsun) on 2010-05-26
affects: alsa-driver (Ubuntu) → alsa-utils (Ubuntu)
Changed in alsa-utils (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: New → Confirmed

I'm not sure, but if my memory does not fail I strongly believe this laptop has always experienced this issue in all versions of ubuntu I have installed on it: 9.04, 9.10, 10.04.

I remember, nevertheless, that it never happened with windows xp home, the original o.s. of this laptop, when it was installed on it, many years ago. Ubuntu is totally installed on the laptop, no windows partition exist, so I can't test current behaviour on windows. Probably, HP drivers post-installation would perform a workaround on the quirk you mention.

Daniel T Chen (crimsun) on 2010-09-12
summary: - Headphones jack doesn't mute speakers
+ Compaq nx6110 needs an alsactl init entry to unmute Headphone Jack Sense
Daniel T Chen (crimsun) wrote :

I've submitted a fix for this bug to upstream.

Changed in alsa-utils (Ubuntu):
status: Confirmed → In Progress
Daniel T Chen (crimsun) on 2010-09-23
Changed in alsa-utils (Ubuntu):
importance: Undecided → Low
Craig Harding (craigwharding) wrote :

This also happens to me. I had 9.10 and initially had the problem but an update fixed this problem. I'm not sure what update it was.

I now upgraded to 10.04 and the problem is back. I have to use a script I found to mute the speakers manually every time I plug my headphones in. Installing gnome-alsamixer does not work for me as I don't have a 'headphone jack sense' option with my sound card. Script to turn off speakers is below.

#/bin/bash
if [ $(~/bin/hda-verb /dev/snd/hwC0D0 0x1f GET_PIN_WIDGET_CONTROL 0x0 | grep 0x0 | wc -l) = 1 ];then ~/bin/hda-verb /dev/snd/hwC0D0 0x1f SET_PIN_WIDGET_CONTROL 0x40;
echo 'unmuted';
else
 ~/bin/hda-verb /dev/snd/hwC0D0 0x1f SET_PIN_WIDGET_CONTROL 0x0;
 echo "Speakers muted";
fi

Gary M (garym) on 2010-10-29
tags: added: hda-jack-sense i386 karmic lucid
bmaupin (bmaupin) wrote :

I still have this problem in 11.04

Gary M (garym) on 2011-07-31
tags: added: natty
Daniel T Chen (crimsun) wrote :

Fixed in Oneiric.

affects: alsa-utils (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Released
zack (zachary61) on 2012-02-05
Changed in alsa-driver (Ubuntu):
assignee: Daniel T Chen (crimsun) → nobody

This bug is still, or again, present in Precise. I just installed 11.10 onto an nx6110, upgraded it to 12.04, and needed to use the gnome-alsamixer workaround to make plugging in headphones mute the speakers.

Gary M (garym) on 2012-02-15
tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers