Ubuntu

[SigmaTel STAC9228] Recording problem

Reported by Ahuman on 2010-05-06
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Daniel T Chen
Lucid
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned
Lucid
Low
Steve Conklin

Bug Description

none of my mics are working. Cant use audacity or skype. Made sure all inputs were on.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.22.1.
 Compiled on Apr 29 2010 for kernel 2.6.32-22-generic (SMP).
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: me 2184 F.... pulseaudio
 /dev/snd/pcmC0D0c: me 2184 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7ffc000 irq 32'
   Mixer name : 'SigmaTel STAC9228'
   Components : 'HDA:83847616,102801f7,00100201'
   Controls : 32
   Simple ctrls : 22
Date: Wed May 5 20:56:53 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [SigmaTel STAC9228] Recording problem
dmi.bios.date: 12/16/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0Y012C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd12/16/2008:svnDellInc.:pnMXG071:pvr:rvnDellInc.:rn0Y012C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXG071
dmi.sys.vendor: Dell Inc.

Ahuman (picdragon99) wrote :
Daren Hayward (ubuntu-hayward) wrote :

I have a Dell M1730 laptop which I believe matches with this hardware

Codec: SigmaTel STAC9228
Address: 0
Function Id: 0x1
Vendor Id: 0x83847616
Subsystem Id: 0x102801f7
Revision Id: 0x100201
No Modem Function Group found

I got the microphone to work by adding the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=dell-bios

This changed the sound preferences to have three options Microphone 1, Microphone 2 or Microphone 3.

Microphone 1 worked with skype and you can see the meter change when noise / voices are detected.

It would be nice if this worked without this mod ;) but at least there is now some info on how to get it working.

I will try it.  Thanks.

-- Sent from my Palm Pre
On May 19, 2010 5:56 PM, Daren Hayward &lt;<email address hidden>&gt; wrote:

I have a Dell M1730 laptop which I believe matches with this hardware

Codec: SigmaTel STAC9228

Address: 0

Function Id: 0x1

Vendor Id: 0x83847616

Subsystem Id: 0x102801f7

Revision Id: 0x100201

No Modem Function Group found

I got the microphone to work by adding the following line to

/etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=dell-bios

This changed the sound preferences to have three options Microphone 1,

Microphone 2 or Microphone 3.

Microphone 1 worked with skype and you can see the meter change when

noise / voices are detected.

It would be nice if this worked without this mod ;) but at least there

is now some info on how to get it working.

--

[SigmaTel STAC9228] Recording problem

https://bugs.launchpad.net/bugs/576160

You received this bug notification because you are a direct subscriber

of the bug.

Status in “alsa-driver” package in Ubuntu: New

Bug description:

none of my mics are working. Cant use audacity or skype. Made sure all inputs were on.

ProblemType: Bug

DistroRelease: Ubuntu 10.04

Package: alsa-base 1.0.22.1+dfsg-0ubuntu3

ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2

Uname: Linux 2.6.32-22-generic x86_64

NonfreeKernelModules: nvidia

AlsaVersion:

 Advanced Linux Sound Architecture Driver Version 1.0.22.1.

 Compiled on Apr 29 2010 for kernel 2.6.32-22-generic (SMP).

AplayDevices:

 **** List of PLAYBACK Hardware Devices ****

 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]

   Subdevices: 1/1

   Subdevice #0: subdevice #0

Architecture: amd64

AudioDevicesInUse:

 USER PID ACCESS COMMAND

 /dev/snd/controlC0: me 2184 F.... pulseaudio

 /dev/snd/pcmC0D0c: me 2184 F...m pulseaudio

Card0.Amixer.info:

 Card hw:0 'Intel'/'HDA Intel at 0xf7ffc000 irq 32'

   Mixer name : 'SigmaTel STAC9228'

   Components : 'HDA:83847616,102801f7,00100201'

   Controls : 32

   Simple ctrls : 22

Date: Wed May 5 20:56:53 2010

InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)

PackageArchitecture: all

ProcEnviron:

 LANG=en_US.utf8

 SHELL=/bin/bash

SelectedCard: 0 Intel HDA-Intel - HDA Intel

SourcePackage: alsa-driver

Symptom: audio

Title: [SigmaTel STAC9228] Recording problem

dmi.bios.date: 12/16/2008

dmi.bios.vendor: Dell Inc.

dmi.bios.version: A10

dmi.board.name: 0Y012C

dmi.board.vendor: Dell Inc.

dmi.chassis.type: 8

dmi.chassis.vendor: Dell Inc.

dmi.modalias: dmi:bvnDellInc.:bvrA10:bd12/16/2008:svnDellInc.:pnMXG071:pvr:rvnDellInc.:rn0Y012C:rvr:cvnDellInc.:ct8:cvr:

dmi.product.name: MXG071

dmi.sys.vendor: Dell Inc.

To unsubscribe from this bug, go to:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/576160/+subscribe

Tobias Krais (tux-spam) wrote :

adding the dell-bios option olved it for me. But my mic is extremely quiet.

Daniel T Chen (crimsun) wrote :

The required change is fairly trivial, but I'm uncomfortable with relying on the bios to Do The Right Thing. On the other hand, at the time (17 Dec 2007) the 3stack addition for this PCI SSID was applied, it was fairly common for the bios to be ... doing the wrong thing. So, we'll get this pushed to stable@ and upstream. Hopefully in three years vendors are less braindead.

Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: New → Triaged
Ahuman (picdragon99) wrote :
Download full text (3.2 KiB)

yep it worked for me too. They still need to fix pulseaudio though.

Thanks.

> Date: Sun, 23 May 2010 20:33:49 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 576160] Re: [SigmaTel STAC9228] Recording problem
>
> The required change is fairly trivial, but I'm uncomfortable with
> relying on the bios to Do The Right Thing. On the other hand, at the
> time (17 Dec 2007) the 3stack addition for this PCI SSID was applied, it
> was fairly common for the bios to be ... doing the wrong thing. So,
> we'll get this pushed to stable@ and upstream. Hopefully in three years
> vendors are less braindead.
>
> ** Changed in: alsa-driver (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: alsa-driver (Ubuntu)
> Status: New => Triaged
>
> ** Changed in: alsa-driver (Ubuntu)
> Assignee: (unassigned) => Daniel T Chen (crimsun)
>
> --
> [SigmaTel STAC9228] Recording problem
> https://bugs.launchpad.net/bugs/576160
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “alsa-driver” package in Ubuntu: Triaged
>
> Bug description:
> none of my mics are working. Cant use audacity or skype. Made sure all inputs were on.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-22-generic x86_64
> NonfreeKernelModules: nvidia
> AlsaVersion:
> Advanced Linux Sound Architecture Driver Version 1.0.22.1.
> Compiled on Apr 29 2010 for kernel 2.6.32-22-generic (SMP).
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: me 2184 F.... pulseaudio
> /dev/snd/pcmC0D0c: me 2184 F...m pulseaudio
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf7ffc000 irq 32'
> Mixer name : 'SigmaTel STAC9228'
> Components : 'HDA:83847616,102801f7,00100201'
> Controls : 32
> Simple ctrls : 22
> Date: Wed May 5 20:56:53 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SelectedCard: 0 Intel HDA-Intel - HDA Intel
> SourcePackage: alsa-driver
> Symptom: audio
> Title: [SigmaTel STAC9228] Recording problem
> dmi.bios.date: 12/16/2008
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A10
> dmi.board.name: 0Y012C
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvrA10:bd12/16/2008:svnDellInc.:pnMXG071:pvr:rvnDellInc.:rn0Y012C:rvr:cvnDellInc.:ct8:cvr:
> dmi.product.name: MXG071
> dmi.sys.vendor: Dell Inc.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/576160/+subscribe

_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.window...

Read more...

Daniel T Chen (crimsun) wrote :

Fix sent to stable@ and upstream

Changed in alsa-driver (Ubuntu):
status: Triaged → In Progress
madbiologist (me-again) wrote :

The abovementioned fix is now upstream in kernel 2.6.32.16.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Lucid repo are:

7e1f412 ALSA: hda: Fix model quirk for Dell M1730

Changed in alsa-driver (Ubuntu):
milestone: none → lucid-updates
Steve Conklin (sconklin) on 2010-08-31
Changed in linux (Ubuntu):
importance: Undecided → Low
assignee: nobody → Steve Conklin (sconklin)
status: New → Fix Committed
status: Fix Committed → Invalid
Steve Conklin (sconklin) on 2010-08-31
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
importance: Undecided → Low
Changed in linux (Ubuntu):
assignee: Steve Conklin (sconklin) → nobody
Changed in linux (Ubuntu Lucid):
assignee: nobody → Steve Conklin (sconklin)
milestone: none → lucid-updates
Changed in alsa-driver (Ubuntu Lucid):
milestone: none → lucid-updates
Changed in linux (Ubuntu):
milestone: none → lucid-updates

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brad Figg (brad-figg) wrote :

We need some testing of the proposed kernel to see whether this has been resolved - please see comment #10 for information about how to get the proposed kernel.

Thanks

Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu Lucid):
status: New → Confirmed
Denis (denis-dellsale) wrote :

I have a similar bug, mic on XPS m1730 is very quiet.
I ran the application ubuntu-bug -s audio and it created this launchpad bug: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1127855.
Can i move it to here?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers