[IDT 92HD73C1X5] No sound from headphone jacks

Bug #568973 reported by Avdi Grimm on 2010-04-23
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Runing Lucid beta 2 on a brand new Dell Studio XPS 16. This laptop has two headphone jacks. Plugging headphones into either jack mutes main speaker audio, but audio does not play back through the headphones.

The headphone jacks are confirmed to work under Windows 7, but I have not tried it under any other version of Linux.

Changing the "Connector" option in Sound Preferences to either "Analog Headphones" or "Analog Line Out" has no effect.

I've also tried installing xfce4-mixer and switching various channels on and off, with no luck.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: avdi 1822 F.... pulseaudio
 /dev/snd/pcmC0D0c: avdi 1822 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf1000000 irq 22'
   Mixer name : 'IDT 92HD73C1X5'
   Components : 'HDA:111d7675,102802fe,00100103'
   Controls : 18
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xcfeec000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Date: Fri Apr 23 08:31:27 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/zsh
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [IDT 92HD73C1X5] Playback problem
dmi.bios.date: 03/12/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0Y517R
dmi.board.vendor: Dell Inc.
dmi.board.version: A08
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A08
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd03/12/2010:svnDellInc.:pnStudioXPS1645:pvrA08:rvnDellInc.:rn0Y517R:rvrA08:cvnDellInc.:ct8:cvrA08:
dmi.product.name: Studio XPS 1645
dmi.product.version: A08
dmi.sys.vendor: Dell Inc.

Daniel T Chen (crimsun) wrote :

Please use linux-alsa-driver-modules-$(uname -r) from ppa:ubuntu-audio-dev.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Daniel Letzeisen (dtl131) wrote :

You might also consider trying a keyword in alsa-base.conf:
gksu gedit /etc/modprobe.d/alsa-base.conf
Copy and paste this:
options snd-hda-intel model=KEYWORD
where KEYWORD is one of the following (e.g. dell-m6)
http://www.mjmwired.net/kernel/Documentation/sound/alsa/HD-Audio-Models.txt#378
Save. Quit. Reboot.

Thank you Daniel, the linux-alsa-driver-modules-2.6.32-21-generic package from ppa:ubuntu-audio-dev fixed the issue.

Daniel T Chen (crimsun) on 2010-04-26
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed

This just broke again as of updating yesterday. I still have ppa:ubuntu-audio-dev in my sources.

I made sure no alsa-modules other than the PPA ones were installed, and re-installed the PPA modules. Headphone audio works again.

madbiologist (me-again) wrote :

If you uninstall the PPA modules and install the kernel from Lucid-proposed, is the problem fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers