Microphone and line-out not working on Dell Latitude 2110

Bug #563215 reported by Alex Moldovan on 2010-04-14
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

The Microphone and the line-out (headset) is not working on Dell Latitude 2110. The built-in speakers are working fine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1214 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 21'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10280461,00100100'
   Controls : 11
   Simple ctrls : 7
Date: Wed Apr 14 13:09:55 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100414)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 01/25/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X06
dmi.board.name: MOE3C3
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX06:bd01/25/2010:svnDellInc.:pnLatitude2110:pvr:rvnDellInc.:rnMOE3C3:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude 2110
dmi.sys.vendor: Dell Inc.

Alex Moldovan (alexmoldovan) wrote :
Ronald McCollam (fader) on 2010-04-16
tags: added: pcert
Ameet Paranjape (ameetp) wrote :

Ronald/Alex,

Does this problem recreate on a more recent kernel version?

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Alex Moldovan (alexmoldovan) wrote :

Tested today with kernel 2.6.32-21, and still not working.

And with linux-alsa-driver-modules-$(uname -r) from ppa:ubuntu-audio-dev?

Ameet Paranjape (ameetp) on 2010-04-21
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Alex Moldovan (alexmoldovan) wrote :

Installing the linux-alsa-driver-modules solved the problem. Both microphone and line-out work well.

Daniel T Chen (crimsun) on 2010-04-22
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed
Martin Wildam (mwildam) wrote :

I have kernel 2.6.32-24-generic
and tried also installing from the ppa with:
sudo apt-get install linux-alsa-driver-modules-2.6.32-24-generic

However, after system restart it still does not work.
My Latitude 2110 is brand new.

I already put all levels up with alsamixer.
Something else I could do?

Martin Wildam (mwildam) wrote :

Which logs should I attach?

Martin Wildam (mwildam) wrote :

Haha! I got it!

After I installed the package mentioned earlier it had no effect. But I tried attaching a headset. And the headset worked. After I plugged that in once and then took off the built-in mic also started to work.

Strange, but that's it.

Martin Wildam (mwildam) wrote :

Oh, I forgot to mention, that I also checked the mixer levels running "alsamixer" from the terminal to make sure the input levels are up.

Martin Wildam (mwildam) wrote :

FYI: Still need to manually run
sudo apt-get install linux-alsa-driver-modules-$(uname -r)
on kernel 2.6.32-32
to get the audio to work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers