No sound in Lucid Lynx Beta 2

Bug #558910 reported by Indian Art on 2010-04-09
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Brian Knoll

Bug Description

1) The release of Ubuntu you are using,Lucid Lynx Beta 2

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
ubuntu@ubuntu:~$ apt-cache policy packagename
W: Unable to locate package packagename

3) What you expected to happen

Play that jungle start rhythm
Play Rhythmbox

4) What happened instead
No sound

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: yelp 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Fri Apr 9 02:30:11 2010
ExecutablePath: /usr/bin/yelp
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp

Indian Art (goldfish-aol) wrote :
Indian Art (goldfish-aol) wrote :

Hardware:

ACER Aspire 5920 Laptop
Intel Core 2 T 5750

2 GB DDR2 RAM, 160 GB HDD
Intel X 3100 Graphics

Sound works flawlessly with Ubuntu 9.04

This problem is on a Live CD. Is it because I need to download stuff to make the sound functional?

affects: ubuntu → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
ChaZcaTriX (chazcatrix) wrote :

Affects me as well
Hardware: MSI Wind U90

Worked on the liveCD on Beta 2 release day, and on a fresh system as well, stopped working after updating in the next days

I installed Lucid beta on the 4th, and have had no sound problems until yesterday, when I lost sound entirely. Not even startup or shutdown tones.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]

  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I uninstalled Pulseaudio and restarted; no change. Sysinfo: Linux 2.6.32-20-generic running KDE Development Platform 4.4.2 (KDE 4.4.2), CPU: AMD Turion X2 Dual-Core Mobile RM-74 at 2200 MHz (4389 bogomips)

I've been updating and upgrading daily. By the way:$ sudo /sbin/alsa reload
[sudo] password for valorie:
/sbin/alsa: Warning: Processes using sound devices: 3366(npviewer.bin).
Unloading ALSA sound driver modules: snd-hda-codec-atihdmi snd-hda-codec-idt snd-hda-intel snd-hda-codec snd-hwdep snd-seq-dummy snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc (failed: modules still loaded: snd-hda-codec-atihdmi snd-hda-codec-idt snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-timer snd-page-alloc).
Loading ALSA sound driver modules: snd-hda-codec-atihdmi snd-hda-codec-idt snd-hda-intel snd-hda-codec snd-hwdep snd-seq-dummy snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.

Makes no difference.

Further info -- tried booting into next older kernel -- no sound.

Used the TTY to run a sound file from Music123 -- no error message; it appeared to be playing the file, but no sound.

I also removed the phonon config in ~/.kde/share/config - no change.

Rebooting into my original Kubuntu Lucid beta LiveCD -- sound plays just fine.

It is most difficult to help with Amarok with no sound!

I would appreciate being added to the CC line for this bug, and don't see where to do that: <email address hidden>

Thanks.

Update: kindly folks on #ubuntu+1 helped interpret the Alsamixer output (screenshot: http://imagebin.org/93240 )

The speaker was muted, and once unmuted -- sound works again. Kmix unmuting had no effect -- and no update should have muted the speaker, so a bug remains, but there is a fix.

Danté (dante-ashton) wrote :

I've had the same problem with 9.04 and 9.10 versions of Kubuntu.

I'm not sure if this is related, but Kubuntu 9.10 did require alsamixer to unmute speakers for flash audio....

ChaZcaTriX (chazcatrix) wrote :

Alsamixer didn't help me

What else - I didn't have all the output channels I had before, both in Alsamixer and KMix: only Master and Front remained...

Brian Knoll (brianknoll2000) wrote :

I rebooted my system (AMD64 Lucid) this morning and now find that no sound hardware is detected any more. I see the volume icon, but it's "blank" (for lack of a better way to describe it; it looks hollow) and in the properties for the volume control, under "Hardware", all I have is a "Dummy Device". So my Intel HDA Audio is no longer detected.

The controller does show up in lspci, so at that level the device is detected by the kernel, but the volume control in Gnome does not see it any more.

I have at least two machines doing this. Both of these machines are 64-bit Lucid machines.

Indian Art (goldfish-aol) wrote :

I also encountered the same problem that you have described so well on how the sound icon looks. "I see the volume icon, but it's "blank" (for lack of a better way to describe it; it looks hollow) and in the properties for the volume control, under "Hardware", all I have is a "Dummy Device". So my Intel HDA Audio is no longer detected."

Such a major bug so close to release, shouldn't someone change the importance to 'High' or Critical'?

HX_unbanned (linards-liepins) wrote :

Agreed - this is CRITICAL bug.

description: updated
OberonKing (oberonking) wrote :

If you guys open a terminal and put:

$ pulseaudio -k

Pufff... magic, the audio work again.....

the problem is: start-sequence of sound modules doesn't synchronize orderly.

Hope this work for you too.

Seeyu

HX_unbanned (linards-liepins) wrote :
Download full text (5.1 KiB)

Not working for me.

linards@linards-desktop:~$ pulseaudio -k
linards@linards-desktop:~$ alsa reload-force
Usage: /sbin/alsa {unload|reload|force-unload|force-reload|suspend|resume}
linards@linards-desktop:~$ alsa force-reload
Terminating processes: 2876 3001 3048 3083 (with SIGKILL:) 3117 (failed: processes still using sound devices: 3150(pulseaudio)).
/sbin/alsa: Warning: Processes using sound devices: 3150(pulseaudio).
mkdir: cannot create directory `/var/run/alsa': Permission denied
/sbin/alsa: Warning: Failed to create /var/run/alsa/.
/sbin/alsa: Warning: Not keeping list of removed modules because /var/run/alsa is absent.
It will not be possible automatically to reload these modules.
Unloading ALSA sound driver modules:/sbin/alsa: 219: cannot create /var/run/alsa/modules-removed: Directory nonexistent
 snd-hda-codec-atihdmi snd-usb-audio snd-usb-lib snd-ca0106 snd-ac97-codec snd-hda-intel snd-seq-dummy snd-hda-codec snd-seq-oss snd-hwdep snd-pcm-oss snd-mixer-oss snd-seq-midi snd-rawmidi snd-pcm snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
mkdir: cannot create directory `/var/run/alsa': Permission denied
Loading ALSA sound driver modules: (none to reload).
linards@linards-desktop:~$ sudo alsa force-reload
[sudo] password for linards:
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
Terminating processes: 3150lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
 3259lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
 3292lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
 3327lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
 (with SIGKILL:) 3360lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
 (failed: processes still using sound devices: 3392(pulseaudio)).
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/linards/.gvfs
      Output information may be incomplete.
/sbin/alsa: Warning: Processes using sound devices: 3392(pulseaudio).
Unloading ALSA sound driver modules: snd-hda-codec-atihdmi snd-usb-audio snd-usb-lib snd-ca0106 snd-ac97-codec snd-hda-intel snd-seq-dummy snd-hda-codec snd-seq-oss snd-hwdep snd-pcm-oss snd-mixer-oss snd-seq-midi snd-rawmidi snd-pcm snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc (failed: modules still loaded: snd-hda-codec-atihdmi snd-usb-audio snd-usb-lib snd-ca0106 snd-ac97-codec snd-hda-intel snd-hda-codec snd-hwdep snd-rawmidi snd-pcm snd-timer snd-seq-device snd-page-alloc).
Loading ALSA sound driver modules: snd-hda-codec-atihdmi snd-usb-audio snd-usb-lib snd-ca0106 snd-ac97-codec snd-hda-intel snd-seq-dummy snd-hda-codec snd-seq-oss snd-hwdep snd-pcm-oss snd-mixer-oss snd-seq-midi snd-rawmidi snd-pcm snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
linards@linards-desktop:~...

Read more...

OberonKing (oberonking) wrote :

why you put "alsa reload-force" the only thing that I did are:

$ pulseaudio -k

And open audio properties (System >> preferences >> Sound) and put the volume on 100%
works for me many times.

try it..... and hope it works this time.

HX_unbanned (linards-liepins) wrote :

I put it because my first try of "pulseaudio -k" command did not work.

And - no - do not work for me. The problem is noticeable in "Multimedia System Selector" config tool. I have "Unsupported" in "Devices" listbox. :P

i AM HOPING THAT AT LEAST rc WILL FIX THIS ISSUE ... Otherwise I am thinking to use Windows more often ... again .... :(

Daniel T Chen (crimsun) wrote :

HX_unbanned, are you using linux-alsa-driver-modules-$(uname -r) from
ppa:ubuntu-audio-dev?

HX_unbanned (linards-liepins) wrote :

linards@linards-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 0: ca0106 [CA0106]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 1: ca0106 [CA0106]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 2: ca0106 [CA0106]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 3: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Speakerphone [Logitech EasyCall Speakerphone], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

HX_unbanned (linards-liepins) wrote :

Daniel T Chen,
Yes - just installed, rebooted.
Result - nothing.

What logs you need? ;)

Daniel T Chen (crimsun) wrote :

wiki/PulseAudio/Log

HX_unbanned (linards-liepins) wrote :

huh? :( U mean dir or web location ... ?

Daniel T Chen (crimsun) wrote :

wiki.ubuntu.com

OberonKing (oberonking) wrote :

to bad that not work for you..... hope you can fix it soon....
If I find something else I tell you....

HX_unbanned (linards-liepins) wrote :

Requested log uploaded, Danel !l! ;)

OberonKing - THANK YOU. GLAD TO BE PART OF SO HELPFUL COMMUNITY!!!

tags: added: patch
Michael Lazarev (milaz) wrote :

@OberonKing: pulseaudio -k worked for me, thank you very much!

I hope users of the final release will be able to listen Frustration
Blues instead of performing it themselves on launchpad :)

HX_unbanned (linards-liepins) wrote :

Any other solution available?

Please ...

ChaZcaTriX (chazcatrix) wrote :

I added

alsactl init

to my KDE autostart, with a "start in terminal" attribute; command itself fixes the sound for me

Olli Niemi (olliniem) wrote :

I have this problem with current Lucid Lynx and Intel motherboard HDMI audio. With Mythbuntu there is no pulseaudio.

Brian Knoll (brianknoll2000) wrote :

I urge everybody on this bug to listen to Daniel T. Chen and go look at but 557421 to see if it looks like that might be the same bug you are experiencing, and if so, then add yourself to the list of affected users for that bug.

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/557421

Olli Niemi (olliniem) wrote :

My problem was HDMI specific and not related to this bug. After updating kernel there are no problems with HDMI (or analog HDA) audio.

Indian Art (goldfish-aol) wrote :

I'm using Lucid Lynx on my computers and I have no problems with sound so I am closing this bug. I feel this bug should have been closed a long time ago.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions