pulseaudio gives no audio output with snd_intel8x0

Bug #557699 reported by Gavin Bisesi on 2010-04-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

When I try to play any audio through pulse, it does not output any sound. Pulse logs are normal with no errors, and nothing unusual shows up in dmesg.

I have a few other machines with an identical set of packages and configuration (both installed from a custom cd), and it works on every other machine, all of which use snd_hda_intel. This is the only machine that fails.

lspci gives:
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller (rev 02)
    Subsystem: Device 414c:4760
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 17
    Region 0: I/O ports at f000 [size=256]
    Region 1: I/O ports at fa00 [size=64]
    Region 2: Memory at fdffe000 (32-bit, non-prefetchable) [size=512]
    Region 3: Memory at fdffd000 (32-bit, non-prefetchable) [size=256]
    Capabilities: [50] Power Management version 2
        Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
        Status: D0 PME-Enable- DSel=0 DScale=0 PME-
    Kernel driver in use: Intel ICH
    Kernel modules: snd-intel8x0

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pulse 1230 F.... pulseaudio
 /dev/snd/pcmC0D0p: pulse 1230 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH7'/'Intel ICH7 with ALC655 at irq 17'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 41
   Simple ctrls : 26
Date: Wed Apr 7 18:54:34 2010
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.19-0ubuntu4.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-20-generic i686
mtime.conffile..etc.default.pulseaudio: 2010-04-07T11:47:22
mtime.conffile..etc.init.d.pulseaudio: 2010-04-07T18:04:01.408669
mtime.conffile..etc.pulse.system.pa: 2010-04-07T11:47:24

Gavin Bisesi (gavin-bisesi) wrote :

Try muting 'External Amplifier' using alsamixer in a Terminal.

Daniel T Chen (crimsun) on 2010-04-08
affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Gavin Bisesi (gavin-bisesi) wrote :

I tested again with that unmuted and still get no sound.

Also, if I stop all pulse processes, I can play using straight alsa. I do need it to work through pulse though.

Daniel T Chen (crimsun) wrote :

Do you mean that you tested with 'External Amplifier' *unmuted* (which means set to 'on')? I asked specifically for it to be *muted* (set to 'off'). What do you mean with your last paragraph?

Gavin Bisesi (gavin-bisesi) wrote :

Sorry, you're right. I meant to say muted there :)

It was off for that test.

Daniel T Chen (crimsun) wrote :

Sheesh, this is convoluted. :-)

So, is sound inaudible both with 'External Amplifier' muted *and* unmuted?

Gavin Bisesi (gavin-bisesi) wrote :

That is correct.

Mark Renouf (mark-renouf) wrote :

I've been working on this issue as well, and wanted to confirm that mixer settings do not appear to be at fault, since with pulseaudio stopped, audio works directly through alsa. Other systems with identical configuration but different sound hardware (using intel_hda driver) do work.

Here's the general test case we have been using:

# paplay /usr/share/sounds/alsa/Noise.wav
-> NO SOUND

# aplay -D default /usr/share/sounds/alsa/Noise.wav
-> NO SOUND (through pulseaudio via alsa-pulseaudio plugin)

# aplay -D hw:0 /usr/share/sounds/alsa/Noise.wav
aplay: main:608: audio open error: Device or resource busy

# pkill pulseaudio
# aplay -D hw:0 /usr/share/sounds/alsa/Noise.wav
-> WORKS

No suspicious output or errors have been spotted in the debug logs from pulseaudio. The commands run and complete just as though sound is being played.

Brad Figg (brad-figg) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
Mark Renouf (mark-renouf) wrote :

Sorry, but this is still broken. I've provided additional information that hasn't yet, been responded to (April 8th).

Changed in alsa-driver (Ubuntu):
status: Expired → New

gavbs, in the original amixer output, Surround, Center, LFE, and
Duplicate Front are all muted for playback. Does adjusting those make
any difference?

Mark, do you actually have an identical controller and codec? See
/proc/asound/card*/*codec*/*

Gavin Bisesi (gavin-bisesi) wrote :

Adjusting them made no difference. I've also tried with every mixer at max and unmuted.

To post a comment you must log in.