Ubuntu

Jack Sense Error on Acer Aspire 7740G

Reported by Peter Bruhn on 2010-04-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

When attatching headset to Acer Aspire 7740G the internal speakers still play sound (headset plays sound also). I would expect the internal speakers to mute.

bru@laptop:~$ uname -a
Linux laptop 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 04:38:19 UTC 2010 x86_64 GNU/Linux

bru@laptop:~$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

ProblemType: Bug
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0600000 irq 22'
   Mixer name : 'Realtek ID 670'
   Components : 'HDA:10ec0670,10250347,00100002 HDA:11c11040,11c10001,00100200'
   Controls : 4
   Simple ctrls : 3
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xcfedc000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Apr 5 22:21:30 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: alsa-driver
Uname: Linux 2.6.31-20-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:1747): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1818): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1793): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (firefox:2293): GLib-WARNING **: g_set_prgname() called multiple times

Peter Bruhn (peter-bruhn) wrote :
Daniel T Chen (crimsun) wrote :

Please use linux-alsa-driver-modules-$(uname -r) from ppa:ubuntu-audio-dev

Changed in alsa-driver (Ubuntu):
status: New → Fix Committed
seopaul (lashbrook-paul) wrote :

im getting this jack sense bug on a acer aspire 7740 (no G) its the same modal without a dedicated gfx card... not sure if the below is what you need, but im on the email list for this bug so if its not what you need if someone could let me know what commands to run i would be very greatful

paul@paul-laptop:~$ uname -a
Linux paul-laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

paul@paul-laptop:~$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

paul@paul-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ID 670
Codec: LSI ID 1040
Codec: Intel G45 DEVIBX

paul@paul-laptop:~$ grep "^Codec\|^Vendor Id\|^Subsystem Id\|^Revision Id" /proc/asound/card*/*codec*{,/*} | grep -B2 -A1 $(lspci -nv | grep -A1 0403 | grep Subsystem | sed 's/://g' | awk '{ print $2 }')
grep: /proc/asound/card*/*codec*/*: No such file or directory
/proc/asound/card0/codec#0:Codec: Realtek ID 670
/proc/asound/card0/codec#0:Vendor Id: 0x10ec0670
/proc/asound/card0/codec#0:Subsystem Id: 0x10250347
/proc/asound/card0/codec#0:Revision Id: 0x100002

Foppe Hemminga (foppe) wrote :

Fix from #2 works in 10.04.
I used info on https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules to install.

Gary M (garym) on 2010-10-29
tags: added: hda-jack-sense karmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers