can't adjust volume with Intel 82801I (ICH9 Family) HD Audio Controller after updating to linux-alsa-driver-modules-2.6.31

Bug #535586 reported by Martin Schröder on 2010-03-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

After installing the prior version of linux-alsa-driver-modules, sound worked (it was played trough my internal speakers, i could adjust the volume, but the speakers didn't mute, if i plugged in headphones).
After updating the kernel and likewise to linux-alsa-driver-modules-2.6.31, headphones don't work anymore, I can't adjust the volume (it's on if the volume is >0 or off, no steps in between) and sound doesn't work anymore at all, if I tried to play flash movies (eg. youtube) in firefox (in the audio-settings there is an entry "alsa-plugin").
I expect
-the volume to be adjustable (like before),
-the headphones to be working and if they are plugged in: the internal speakers to be muted
-sound played through alsa-plugin not to crash the audio-system

Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 1923 F.... pulseaudio
 /dev/snd/pcmC0D0c: martin 1923 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf3400000 irq 21'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:11061398,1025020a,00100100 HDA:14f12c06,10250093,00100000 HDA:10de0003,10de0101,00100000'
   Controls : 29
   Simple ctrls : 15
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: alsa-driver (not installed)
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
Uname: Linux 2.6.31-20-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

After installing linux-alsa-driver-modules-2.6.31-20-generic, according to my kernel version, i can adjust the volume again and flash in firefox works, too.
One problem remains: When i plug in my headphones, the internal speakers are not muted.
I think the problem is related to the following issue: In AlsaMixer for playback devices, I can see (amongst others) Master Front, Headphone, PCM, Front, Front Mic and Mic. The "Master" slide behaves correctly (the overall volume is controlled), the "Headphone" slide is without function (the value has no effect on the headphone's volume), "PCM" also controls overall volume, "Front" controls both, internal speakers and headphones, "Front Mic" doesn't affect normal playback, but "Mic" behaves like an alternative slide for "Master" (If the last volume setting is made with "Master", it's value is taken, if the last volume setting is made with "Mic", the "Mic"-value is taken).

Brad Figg (brad-figg) on 2010-03-28
tags: added: kj-triage
Brad Figg (brad-figg) on 2010-03-31
tags: added: karmic

after the multiple updates in the last weeks, the problem remains with unmuted internal speakers, not working microphone and the mic-slider controlling the master volume.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers