Internal microphobe doesn't work on Sony VAIO VPCF11Z1E #Lucid + Patch

Bug #531028 reported by Mathieu Laurent on 2010-03-02
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Mathieu Laurent
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Mathieu Laurent

Bug Description

linux-image : 2.6.32-14-generic

Mathieu Laurent (mla) wrote :

Here's a patch for 2.6.32.8 to get it working. To get the internal mic, use the patch
posted above.

http://code.google.com/p/vaio-f11-linux/issues/detail?id=2

Mathieu Laurent (mla) wrote :

It's not a bug on alsa-driver... It's a bug on linux-image, but I cannot affect this project

tags: added: patch
tags: added: kernel-series-unknown
Brad Figg (brad-figg) on 2010-03-28
tags: added: kj-triage needs-required-logs no-sound-mic
Mathieu Laurent (mla) wrote :

tags: added: kj-triage needs-required-logs no-sound-mic ???

Do you need some feedback about this bug

Regards

Mathieu

Jeremy Foshee (jeremyfoshee) wrote :

Hi Mathieu,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 531028

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
Mathieu Laurent (mla) wrote :
Daniel T Chen (crimsun) wrote :

This is fixed in linux-alsa-driver-modules-$(uname -r) in ppa:ubuntu-audio-dev

Changed in alsa-driver (Ubuntu):
status: New → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Mathieu Laurent (mla) wrote :

I installed linux-alsa-driver-modules-2.6.32-22-generic but mic didn't work...

apt-cache show linux-alsa-driver-modules-2.6.32-22-generic
Package: linux-alsa-driver-modules-2.6.32-22-generic
Source: linux-alsa-driver-modules-2.6.32
Priority: optional
Section: admin
Installed-Size: 8688
Maintainer: Ubuntu Kernel Team <email address hidden>
Architecture: amd64
Version: 2.6.32-22.201005160600
Replaces: linux-backports-modules-alsa-2.6.32-22-generic
Depends: linux-image-2.6.32-22-generic
Conflicts: linux-backports-modules-alsa-2.6.32-22-generic
Pre-Depends: dpkg (>= 1.10.24)
Filename: pool/main/l/linux-alsa-driver-modules-2.6.32/linux-alsa-driver-modules-2.6.32-22-generic_2.6.32-22.201005160600_amd64.deb
Size: 1876810
MD5sum: d254b1f33db2c7a89ea4a037acb89a02
SHA1: 08e655ab43f524f15ec67b9dc191ed9c96e5fa1b
Description: Ubuntu-supplied Linux modules for version 2.6.32-22-generic ALSA snapshots
 This package contains modules supplied by Ubuntu for Linux 2.6.32-22-generic ALSA
 snapshots from http://kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.bz2
 .
 You likely do not want to install this package directly. Instead, install
 the linux-alsa-driver-modules-lucid-generic meta-package, which will
 ensure that upgrades work correctly and that supporting packages are
 also installed.

Daniel T Chen (crimsun) wrote :

Can you run http://www.alsa-project.org/alsa-info.sh again, please?

Mathieu Laurent (mla) wrote :

Hi Daniel,

Here is the result : http://www.alsa-project.org/db/?f=3be61061057d0f010a6b1993e6794730b9af1a42

Thanks for your help

eloy (eloygbm) wrote :

Hi everybody,

are your mic working?

In my vaio model VPCS11C5E the mic doesn't work?

may be another thread to discuss?

thanks!

auxbuss (launchpad-auxbuss) wrote :

You might want to try the fix from here:

  http://code.google.com/p/vaio-f11-linux/wiki/EnableMicrophone

#34 here worked for me:

  http://code.google.com/p/vaio-f11-linux/issues/detail?id=2&can=1

This requires using the HDA anayzer from here:

  http://www.alsa-project.org/main/index.php/HDA_Analyzer

eloy (eloygbm) wrote :

Great!
It works for my external mic, not internal ...
At least I can speak with skype ;)

thanks!

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.