crackling on audio capture in any application internal or external microphone

Bug #525328 reported by Brian Buchanan on 2010-02-21
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Daniel T Chen

Bug Description

Binary package hint: pulseaudio

All audio playback is perfect including in Skype, but audio capture through the internal or an external microphone
in any application has crackling/popping in the background.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: novatech-linux 1381 F.... pulseaudio
 /dev/snd/pcmC0D0c: novatech-linux 1381 F...m pulseaudio
 /dev/snd/pcmC0D0p: novatech-linux 1381 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'SIS966'/'HDA SIS966 at 0xd3200000 irq 18'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,15580802,00100101 HDA:10573055,00305557,00100900'
   Controls : 25
   Simple ctrls : 15
Date: Sun Feb 21 15:09:50 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
NonfreeKernelModules: nvidia
Package: pulseaudio 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu9
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.19-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.32-14-generic x86_64

Brian Buchanan (nighthawk-uk) wrote :
Daniel T Chen (crimsun) wrote :

Is this reproducible with 0ubuntu11?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
VadimL (vadim-mbdsys) wrote :

I have the same problem with the same card/chipset on karmic koala 32-bit...
not only with skype but with gnome audacity and sound recorder too

Brian Buchanan (nighthawk-uk) wrote :

Yes this is reproducible with 0ubuntu11

Daniel T Chen (crimsun) wrote :

Can you reproduce this symptom using linux-alsa-driver-modules from ppa:ubuntu-audio-dev?

affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: Incomplete → Triaged
status: Triaged → Incomplete
Brian Buchanan (nighthawk-uk) wrote :

I installed the linux-alsa-driver-modules, restarted and tried recording in Skype, Audacity and Sound Recorder, the crackling still remains same as before (no change), it is worse in Skype and Sound Recorder than it is in Audacity, also the if I increase the recording volume the crackling is worse than if i record at a low volume then normalize the sound after.

Daniel T Chen (crimsun) wrote :

Is this also the case if you append "options snd-hda-intel position_fix=1" to /etc/modprobe.d/alsa-base.conf?

If, after a reboot, that resolves your symptom, please attach the output from running http://www.alsa-project.org/alsa-info.sh here.

Brian Buchanan (nighthawk-uk) wrote :

I added what you suggested but there is no change.
Would you still like me to run and attach the output from the alsa-info script?

Daniel T Chen (crimsun) wrote :

Not yet.

DGMcCloud (duncan-doyle) wrote :

I've got the same problem on a Dell D820 with a STAC92XX Analog (HDA Intel) card on both Karmic 64 and Lucid 64 (LiveCD). I tried installing the alsa-backports for Karmic, which didn't help. I tried adding the 'position_fix=1' option which didn't help. I tried various mixer settings using the default mixer, alsamixer and PulseAudio Volume Control. I updated the pulse audio system ppa:ubuntu-audio-dev repo, which didn't help either.

Recording audio via the internal monitor (for example recording audio which is played by Rythmbox) works perfect, but recording using the microphone (either using the built-in mic or using an external mic via the input-jack) results in crackling and popping recordings. This is very annoying when using programs like Skype.

I have the same problem on an acer Apire 7740 with the following hardware:
This crackling noise also occurs on recorded audio from Line In.

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC670 Analog [ALC670 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC670 Digital [ALC670 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 7: INTEL HDMI 1 [INTEL HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I am using the following driver from the Ubuntu Audio Dev team PPA

linux-also-driver-modules=2.6.32-21-generic

John

VadimL (vadim-mbdsys) wrote :

The problem is still present on lucid lynx 32 bit

navy (ivan-martinek) wrote :

Any prospects on solving the problem?

description: updated
Daniel T Chen (crimsun) wrote :

Guys/gals, we really need separate bug reports filed against alsa-driver if you aren't Brian Buchanan (the original reporter).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers