No sound on system with Pentium4 and Intel D865 chipset (release 9.10 with no updates)

Bug #489816 reported by Mark Overton on 2009-11-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

1. Neither system-sounds nor sounds from Adobe flashplayer nor from the system audio-test can be heard.

2. In Sound Preferences|Input, the level-bar moves when I speak. So input appears to work. (But not output).

3. In Sound Preferences|Output, I tried several connector settings. No sound with any setting.

4. Here's an lsmod:

snd_intel8x0 30168 2
snd_ac97_codec 101216 1 snd_intel8x0
ac97_bus 1532 1 snd_ac97_codec
snd_pcm_oss 37920 0
snd_mixer_oss 16028 1 snd_pcm_oss
snd_pcm 75296 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 2656 0
snd_seq_oss 28576 0
snd_seq_midi 6432 0
snd_rawmidi 22208 1 snd_seq_midi
snd_seq_midi_event 6940 2 snd_seq_oss,snd_seq_midi
snd_seq 50224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 22276 2 snd_pcm,snd_seq
snd_seq_device 6920 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: user 1377 F.... pulseaudio
 /dev/snd/pcmC0D0c: user 1377 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with AD1981B at irq 17'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 34
   Simple ctrls : 23
CheckboxCommand: alsa_record_playback
CheckboxDescription:
 Open the volume control application by right-clicking on the speaker icon in the panel and selecting "Sound Preferences". Select the "Input" tab and choose any alternate (non-default) device(s). Select the "Output" tab and choose any alternate (non-default) device(s). When you are done, click the Test button, then speak into the microphone. After a few seconds, your speech will be played back to you.

 Did you hear your speech played back?
CheckboxTest: alsa_record_playback_alternates
CurrentDmesg: [ 23.308015] eth0: no IPv6 routers present
Date: Sat Nov 28 18:39:07 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: alsa-driver
Tags: checkbox-bug
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:1426): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1426): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1544): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1528): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mark 1234 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with AD1985 at irq 17'
   Mixer name : 'Analog Devices AD1985'
   Components : 'AC97a:41445375'
   Controls : 50
   Simple ctrls : 35
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups:

dmi.bios.date: 03/07/2005
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BF86510A.86A.0075.P24.0503071605
dmi.board.name: D865GBF
dmi.board.vendor: Intel Corporation
dmi.board.version: AAC25843-406
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrBF86510A.86A.0075.P24.0503071605:bd03/07/2005:svn:pn:pvr:rvnIntelCorporation:rnD865GBF:rvrAAC25843-406:cvn:ct2:cvr:

Mark Overton (markoverton) wrote :
Mark Overton (markoverton) wrote :

The computer is an HP d530.

Brad Figg (brad-figg) wrote :

Hi Mark,

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 489816

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-required-logs needs-test-current-image no-sound-system
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Brad Figg (brad-figg) on 2010-03-31
tags: added: karmic
Doug Taylor (cymbolic) wrote :

Still a problem with 10.4 release on D865glc Motherboard, working in XP prior to install of 10.4

thx!

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Mark Overton (markoverton) wrote :

I am a programmer specializing in low-level software that controls hardware. So although I reported this bug, I would also like to help fix it if possible. Please email me if I can help.

There are millions of semi-legacy computers around which use the Intel 865 and 875 chipsets. According to motherboard reviews from back then, Linux audio worked. So there's probably some detail that broke in the meantime. Today, I tested both of these chipsets with Ubuntu 10.04 LTS, and still no audio on both, although lspci shows the AC'97 device and lsmod shows the various snd* drivers loaded.

Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.