sound playback problems with all players

Bug #474355 reported by beryl14 on 2009-11-04
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
griolo

Bug Description

In freshly Installed Karmic on a desktop computer the problems began when I tried to play an mp3 file with Rhytmbox. Rhytmbox has downloaded the needed codecs and other packages, after that the playback has a lot of problems.
The playback starts well, but abruptly the sound gets stumble in one's play, cracks, and at the same time the processor load is 100% . In this case of course after some time the sound stops or the system totally freezes. This situation happens again independently which program runs: audacious, qmmp, moc, exaile, amarok, mplayer, vlc, mpg123, mpg321, music123, etc.

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: albert 1602 F.... pulseaudio
 /dev/snd/controlC0: albert 1602 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'CMI8738'/'C-Media CMI8738 (model 37) at 0xb000, irq 16'
   Mixer name : 'CMedia PCI'
   Components : ''
   Controls : 43
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'UART'/'MPU-401 UART at 0x330, irq 10'
   Mixer name : ''
   Components : ''
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Card2.Amixer.info:
 Card hw:2 'U0x46d0x8a2'/'USB Device 0x46d:0x8a2 at usb-0000:00:0b.0-3, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08a2'
   Controls : 3
   Simple ctrls : 2
CheckboxCommand: alsa_record_playback
CheckboxDescription:
 Disconnect any external microphones that you have plugged in. Click the Test button, then speak into your internal microphone. After a few seconds, your speech will be played back to you.

 Hallotta a visszajátszott hangját?
CheckboxTest: alsa_record_playback_internal
Date: Wed Nov 4 16:48:58 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=hu_HU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: alsa-driver
Tags: checkbox-bug
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:1663): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1663): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1758): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1788): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

beryl14 (beryl14) wrote :
affects: ubuntu → alsa-driver (Ubuntu)
Daniel T Chen (crimsun) wrote :

Please log out of GNOME, log into a tty, rm -rf ~/.pulse*, log out, and log back into GNOME.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Download full text (8.0 KiB)

Hi,

I ingeminate what I wrote:

I did a clean install of Karmic (9.10) on my desktop computer after the new
version came out. After clean installation in the new system I got a lot of
problems accoring to sound playback.
My configuration is as follows:
- motherboard: Asus
- processor: Intel(R) Pentium(R) 4 CPU 3.20GHz, 3199.901 MHz
- memory: 1 GB/666 Mhz
- HDD-s: SAMSUNG HD161HJ 140GB
Maxtor 6L080LO 80 GB
- Graphic video card: GeForce 7300 GS
- Sound card: CMI8738

On my computer I have four partitions.
On 1. of them installed Linux Mint 7 Gloria (9.04) Hungarian
On 2. of them installed Linux Mint 7 Gloria (9.04) Russian
On 3. of them installed Kiwi Linux 9.04 with LXDE desktop
All three old systems use the same hardware and are working wery well,
without any problem, especially according to sound and video possibilities.

I made a clean install of the new version (9.10 Karmic) on the 4. partition.
Of course before installation I checked the md5sum of downloaded ISO file
(ubuntu-9.10-desktop-i386.iso), checked the burned CD two times. The burned
CD is without any defects and errors.

The istallation and the boot process went without problems.
The problems began when I tried to play an mp3 file with Rhytmbox. Rhytmbox
has downloaded the needed codecs and other packages, after that the playback
has a lot of problems.
The playback starts well, goes normally some time but abruptly the sound
gets stumble in one's play, cracks, and *at the same time the processor load
is 100% *. In this case of course after some time the sound stops or the
system totally freezes.
After that I downloaded and tested the sound playback with several
downloaded players as well.

The afore mentioned situation happens again independently which program
runs: audacious, qmmp, moc, exaile, amarok, mplayer, vlc, mpg123, mpg321,
music123, etc. At last I uninstalled all other players and leaved just
mplayer.

I tried a lot of setup variations in multimedia system setup: Pulseaudio,
Alsa, OSS, the result is the same. I uninstalled the pulseaudio totally, but
theese problems are abiding. I installed again the pulseaudio.

I did a comparison of the play of the same mp3 song in Linux Mint 7 Gloria
and in the newly installed Karmic with own mplayer.
The result was as follows:

In the Linux Mint 7 Gloria:

"albert@Mint ~ $ MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.20GHz (Family: 15, Model: 6, Stepping: 5)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing Israel - Hava Nagila Hava.mp3.
Audio file file format detected.
================================================== ========================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 160.0 kbit/11.34% (ratio: 20000->176400)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
================================================== ========================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no vi...

Read more...

Hi, I've this bug too.
I have the same sound card : Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10).
I have make a PulseAudio verbose log like https://wiki.ubuntu.com/PulseAudio/Log
What I have to give as other information to help find the problem ?

I can say that I have test playing music with onboard sound card activate and it is ok.

Fran (feelzenoize) wrote :

Same as Peterpan12, same card, same symptoms!

ulysse666 (ulysse-6-6-6) wrote :

Same as Peterpan12, same card, same symptoms!

Why this bug is incomplete ?

beryl14 (beryl14) wrote :
Download full text (3.3 KiB)

I don't know, why the bugreport is incomplete. I don't know exactly how to
do a proper bugreport, which application to use for this. There is an
application called system test, but it wants to test microphone but my
problem is with playback. After upgrade yesterday all problems left.

2010/1/19 Peterpan12 <email address hidden>

> Why this bug is incomplete ?
>
> --
> sound playback problems with all players
> https://bugs.launchpad.net/bugs/474355
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “alsa-driver” package in Ubuntu: Incomplete
>
> Bug description:
> In freshly Installed Karmic on a desktop computer the problems began when I
> tried to play an mp3 file with Rhytmbox. Rhytmbox has downloaded the needed
> codecs and other packages, after that the playback has a lot of problems.
> The playback starts well, but abruptly the sound gets stumble in one's
> play, cracks, and at the same time the processor load is 100% . In this case
> of course after some time the sound stops or the system totally freezes.
> This situation happens again independently which program runs: audacious,
> qmmp, moc, exaile, amarok, mplayer, vlc, mpg123, mpg321, music123, etc.
>
> ProblemType: Bug
> Architecture: i386
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC2: albert 1602 F.... pulseaudio
> /dev/snd/controlC0: albert 1602 F.... pulseaudio
> Card0.Amixer.info:
> Card hw:0 'CMI8738'/'C-Media CMI8738 (model 37) at 0xb000, irq 16'
> Mixer name : 'CMedia PCI'
> Components : ''
> Controls : 43
> Simple ctrls : 23
> Card1.Amixer.info:
> Card hw:1 'UART'/'MPU-401 UART at 0x330, irq 10'
> Mixer name : ''
> Components : ''
> Controls : 0
> Simple ctrls : 0
> Card1.Amixer.values:
>
> Card2.Amixer.info:
> Card hw:2 'U0x46d0x8a2'/'USB Device 0x46d:0x8a2 at usb-0000:00:0b.0-3,
> full speed'
> Mixer name : 'USB Mixer'
> Components : 'USB046d:08a2'
> Controls : 3
> Simple ctrls : 2
> CheckboxCommand: alsa_record_playback
> CheckboxDescription:
> Disconnect any external microphones that you have plugged in. Click the
> Test button, then speak into your internal microphone. After a few seconds,
> your speech will be played back to you.
>
> Hallotta a visszajátszott hangját?
> CheckboxTest: alsa_record_playback_internal
> Date: Wed Nov 4 16:48:58 2009
> DistroRelease: Ubuntu 9.10
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> NonfreeKernelModules: nvidia
> Package: alsa-base 1.0.20+dfsg-1ubuntu5
> PackageArchitecture: all
> ProcEnviron:
> SHELL=/bin/bash
> LANG=hu_HU.UTF-8
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: alsa-driver
> Tags: checkbox-bug
> Uname: Linux 2.6.31-14-generic i686
> XsessionErrors:
> (gnome-settings-daemon:1663): GLib-CRITICAL **: g_propagate_error:
> assertion `src != NULL' failed
> (gnome-settings-daemon:1663): GLib-CRITICAL **: g_propagate_error:
> assertion `src != NULL' failed
> (nautilus:1758): Eel-CRITICAL **: eel_preferences_get_boolean: assertion
> `preferences_is_initialized ()' failed
> (polkit-gnome-authentication-agent-1...

Read more...

Brad Figg (brad-figg) on 2010-03-31
tags: added: karmic
griolo (saragl7) on 2012-07-10
Changed in alsa-driver (Ubuntu):
assignee: nobody → griolo (saragl7)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.