Ubuntu

Playback sound is only audible starting at 50% on Dell Inspiron 1420

Reported by komputes on 2009-06-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alsa-base

Playback sound is only audible starting at 50% on Dell Inspiron 1420 running Ubuntu 9.04 Desktop x86. This is true with 9.04, 8.10, 8.04 (all x86).

BIOS version on both is (A00 05/23/2007)
Sound card on both is Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)
Codec on both is:
Sigmatel STAC9228
Conexant ID 2C06

Tested the following on two 1420 Laptops. The first running Ubuntu 9.04 x86 and the second running Ubuntu 9.04 AMD64. I find that I can start hearing audio at ~50% on both.

On Ubuntu 9.10 sound is audible at ~4% on the second.

Both of these volume levels refer to the "Master" level, all other important playback levels are at 100%.

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 5240 F.... mixer_applet2
                      ubuntu 6636 F.... gnome-volume-co
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe9fc000 irq 21'
   Mixer name : 'SigmaTel STAC9228'
   Components : 'HDA:83847616,102801f3,00100201 HDA:14f12c06,14f1000f,00100000'
   Controls : 37
   Simple ctrls : 24
CurrentDmesg:
 [ 112.045054] eth0: no IPv6 routers present
 [ 7615.564504] tg3: eth0: Link is down.
 [ 7639.674979] tg3: eth0: Link is up at 100 Mbps, full duplex.
 [ 7639.674986] tg3: eth0: Flow control is on for TX and on for RX.
DistroRelease: Ubuntu 9.04
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: alsa-driver
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
Sridhar (sridharan71) wrote :

Hi,

I do have the same problem with my Dell Inspiron 1420 (with Ubuntu 8.04, 8.10, 9.04).

sridhar

Changed in alsa-driver (Ubuntu):
assignee: nobody → Sridhar (sridharan71)
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I'm unassigning this bug report since I don't believe the assignee is actively working on fixing the bug report and that is when bugs should be assigned. For further information see http://wiki.ubuntu.com/Bugs/Assignment.

Changed in alsa-driver (Ubuntu):
assignee: Sridhar (sridharan71) → nobody

Hello,

Thanks for unassgining. I have no idea how it got assigned to me in the
first place.
 I came to know
about launchpad just today (and registered). If it was done by me, I must
have clicked some buttons accidentally.

thanks once again,

sridhar

On Mon, Jun 1, 2009 at 5:42 PM, Brian Murray <email address hidden> wrote:

> I'm unassigning this bug report since I don't believe the assignee is
> actively working on fixing the bug report and that is when bugs should
> be assigned. For further information see
> http://wiki.ubuntu.com/Bugs/Assignment.
>
> ** Changed in: alsa-driver (Ubuntu)
> Assignee: Sridhar (sridharan71) => (unassigned)
>
> --
> Playback sound is only audible starting at 50% on Dell Inspiron 1420
> https://bugs.launchpad.net/bugs/382488
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “alsa-driver” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: alsa-base
>
> Playback sound is only audible starting at 50% on Dell Inspiron 1420
> running Ubuntu 9.04 Desktop x86. This is true with 9.04, 8.10, 8.04 (all
> x86).
>
> BIOS version on both is (A00 05/23/2007)
> Sound card on both is Intel Corporation 82801H (ICH8 Family) HD Audio
> Controller [8086:284b] (rev 02)
> Codec on both is:
> Sigmatel STAC9228
> Conexant ID 2C06
>
> Tested the following on two 1420 Laptops. The first running Ubuntu 9.04 x86
> and the second running Ubuntu 9.04 AMD64. I find that I can start hearing
> audio at ~50% on the first (running Ubuntu 9.04 x86), and at ~4% on the
> second. Both of these volume levels refer to the "Master" level, all other
> playback levels are at 100%.
>

komputes (komputes) wrote :
komputes (komputes) on 2009-06-04
description: updated
komputes (komputes) wrote :

After further testing I find that this problem also affects a clean Ubuntu 9.04 64-bit. I have also tested Ubuntu 9.10 (still in development) where this no longer seems to be an issue. I have updated the bug description to represent these findings.

The difference in alsa is from 1.0.18 (in Ubuntu 9.04) to 1.0.20 (in Ubuntu 9.10). I am attaching the alsa-info output from Ubuntu 9.10, where volume is working correctly (it is audible at ~4%).

Brad Figg (brad-figg) wrote :

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 382488

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: jaunty low-volume
Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Sridhar (sridharan71) wrote :

 Yes, it is still a problem/issue.
Do you mean Ubuntu 10.04 is already available.? Anyway, I haven't upgraded
after 9.04.
However, due to my busy schedule (and to avoid possible mess-ups that
occured with my
laptop when I upgraded from 8.04 to 9.04), I am not likely to upgrade the
system and do
the tests until the end of May 2010.
I will test and respond then. Hope that will not be too late.

thanks,
sridhar

On Fri, Mar 12, 2010 at 6:00 PM, Brad Figg <email address hidden> wrote:

> This bug was reported a while ago and there hasn't been any activity in
> it recently. We were wondering if this is still an issue? Can you try
> with the latest development release of Ubuntu? ISO CD images are
> available from http://cdimage.ubuntu.com/releases/ .
>
> If it remains an issue, could you run the following command from a
> Terminal (Applications->Accessories->Terminal). It will automatically
> gather and attach updated debug information to this report.
>
> apport-collect -p alsa-base 382488
>
> Also, if you could test the latest upstream kernel available that would
> be great. It will allow additional upstream developers to examine the
> issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once
> you've tested the upstream kernel, please remove the 'needs-upstream-
> testing' tag. This can be done by clicking on the yellow pencil icon
> next to the tag located at the bottom of the bug description and
> deleting the 'needs-upstream-testing' text. Please let us know your
> results.
>
> Thanks in advance.
>
> ** Tags added: jaunty low-volume
>
> ** Changed in: alsa-driver (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Playback sound is only audible starting at 50% on Dell Inspiron 1420
> https://bugs.launchpad.net/bugs/382488
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “alsa-driver” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: alsa-base
>
> Playback sound is only audible starting at 50% on Dell Inspiron 1420
> running Ubuntu 9.04 Desktop x86. This is true with 9.04, 8.10, 8.04 (all
> x86).
>
> BIOS version on both is (A00 05/23/2007)
> Sound card on both is Intel Corporation 82801H (ICH8 Family) HD Audio
> Controller [8086:284b] (rev 02)
> Codec on both is:
> Sigmatel STAC9228
> Conexant ID 2C06
>
> Tested the following on two 1420 Laptops. The first running Ubuntu 9.04 x86
> and the second running Ubuntu 9.04 AMD64. I find that I can start hearing
> audio at ~50% on both.
>
> On Ubuntu 9.10 sound is audible at ~4% on the second.
>
> Both of these volume levels refer to the "Master" level, all other
> important playback levels are at 100%.
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/382488/+subscribe
>

komputes (komputes) wrote :

I have tested the Inspiron 1420 using Ubuntu 10.04 Alpha daily current and this issue seems to have been fixed.

Daniel T Chen (crimsun) on 2010-03-13
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers