Ubuntu

No audio recording on Thinkpad T61p, in any application

Reported by Chris Robison on 2009-04-29
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-media

I have been waiting for a version of Ubuntu with functioning audio on a Thinkpad T61p. I've just installed Jaunty, and it's still broken, out of the box.

I've found instructions for "activating" (?!!) the microphone, which don't exactly correspond to the dialogs and menus I see, and don't work.

I run Skype, Sound Recorder, or Audacity, and try to record. (With Skype, I perform a test call). The playback indicates nothing was recorded.

Interestingly, if I try recording in Sound Recorder, I get a fluctuation of the level meter at the bottom that shows that it's detecting sound. I tap on the microphone hole on the keyboard, and I get jumps in the meter. When I play the sound back, I get background hiss (lots of background hiss if the output volume is all the way up), and nothing else. How on earth am I getting a level response, but no recorded audio?

On any other application, there's no indication whatsoever that recording is functional at all.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-sound-recorder
Package: gnome-media 2.26.0-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-media
Uname: Linux 2.6.28-11-generic i686

affects: gnome-media (Ubuntu) → alsa-lib (Ubuntu)
dmoyne (daniel-moyne) wrote :

I experienced the same problem With Skype, Audacity and basically all applications that use a microphone ; here is a fix that does not make sense but works to re-establish microphone on jaunty 64 bits X2 with hda Intel built in motherboard sound device ; I am not even sure that once this setting is made it will be possible to recover it on next session :
- no way to use Kmix that has no microphone input (bug),
- Aumix shows a microphone setting but is not usable as a fix,
- The only possibility is to use the sound setting manager of Gnome called Gnome-volume-control (even possible under KDE) and apply this crazy setting (other ones of same madness may work) : I have attached a zip file for all settings of Gnome sound settings, skype and audacity as tested on my machine conducted with Ubuntu Alsa package and PulseAudio installed.

Sound worked perfectly well on pre-Jaunty ; apparently it is not an Alsa problem as even after re-compiling Alsa 1.0.20 It did not work any better for the microphone (maybe I did not complete the job) ; it may have to be with interface between PulseAudio and Alsa.

Hope this will be fixed on next update.
Regards.

dmoyne (daniel-moyne) wrote :

After further investigation I realized that I had to use "Configure channels" in Kmix to bring settings for microphone input ; now I can manage full sound settings with Kmix with microphone ; if I open gnome-volume-control record with microphone is muted so apparently now the conclusion is that gnome-volume-control is somehow problematic as whereas Kmix shows microphone input unmuted gnome-volume-control shows it muted.

Now with Kmix I have audacity and skype working.
Regards.

Daniel T Chen (crimsun) on 2010-01-31
Changed in alsa-lib (Ubuntu):
status: New → Invalid

I have just tried a new install of Ubuntu 9.10 on a T60p (same laptop, my original post is actually incorrect; this particular laptop is a T60p type 8744-J2U), and audio recording is still broken out of the box, and at this point the audio settings application is so different that no information online seems to even remotely apply. Everything still works fine under Windows, still broken in Ubuntu.

Noticed that an *external* microphone works just fine. The buit-in *internal* microphone is muted. It actually seems like the audio driver is not recognizing that there are two audio devices and is presenting the user with adjustment for only the one external port, not the internal one (the mic that 99.9% of users would use, since it seems rather silly to carry an external microphone for a laptop that already has one).

Has this bug been set as "Invalid" ? Why no explanation for this change? Did I enter the bug in the wrong place? Is there someone else I should bother about it? Is there any more information I can provide that would help?

Changed in alsa-lib (Ubuntu):
status: Invalid → New

FWIW, in the above comment, I should have said "there are two audio inputs", not "two audio devices" ... Incidentally, in alsamixer, I've noticed that when I switch to Capture settings, the microphone can't be adjusted at all. Very strange behavior.

Daniel T Chen (crimsun) wrote :

It isn't a -lib problem; migrated to the proper source package.

That said, you need to try both pulseaudio and linux-alsa-driver-modules-2.6.31-19-generic from ppa:ubuntu-audio-dev.

affects: alsa-lib (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Brad Figg (brad-figg) on 2010-03-11
tags: added: mic-int
Brad Figg (brad-figg) on 2010-03-31
tags: added: jaunty
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
smpwrflgard (smpwrflgard) wrote :

I have no audio recording, either with internal or external mics. I try "Skype" and no audio. since I've have installed Ubuntu I have not had any audio thru the mic inputs. can you tell me where in the code the mic input "could" be set in either "on" or "off" positions. Thank you, Paul

Changed in alsa-driver (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers