troubleshooting alsa sound

Bug #314635 reported by Sebastian Geiger on 2009-01-07
2
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

(Ubuntu 8.10)
I file this bug as an addition to a blueprint about sound troubleshooting:

Today I tried installing a realtek sound driver that i had downloaded from asus.com hoping it would enable me dolby sound features instead of only having the stereo sound that worked out of the box.
However the installer of the sound driver was broken due to alsaconf missing, yet it deleted my existing sound driver installation. I was searching for around 4 hours on google and IRC (because i didn't know where to start) until i came to this page:
https://help.ubuntu.com/community/SoundTroubleshooting#Manual Installation

With one command: sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2
I reinstalled my complete sound system. Now what I don't understand is why ubuntu does not come with a build in feature to reinstall sound drivers if the go missing, or at least a notice in the volume plugin.
The gnome volume plug-in just left me with a note about gsteamer being not correctly configured. I think the least thing that could help reduced time for troubleshooting would be to add a note in the volume plug-in error message that directs to the link above.

The best thing would be to include an application in System->Administration which can troubleshoot the whole sound system. I would be happy to give more information if needed or help testing on this issue.

Cheers,
Lanoxx

Daniel T Chen (crimsun) wrote :

Ubuntu (and now Debian) has not shipped alsaconf for years. It isn't maintained, and it is known to freeze machines.

dave b. (d+b) wrote :

Daniel. That is not true. I am on debian lenny from installing it from rc1 disks. I _have_ alsaconf installed.

Brad Figg (brad-figg) wrote :

Hi LanoxxthShaddow,

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 314635

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-required-logs needs-test-current-image
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Brad Figg (brad-figg) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers