Sound intermittently works / crackles & fades out

Bug #296251 reported by Chris Rosenhain on 2008-11-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Daniel T Chen

Bug Description

Binary package hint: alsa-base

http://www.alsa-project.org/db/?f=338145a8760d96951284224a4df45d7d2a4d0457

I have had this problem since 6.04, where the sound either just works through the headphones (not sure for how long) or it works through the speakers, and fades/crackles out.

It happens whether or not I'm using the sound card, for example I could have the typical login sound, not use the sound for 20 minutes afterwards, and then there is no sound.

It doesn't take more than about 3 minutes for the sound to fade and crackle out. I really don't know what causes it, but my guess is that it's a sound buffer problem. But once again - really unsure.

I have tried all the options suggested in the ALSA readme for the ALC883, 6stack-dig has given me the best results.

The link at the start should contain the information needed I think, but if you need anything else I'll gladly get it for you.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hydra 1563 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd8500000 irq 22'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,00001854,00100002 HDA:11c13026,11c13026,00100700'
   Controls : 34
   Simple ctrls : 21
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-20-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/13/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: RKYWSF28
dmi.board.name: ROCKY
dmi.board.vendor: LG Electronics
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LG Electronics
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrRKYWSF28:bd02/13/2007:svnLGElectronics:pnP1-KB11A:pvrNotApplicable:rvnLGElectronics:rnROCKY:rvrNotApplicable:cvnLGElectronics:ct10:cvrN/A:
dmi.product.name: P1-KB11A
dmi.product.version: Not Applicable
dmi.sys.vendor: LG Electronics

Hi anyone who is reading.

I have more information - the crackling/fading to nothing does not happen through the headphone socket at all, this only happens to the inbuilt speakers.

Matteo Settenvini (tchernobog) wrote :

Please paste here the part of "lspci -v" about your multimedia audio controller.
Have you tried following this guide?

https://wiki.ubuntu.com/DebuggingSoundProblems

Yes I have run through the DebuggingSoundProblems page without any luck.

Here are the results from "sudo lspci -v":

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: LG Electronics, Inc. Device 005f
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at d8500000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

I guess there are a few parts to this bug - one is that the device is incorrectly detected (have to manually set it to use 6stack-dig) and the other is the crackling when using the built in speakers on the laptop.

Thanks

Brad Figg (brad-figg) wrote :

Hi Chris,

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 296251

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-required-logs needs-test-current-image
Changed in alsa-driver (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hi again,

I've upgraded to 10.04 to see if this fixes the problem - it does not.

I have worked around it by adding the following to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=laptop-eapd enable=1 index=0

I'll submit the "apport-collect -p alsa-base 296251" now as well.

Daniel T Chen (crimsun) wrote :

Do you still need the model=laptop-eapd quirk if you use linux-alsa-driver-modules-$(uname -r) from ppa:ubuntu-audio-dev?

Hi there,

I installed linux-alsa-driver-modules-2.6.32-20-generic and removed the option line from alsa-base.conf, no sound.

I re-added the options starting with the index, then enable, and finally model. Only after adding the model option did the sound return.

Daniel T Chen (crimsun) wrote :

Ok, one final set of question: does jack sensing work as expected for both headphones/internal speakers and internal/external microphone(s)?

Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Low
assignee: nobody → Daniel T Chen (crimsun)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers