Audio out on x200/x200s dockingstation doesn't work

Bug #285834 reported by ccc1 on 2008-10-19
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Arch Linux)
Invalid
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

i have the following problem with my thinkpad x200 dockingstation:

When the audio out on the ultrabase is connected to external speakers the internal speaker on the utlrabase are muted, but there is no sound on the external speakers.

here sound information gathered by the alsa-info.sh script. (ultrabase was not connected when i ran the script, but that isn't necessary, is it?):

http://www.alsa-project.org/db/?f=f6bbc7fe7b0b728b9b67dc2394da3896ce83aae0

description: updated
Lukas (bobukas) wrote :

I can confirm this bug.
Attached output of alsa-info.sh (laptop connected to the Ultrabase)

S V N Vishwanathan (vishketan) wrote :

I can also confirm this bug on my Thinkpad X200 with a Ultrabase. The problem may be related to the dock module. I am attaching logs to help track down the problem.

S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :

I can also confirm that I am able to hear the system beep when using the docking station output. But I am not able to hear any output from rhythmbox.

Raido (raidoz) wrote :

I can also confirm this with X200s and Ultrabase.

Brit Butler (redline6561) wrote :

I'm also seeing the bug on ArchLinux. Pretty troublesome. Any thoughts on potential workarounds?

AK (andy12345) wrote :

I have the same problem with my new x200s too.

can someone of the ubuntu-audioteam set this bug to confirmed?
should we report this bug somewhere else, since nobody here seems to care?

ccc1

i have to bump this bug again.
where should we report this bug to get it fixed?

David Henningsson (diwic) wrote :

ccc1, if nobody seem to care here, it's possible you could get some support on a suitable alsa mailing list: http://www.alsa-project.org/main/index.php/Mailing-lists

Changed in alsa-driver:
status: New → Confirmed
Albert Sidelnik (sidelnik) wrote :

I noticed there was patch to fix this in the latest version of Alsa:

http://mailman.alsa-project.org/pipermail/alsa-devel/2009-February/014777.html

Albert Sidelnik (sidelnik) wrote :

I just compiled/installed the latest alsa-driver and alsa-lib snapshots, and I can verify that sound works with a X200s and ultrabase.

thats great news!
will this patch make it into jaunty?

Luka Renko (lure) wrote :

Can confirm on x200s.

I have traced down the patch in sound-2.6.git, so I hope some Ubuntu Kernel developer can cherry-pick this patch into Ubuntu Jaunty kernel:
http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=commit;h=27e089888fb1a3d1d13892262f9d522b03985044

Changed in linux:
status: Confirmed → Triaged
Luka Renko (lure) wrote :

I have built test package with above fix in my PPA and can confirm that both mic and headphone jack work properly on x200 UltraBase dock on my x200s. I really hope we can get this patch into Jaunty.

If anybody else would like to test my packages, it can get them here:
https://launchpad.net/~lure/+archive/ppa

Note: I have other test packages in the PPA, therefore I suggest that you only download appropriate linux-image. Direct links to images:

i386:
https://edge.launchpad.net/%7Elure/+archive/ppa/+files/linux-image-2.6.28-9-generic_2.6.28-9.31~lure1~lp285834_i386.deb

amd64:
https://edge.launchpad.net/%7Elure/+archive/ppa/+files/linux-image-2.6.28-9-generic_2.6.28-9.31~lure1~lp285834_amd64.deb

Please report back if it works or not for you.

Changed in linux:
assignee: nobody → ubuntu-audio

>Please report back if it works or not for you.

thanks a lot! the headphone jack on the ultrasbase is working fine now.

>[...] I hope some Ubuntu Kernel developer can cherry-pick this patch into Ubuntu Jaunty kernel:

yeah, please add this patch to the jaunty kernel.
only a few lines of code, won't brake anything and would make a lot ultrabase users happy. :)

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu):
assignee: ubuntu-audio → timg-tpi
importance: Undecided → Medium
milestone: none → ubuntu-9.04-beta
status: Triaged → Fix Committed

thanks a lot adding this fix to the jaunty kernel!

Tim Gardner (timg-tpi) wrote :

2.6.28-11.34

  * SAUCE: (drop after 2.6.28) ALSA: hda: add quirk for Lenovo X200 laptop
    dock

Changed in linux (Ubuntu Jaunty):
assignee: Tim Gardner (timg-tpi) → nobody
milestone: ubuntu-9.04-beta → none
status: Fix Committed → Fix Released
Changed in alsa-driver (Ubuntu Jaunty):
status: New → Invalid
Changed in alsa-driver (Arch Linux):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers