Settings in System Sounds aren't effective until reboot

Bug #262639 reported by Chih-Hsyuan Ho on 2008-08-29
2
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
Medium
Michael Terry
Ubuntu Netbook Remix Launcher
Medium
Michael Terry
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce the issue:

1. Preferences -> Sound Preferences -> Sounds -> enable Play system sounds.
2. Set up some actions with sounds
3. Test the sound effects ===> Not effective.
4. Reboot the system and settings in 2. takes effective.

Bill Filler (bfiller) wrote :

mterry, didn't we work around this issue once before?

Changed in netbook-remix-launcher:
assignee: nobody → mterry
importance: Undecided → Medium
status: New → Triaged
Michael Terry (mterry) wrote :

Fixed by patching libgnome to forget ESD cached sample IDs when the user changes sounds, and gnome-control-center to update a gconf key that libgnome and gnome-settings-daemon listen to, to refresh sound samples. These changes are suitable for main Ubuntu too. I'll attach patches.

Changed in netbook-remix:
assignee: nobody → mterry
importance: Undecided → Medium
status: New → Fix Committed
Changed in netbook-remix-launcher:
status: Triaged → Invalid
Bill Filler (bfiller) on 2008-09-05
Changed in netbook-remix:
milestone: none → 1.0
Bill Filler (bfiller) on 2008-09-22
Changed in netbook-remix:
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

Hi Chih,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 262639

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-required-logs needs-test-current-image
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers