Wayland dual monitor switch from 30Hz to 60Hz: High pitch audio double playback speed

Bug #1957819 reported by Troels Petersen
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I described the issue here first: https://bugs.launchpad.net/ubuntu/+bug/1957816

I am not sure it belongs here, but after the initial report i made an audio issue report with `ubuntu-bug -s audio`

copy/paste:

I have a desktop computer with a 60Hz 4K display connected through Display Port. The display is a ThinkVision X1 with built in audio. With the Display Port cable I am then able to output sound from the monitor and this works without any issues.
I have now added a 4K Samsung television through HDMI to the same GPU, which also allows me to do 4K at 60Hz, albeit only with Wayland. In Xorg I can only do 30Hz on the television while doing 60Hz on the ThinkVision X1. It is clear however, that when it is set to 60Hz in Wayland, the animation on the television is much more smooth.

The problem is that whenever I set the television to 60Hz, the playback of any sound is both high pitched and faster than normal. If I play a video in YouTube, the video appears to playback about twice as fast as normal and and very high pitched sound (everyone sounds like chipmunks). This is the case on the entire system (also when playing the video or any other sounds on the X1 display at 60Hz). Only if I set the refresh rate, on the television, to 30Hz again does everything play and sound normal again.
It is only the playback of media that is doubled in speed. Everything else (animations, mouse, etc.) is still behaving as normal.

If I change audio output to the ThinkVision X1 (or something else) at 60Hz while also being connected to the television at 60Hz, the audio stays high pitched and sped up.

If I unplug the main display, ThinkVision X1, then the playback of media on the television becomes normal.

I have tried with different +100 USD HDMI cables, that are all rated as HDMI 2.0 and the behavior stays the same.

My system is Ubuntu 20.04 LTS. I tried in a LiveUSB 21.10, but the behavior was the same.

I have an AMD Radeon VII GPU (Has 3x Display Port and 1x HDMI).

As mentioned I cannot test it in Xorg, but that is only because it does not allow me to set the refresh rate to 60Hz.

I am uncertain whether this is related to MESA, Pulseaudio or maybe Mutter/Wayland?

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 5.13.0-25.26~20.04.1-generic 5.13.19
Uname: Linux 5.13.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.21
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu Jan 13 17:24:02 2022
InstallationDate: Installed on 2020-05-03 (620 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:HDMI successful
Symptom_Card: Vega 20 HDMI Audio [Radeon VII] - HDA ATI HDMI
Symptom_Jack: Digital Out, HDMI
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: None of the above
Title: [System Product Name, ATI R6xx HDMI, Digital Out, HDMI] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/15/2021
dmi.bios.release: 5.13
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 8101
dmi.board.asset.tag: Default string
dmi.board.name: CROSSHAIR VI HERO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr8101:bd07/15/2021:br5.13:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnCROSSHAIRVIHERO:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:skuSKU:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Revision history for this message
Troels Petersen (thesleort) wrote :
description: updated
summary: - Wayland dual monitor 60Hz: High pitch audio and fast playback
+ Wayland dual monitor switch from 30Hz to 60Hz: High pitch audio double
+ playback speed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers