Ubuntu

alsamixer broken in hardy - intel hda

Reported by Jose Bernardo on 2008-02-16
142
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Baltix)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Medium
Unassigned

Bug Description

alsa-base - 1.0.16-0ubuntu1
uname -r - 2.6.24-8-generic
aplay -l:
**** Lista de Dispositivos de Hardware PLAYBACK ****
placa 0: Intel [HDA Intel], dispositivo 0: ALC861 Analog [ALC861 Analog]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
placa 0: Intel [HDA Intel], dispositivo 1: ALC861 Digital [ALC861 Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
placa 0: Intel [HDA Intel], dispositivo 6: Si3054 Modem [Si3054 Modem]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0

asoundconf list
Names of available sound cards:
Intel

The first symptoms I had is that kmix wouldn't move the sound sliders, and enabling/disabling inputs wouldn't work. Launching alsamixer at a command prompt gives this:
$ alsamixer

alsamixer: function snd_mixer_load failed: No such file or directory

Sound worked well in gutsy on the same laptop, a Fujistu Siemens Amilo Pi 1505, with Intel Centrino Duo chipset (945G)

Jose Bernardo (bernardo-bandos) wrote :

Could this be because alsa-base is at 1.0.16 and all the rest of alsa at 1.0.15-3?

polarch (deadflagblue) wrote :

I can confirm this after an upgrade from gutsy to hardy. My PC is a toshiba satellite A100-237. Sound worked perfectly in Gutsy . Furthermore there are no more inputs (no microphone), only outputs. Pulseaudio seems to be functioning properly, with proper level meters on playback, however no sound can be heard. KMix does not work. Media players (VLC , mplayer) are working as far as they are set to use the hardware device. Amarok with xine is unable to initialise audio devices. Alsamixer and amixer does not work:
kane@kane-laptop:~/muzik/testfiles$ alsamixer -c 0
alsamixer: function snd_mixer_load failed: No such file or directory

kane@kane-laptop:~/muzik/testfiles$ amixer -c 0
amixer: Mixer hw:0 load error: No such file or directory

and my specs:

alsa-base: Version: 1.0.16-0ubuntu2

kane@kane-laptop:~$ uname -a
Linux kane-laptop 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

kane@kane-laptop:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

kane@kane-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

kane@kane-laptop:~/muzik/testfiles$ asoundconf list
Names of available sound cards:
Intel

FriedChicken (domlyons) wrote :

Confirmed.
(also Fujitsu-Siemens Amilo Pi 1505, Kubuntu Hardy Heron with all recent updates)

Some additional information:

   $ amixer
amixer: Mixer default load error: No such file or directory

kmix only shows Master, Microphone, CD, PCM and Digital, all in the "output"-tab. There are no more channels available.
kmix shows the soundchip as Realtek ALC861.
Muting and moving of the sliders is possible but has got no effect.

   $ uname -a
Linux amilo 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

   $ lspci -v
[...]
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Fujitsu Siemens Computer GmbH Unknown device 10c7
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at f0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0
[...]

Changed in alsa-driver:
status: New → Confirmed
Martti Kuparinen (mk1970) wrote :

I see this also on Dell Latitude D630 running 8.04 with all the updates installed 5 min ago.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# lspci -vv | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Same thing here. I upgrade kernel of Gutsy with Hardy's 2.6.24-8 and problem appear. Then i compile and install new 1.0.16 alsa-driver, alsa-lib and alsa-utils but nothing changed. I have sound but i can't control it.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# lspci -vv | grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

polarch (deadflagblue) wrote :
Download full text (3.2 KiB)

Since the upgrade to Hardy, Pulseaudio sound server is not working properly. I am not sure if it is related to this bug, but again it seems to be using alsa-utils.c, can anybody else confirm that?
Pulseaudio seems to connect successfully and its clients are registered correctly, however no sound is coming out, as it cannot send the stream to the output.
---------------------------------------------------
kane@kane-laptop:~$ pulseaudio -v

I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
I: module-hal-detect.c: Trying capability alsa
W: alsa-util.c: Device (null) doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
W: alsa-util.c: Unable to load mixer: No such file or directory
I: sink.c: Created sink 0 "alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0" with sample spec "s16le 2ch 48000Hz"
I: source.c: Created source 0 "alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0").
W: alsa-util.c: Device (null) doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
W: alsa-util.c: Unable to load mixer: No such file or directory
I: source.c: Created source 1 "alsa_input.pci_8086_27d8_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_8086_27d8_sound_card_0_alsa_capture_0").
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
I: module.c: Loaded "module-x11-publish" (index: #9; argument: "").
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: main.c: Daemon startu...

Read more...

Martti Kuparinen (mk1970) wrote :

I haven't done anything except installing the latest updates (I did't even care to look what those were) but now this morning I had sound in youtube videos...

polarch (deadflagblue) wrote :

 This is not a no-sound bug for me, it is an alsa-utils bug. Since a player is set to use the alsa device directly sound is working fine; VLC, mplayer, JACK audio server or the flashplugin all have sound but there is the shortcoming of only one of them using the alsa device, so no sound from flashplugin if VLC is open. What is not working for me are the alsa-utils described above, pulseaudio which can take care of the software mixing and xine engine (and amarok). Probably the last two also use some pf the alsa-utils.

Chris Halse Rogers (raof) wrote :

I also see this bug; I'm uploading the ALSA info as per DebuggingSoundProblems from the Wiki, since no one else seems to have done this. I'll also add an strace of alsamixer failing, on the off chance that's useful.

Chris Halse Rogers (raof) wrote :
Chris Halse Rogers (raof) wrote :

I don't think this is caused by a version mis-match. A quick and dirty merge of alsa-utils and alsa-lib 1.0.16 from Sid still exhibits this bug for me.

Daniel T Chen (crimsun) wrote :

Already fixed in alsa-source. Adding lum task.

Changed in alsa-driver:
status: Confirmed → Fix Released
Zenigata (drebon) wrote :

Hmm I have the same problem on hardy amd64 up to date. I saw a status flag set to fix released, is this true, or is there still some problem and need for further information ?

Regards

--
Z.

For me it is still broken, and I just updated my system. The symptoms haven't changed, alsamixer, amixer, kmix and kmix4 still broken.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
polarch (deadflagblue) wrote :

Still broken here, with latest updates:

alsa-base_1.0.16-0ubuntu4
alsa-utils_1.0.15-3ubuntu2
linux-sound-base_1.0.16-0ubuntu4
libasound2_1.0.15-3ubuntu4

Unfortunately, it is also still broken here (just updated).

FriedChicken (domlyons) wrote :

Also still broken here after Hardy Beta and last updates.

Output of alsa-info.sh: http://pastebin.ca/955590

Seems like this is a show-stopper which should be fixed before 8.04...

My alsa-info.sh output is to be found @ http://pastebin.ca/958648 from my Eee PC.

xRaich[o]²x (raichoo) wrote :

Confirmed. On Amilo 1505

lspci:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
alsamixer:
alsamixer: function snd_mixer_load failed: No such file or directory

Adna rim (adnarim) wrote :

Also here it's still unfixed:

[09:18:00]bash:~$ uname -a
Linux goldstein-laptop 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux
[09:18:03]bash:~$ alsamixer
alsamixer: function snd_mixer_load failed: No such file or directory

Could someone please change the bug-status from Fix-released to Confirmed or shall we open a new bug-report?

Dave Gilbert (ubuntu-treblig) wrote :

me-too

Toshiba Equium A100-306; used to need a model=auto on gutsy; that doesn't help on Hardy.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

symptom was initially left channel dead/very quiet - with model=auto they seem to be OK; but the mixer is confused over the channels - I can't find any that actually does volume; and the volume channel seems to be 100% or 0% (not that it makes any difference).

(Possibly related; during recover from hibernate I thought I heard an odd sound - can't really describe it)

FriedChicken (domlyons) wrote :

As "Adna rim" said the status for alsa-driver was set to "Fix Released". I don't think that's correct because it's assigned to nobody and importance is also unset.
Because I think that alsa-driver also is or could be affected I would say it should be "Confirmed".

Changed in alsa-driver:
status: Fix Released → Confirmed
JockeTF (jocketf) wrote :

I also still have this problem with my Fujitsu Siemens Amilo Pi 1505.

alsa-info.sh output: http://pastebin.ca/973832

It is possible for me to change volume by editing the the values of the attached asound.state file and loading it with
$ alsactl -F -f <file> restore

I'm also on a Pi 1505, and still stuck. And since it is now April and no test fix has been released yet, I'm afraid this bug will stay with Hardy...

Zenigata (drebon) wrote :

Well the trick of using an asound.state file seems to work, and using pulse audio allow one to set the volume of the pulse device using alsamixer. So this bug is probably going to be quite transparent to the typical user that is doing a fresh installation.

Anyway it is a bad thing to have in a lts, maybe it is due to the version mimatch between the different alsa component, but the fact is that one is able to change the mixer settings using the old asound.state file.

I use a file with all the outputs, not only one, that allow me to tweak my settings quite fine.

regards.

--
Z.

Leszek Trenkner (olaf-post) wrote :

I can confirm this bug on Hardy Beta AMD64 with all available updates (kernel 2.6.24-15), on Uniwill M31E. Alsa mixer is not available, and in avaliable mixers there is no HDA Intel (Alsa mixer), only Realtek ALC861 (OSS Mixer) for onboard audio. I cannot effectively set volume in GUI.

Running exactly same system booted with vanilla kernel 2.6.24-3 fixes these problems - so i think alsa modules in Hardy's kernel are somewhat broken.

JockeTF (jocketf) wrote :

Same thing here, there is no intel HDA ALSA device, only a Realtek ALC861 OSS mixer.

I tried installing libasound2* and alsautils 1.0.16 (compiled for debian unstable) and ran alsaconf, this did not solve the proble. However, while running alsaconf it told me about "being able to change volume using applications such as alsamixer or gamix" so I installed gamix and I was, using that, able to change my volume. Something which also might be worth pointing out it is that the "digital" mixer disapeared in gamix after I installed libasound2* and alsa-utils 1.0.15.

Confirming that gamix gives me access to my sound settings.

Keith Z-G (keithzg) wrote :

Confirmed here, also intel, blah blah (my laptop is a generic-brand, I don't have it bootable right now but I think we know by this point the specific hardware isn't entirely important). I'm thinking users not being able to control volume levels? Umm, "high" importance in my opinion.

caturn (bronnum-hansen) wrote :

I am not able to set volume levels in kmix because of this bug. Priority should be high.

Very long standing issue, any changes to have it fixed before Hardy goes gold?

Same problem here (amd64). Audio device is "nVidia Corporation MCP51 High Definition Audio (rev a2)" according to lspci -v.

Once solved the problem by compiling the alsa kernel module from the alsa source package, but this kernel module has been overwritten by the latest kernel updates.

As this seems to be somewhat independent of the hardware and affects important functionality, I also vote for heightening the priority.

flowerdealer (pixelcowboy79) wrote :

I also get the problem with my Dell Inspiron 9400, both in Kubuntu and Ubuntu. Sound control works for some functions and not in others. Also, startup sound is too loud and a bit distorted. I also think this is my biggest issue so far.

Ryan Rawdon (flieslikeabrick) wrote :

Confirmed again, on an ASUS Eee PC (4G Surf, though the model shouldn't matter). I've had this problem since shortly after I upgraded to hardy a month or two ago. It was working for a short period of time, but some set of updates broke it.

Francisco (franjesus) wrote :

This is already fixed http://people.ubuntu.com/~ogasawara/hardy-buglist.html

If you don't want for the updates to get uploaded to repositories just do:

sudo apt-get install module-assistant

module-assistant a-i alsa-source

reload the sound modules (or restart) and it should be working.

Adna rim (adnarim) wrote :

No this doesn't fix the problem.

Francisco (franjesus) wrote :

Well, it has fixed it for me. Did you reboot?

aplay -l:

 Asus F3JC**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC861 Digital [ALC861 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

alsamixer & kmix work fine now.

Adna rim (adnarim) wrote :

Yes, sorry I was wrong! This really fixed the problem! Thank you very much!

greets

Yep, building from source now amixer, alsamixer and kmix work. And I finally found kmilo is still broken...

31 comments hidden view all 111 comments
darkangel88 (tipat88) wrote :

Jose Bernardo:

I did exactly has you said and it works !! Only problem, after rebooting, I get to execute the exact same steps to get it to work again. Is there a way to make this fix permanent ? Thanks !

The fix should be permanent, only needing to rebuild alsa with a kernel update. That is, if you added the options line to /etc/modprobe.d/alsa-base. You can always try a "sudo depmod -ae" but that shouldn't change anything, as loading the module by hand works for you. Strange.

darkangel88 (tipat88) wrote :

Thanks for your quick answer Jose Bernardo.

Here's what I have done... don't know if I missed something but anyway, here's the steps :

sudo apt-get install module-assistant
sudo m-a a-i alsa-source

After that, I modified the file "/etc/modprobe.d/alsa-base" to add the following : "options snd-hda-intel model=3stack" at the bottom of the file, without removing anything.

Then, reboot the machine but still no sound. As soon as I do the "sudo alsa force-unload; sudo modprobe snd-hda-intel" I'm getting sound.. but after I restart the computer I have to do it again if I want sound !! I was thinking about executing a script that does those 2 commands but it sounds to me like a dirty fix.... there must be something I'm doing wrong here !

That is strange. What I can suggest is that you check the output of dmesg, both after rebooting and after resetting alsa. Check if there is anything different when loading the snd-hda-intel module. Also, check if there is a duplicate module somewhere under /usr/lib/modules. It was simpler before the ubuntu developers removed slocate in hardy, all you needed to do was "locate snd-hda-intel", right now you need to do a find or something similar.
Finally, check if there is another "option snd-hda-intel ..." entry either in /etc/modprobe.d/alsa-base or another file in /etc/modprobe.d - do "grep snd-hda-intel /etc/modprobe.d" and make sure the only output is the line you added to alsa-base.

Laurent Dinclaux (dreadlox) wrote :

I have Hardy with latest update. My ASUS F3JC can play sound but not record either using integrated microphone or plugged microphone.

Do I have to recompile alsa? Or a specific line in /etc/modprobe.d will do it (tried some with no success)?

uname -r
2.6.24-16-generic

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

$ aplay -l
**** Liste des PLAYBACK périphériques ****
carte 0: Intel [HDA Intel], périphérique 0 : ALC861 Analog [ALC861 Analog]
  Sous-périphériques: 0/1
  Sous-périphérique: #0: subdevice #0
carte 0: Intel [HDA Intel], périphérique 1 : ALC861 Digital [ALC861 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte 0: Intel [HDA Intel], périphérique 6 : Si3054 Modem [Si3054 Modem]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

$ asoundconf list
Names of available sound cards:
Intel

$ alsamixer

alsamixer: function snd_mixer_load failed: No such file or directory

Gabriel (misc-evotex) wrote :
Download full text (5.3 KiB)

I tried everything mentioned here, but my sound is still super low, and now it sound worse than before, like if the speakers are at there max (but they aren't, since the sound is super low).

I tried :

sudo apt-get install module-assistant
sudo m-a a-i alsa-source
sudo alsa force-unload; sudo modprobe snd-hda-intel

and still the same problem, then adding "options snd-hda-intel model=3stack" to my "/etc/modprobe.d/alsa-base"
and then running "sudo alsa force-unload; sudo modprobe snd-hda-intel" but I still have the same problem, I also tried these :

options snd-hda-intel model=3stack-dig
options snd-hda-intel model=auto

I also tried reinstalling all of my alsa related packages :

sudo aptitude reinstall alsa-base alsa-source alsa-utils libesd-alsa0 libpt-1.10.10-plugins-alsa libsox-fmt-alsa alsa-oss

but that didn't work either. Here is my info :

uname -a : Linux desktop-01 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC861 Digital [ALC861 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

(with "options snd-hda-intel model=auto" or "options snd-hda-intel model=3stack-dig" or without the option)

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

(with "options snd-hda-intel model=3stack")

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

cat /proc/asound/card0/codec#*|grep Codec
Codec: Realtek ALC861

ls /var/cache/apt/archives/ | grep alsa
alsa-base_1.0.16-0ubuntu4_all.deb
alsa-oss_1.0.15-1_i386.deb
alsa-source_1.0.16-0ubuntu4_all.deb
alsa-utils_1.0.15-3ubuntu2_i386.deb
libesd-alsa0_0.2.38-0ubuntu9_i386.deb
libpt-1.10.10-plugins-alsa_1.10.10-1ubuntu6_i386.deb
libsox-fmt-alsa_14.0.0-5_i386.deb

oh, and I no longer have "Master" after all of this, only "PCM" in my gnome volume applet, but if I do :

amixer I see it :

amixer
Simple mixer control 'Master',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 200 [78%] [-11.00dB]
  Front Right: Playback 200 [78%] [-11.00dB]
Simple mixer control 'Front',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Front Mic',0
  Capabilities: pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Mono: Capture [off]
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Surround',0
  Capabilities:...

Read more...

Fragipani (pfisterthomas) wrote :

I also had exactly the same problem like you guys.
I fixed it with just typing 4 commands. I hope it works for you:

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

After this you just have to restart your system. It should work now

strk (strk) wrote :

Same issue here, alsamixer complains and module-assistant gets to a failure to build the alsa modules :'(

Neodon (neodon+launchpad) wrote :

I have a Dell Dimension E520 with the following audio:

lspci -vv | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

I fixed the problem by installing the linux-ubuntu-modules package for my kernel (only the generic was installed and I was running the 386 kernel).

After installing that package, sudo alsa force-unload; sudo modprobe snd-hda-intel caused my sound to start working.

Pavel Novak (pavel-innuendo) wrote :

I tried these five steps what Fragipani wrote on 2008-05-19 but after this, sound doesn't play nohow. Is't possible to get rid these steps out back when sound played well only alsamixer didn't play?

mustik (a-bashlykov) wrote :

>I also had exactly the same problem like you guys.
>I fixed it with just typing 4 commands. I hope it works for you:

>sudo apt-get install module-assistant
>sudo m-a update
>sudo m-a prepare
>sudo m-a a-i alsa

>After this you just have to restart your system. It should work now

Yes, this wokrs

m-a -f get alsa-sources
m-a prepare,update alsa
m-a build,install alsa
reboot

After the restart alsamixer works

my configuration:
alex@linux:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
alex@linux:~# uname -a
Linux gutsy 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

Randy Noseworthy (thenose100) wrote :

Ok, so for me to fix my Headphone jack problem, with my Realtek ALC861-VD sound chip on my Toshiba Satellite A135-S4656 The following will put the beast right and the headphones will kill the speakers when a jack is plugged in?

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

OR

sudo m-a -f get alsa-sources
sudo m-a prepare,update alsa
sudo m-a build,install alsa

EricDHH (ericdhh) wrote :

Hello
i can fully confirm this bug on hardy with 3.6.24-17-386 kernel. No sound usable on the thinkpad t23 since upgrade to hardy.
But the described workaround fails while compiling. M-A hangs at stage 1 and ends minutes later with error, please take a look at the attached logfile.

Whats wrong here?

Bye
Eric

EricDHH (ericdhh) wrote :

Going nuts

everything works fine on amd64 (ALC888 HDA Chip like described above), only on i386 it's a total showstopper.

2.6.24-17-generic
eric@ingerimm:~/.mplayer$ more /proc/asound/card
card0/ cards
eric@ingerimm:~/.mplayer$ more /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe938000 irq 16

ii alsa-base 1.0.16-0ubuntu4 ALSA driver configuration files
ii alsa-oss 1.0.15-1 ALSA wrapper for OSS applications
ii alsa-utils 1.0.15-3ubuntu2 ALSA utilities

Bye
Eric

Well, it is still broken in 2.6.24-18 on i386. I still had to rebuild the alsa modules to have sound. As usual:

"sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa
sudo alsa force-unload
sudo depmod -ae
sudo modprobe snd-hda-intel"

funfrank (funfrank) wrote :

i have an alc861 codec.

installed hardy. no microphone.

added an snd-hda option, no sound.
removed snd-hda, got sound back, but still no mic.

i recompiled alsa following this post, and got the alsamixer for the first time, but still no mic.

added an snd-hda option.
no sound.

anybody have an idea why adding an snd-hda option shuts down my sound?

EricDHH (ericdhh) wrote :

Hello

since module assitant break the compile, i tried the old tripleset on the source. Configure runs well without complains, but make stop here.

  CC [M] /usr/src/modules/alsa-driver/drivers/opl4/yrw801.o
  LD [M] /usr/src/modules/alsa-driver/drivers/opl4/snd-opl4-lib.o
  LD [M] /usr/src/modules/alsa-driver/drivers/opl4/snd-opl4-synth.o
  CC [M] /usr/src/modules/alsa-driver/drivers/pcsp/pcsp.o
/usr/src/modules/alsa-driver/drivers/pcsp/pcsp.c: In Funktion »snd_pcsp_create«:
/usr/src/modules/alsa-driver/drivers/pcsp/pcsp.c:55: Fehler: »loops_per_jiffy« nicht deklariert (erste Benutzung in dieser Funktion)
/usr/src/modules/alsa-driver/drivers/pcsp/pcsp.c:55: Fehler: (Jeder nicht deklarierte Bezeichner wird nur einmal aufgeführt
/usr/src/modules/alsa-driver/drivers/pcsp/pcsp.c:55: Fehler: für jede Funktion in der er auftritt.)
make[4]: *** [/usr/src/modules/alsa-driver/drivers/pcsp/pcsp.o] Fehler 1
make[3]: *** [/usr/src/modules/alsa-driver/drivers/pcsp] Fehler 2
make[2]: *** [/usr/src/modules/alsa-driver/drivers] Fehler 2
make[1]: *** [_module_/usr/src/modules/alsa-driver] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-2.6.24-16-386'
make: *** [compile] Fehler 2

So i have no sound and no workaround to fix this problem. Are there other workarounds or do i have to format the notebook down to gutsy?

Bye
Eric

Baptiste (baptiste2050) wrote :

I've rebuild the alsa modules and now all seems to work fine. Thanks.

avenger (mrholfelner) wrote :

i have a toshiba satelite and i had audacity use alsa and i ran my microphone through a mixer then to my laptop
and i was able to record my voice by turning my volume on my mixer all the way up,the recording wasn't very loud so i think it's a problem with being able to configure the alsa mixer controls.

Cedric Girard (x-dark) wrote :

I've just done a fresh reinstall of Ubuntu 8.04 32 bits. The mixer wasn't working right even after all the updates. The rebuild of alsa modules fixed the problems as usually.

avenger (mrholfelner) wrote :

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

i tried this but when i restarted it i got no sound and it froze every time i tried to log in
but i did get logged in 2 times
once it stopped accepting input from the keyboard the 2nd i tired to reload it but then it froze

Ed Sirett (ed-makewrite) wrote :

Gutsy OK, upgrade Gutsy or load Hardy and sound breaks.
Since there is also no sound in Fedora 9 I strongly suspect this is a kernel problem.

My Hardware Medion Akira MD96640, Sound Intel ICH8.

Antonio (amla) wrote :

I'm having the same compiling error as Eric Wick above. Does anybody have a clue about what is happening here?

BTW, I don't know much about dependencies versioning but there is a version mismatch between alsa-base (1.0.16) and alsa-utils/tools (1.0.15). May this got something to do with alsamixer breakage?

EricDHH (ericdhh) wrote :

Now i download alsa-source (1.0.16-1.1) from debian, this package compiles well with M-A on ubuntu.

The ubuntu package wont compile like described above, reason unknown. So the bug is fixed by workaround now, but this is no really solution.

Bye
Eric

fed (fedhere) wrote :

is this still broken...? my asus s6f has the same problem: i've been keeping an eye on the thread but i see nothing new since mid-june...

FriedChicken (domlyons) wrote :

For me it's working on Intrepid Ibex.

For me it is also working in intrepid. I still have the "option" entry for snd-hda-intel in /etc/modprobe.d/options.

Maybe it's time to move to Intrepid, since hardy's been going on for good
now and this bug is getting pretty old without any changes (and pretty
long... and there are a couple of duplicates around). So it seems that it's
not gonna be fixed in hardy.
What I'd like to know is, in Intrepid, without any option or with
option=auto if you get any sound. Cause I hate all the bogus sliders that
option=3stack-dig or whatever produces for my onboard card, which has only
one input/output/CD and speakers... Also does the mic work? Cause mine is
not also that's probably an alsadriver problem for my realtek 861 chipset.
Another thing it does affect is the slmodem-daemon for alsa-modems, it
doesn't work till I upgrade the alsa-utils, but I'm gonna post a new bug
about that.

2008/7/17, Jose Bernardo <email address hidden>:
>
> For me it is also working in intrepid. I still have the "option" entry
> for snd-hda-intel in /etc/modprobe.d/options.
>
> --
> alsamixer broken in hardy - intel hda
> https://bugs.launchpad.net/bugs/192382
> You received this bug notification because you are a direct subscriber
> of the bug.
>

FriedChicken (domlyons) wrote :

It worked without a "option" entry, but I didn't test the microphone till
now.

Still no mike (and also alc861). Sound ouptut works without a "option"entry, though. Unfortunately I have no way to test the digital output.

Brian Harkness (maestro-bwh) wrote :

Using this worked most easily for me.

 Jose Bernardo wrote on 2008-05-04: (permalink)

Did you add "options snd-hda-intel model=3stack-dig" to /etc/modprobe.d/alsa-base ? After that do a "sudo alsa force-unload; sudo modprobe snd-hda-intel" and you should have sound and kmix. Only the "master" channel will be useless.

fed (fedhere) wrote :

thanks, i have a kmix now. however i was crossing my finger for alsamix... basically with kmix now i can mute and change the left-right balance, but that is about it....

johnny (jan-staniek) wrote :

Hi,
Amilo PI1505, ALC 861
I've recompiled alsa from a snapshot today and all works fine.
Module options: index=0 enable_msi=0 position_fix=1 model=3stack
The micro is being seen as "Front Microphone". No problems with skype or other recording software.
Ubuntu Kernel Team: Is it so difficult to create a package which resolves our problems ??
I never had these under Debian :-|

Bruce H. McCosar (bmccosar) wrote :

Greetings, everyone. I'm new to Launchpad, so I hope I'm not doing something incorrectly here.

I have a decent amount of experience with Linux, going back to my original Debian distro. I've custom compiled kernels before, and even built Linux from Scratch.

I switched to Ubuntu because of the amount of time I was spending configuring and reconfiguring audio. The ubuntu-studios packages fixed a lot of that.

Unfortunately, today, I'm back to square one. I have a new computer (my old one died recently), an HP Pavilion m8530f (amd 64, 5Gb mem). The sound card seems to be an intel hda with the ALC883 chip above.

I have followed many of the recommendations above, but the result is always the same -- the sound works, but is massively clipped, and echoes as if fifteen different processes were sending sound to the card at once. That is, if I play a sound file of a single tone, for example "aaaahhh", it sounds like "AACK!zzztAACK!zzt!AACK!zzzt!aack!zz!aack!zz!aak!" The output is choppy, I guess you could say.

Following available directions, I custom compiled the alsa modules on a testbed partition (/dev/sda2, not my main Ubuntu, but one I use to try out dumb things before I blow up the system I rely on). Despite successful compilation, install, reboot, and lsmod analysis, the sound still did exactly the same thing.

In the end, I gave up and bought an Edirol UA-4FX. (Thank you, usb_audio developers!)

Nevertheless, it's still a problem. I think I could get the latency on the system down to a bare minimum if I could use the on-board sound card.

Now. Since I've never done this before -- bug reporting here on Launchpad -- I'm kind of at square one. What do I report? What module information, hardware information, and so on do you need?

P.S. I've also installed Intrepid on my testbed partition in both the amd64 and i386 flavors (i386 is the current version, as of last night). Although everything else works faultlessly, the sound remains clobbered. A serious bug, since I'm a musician ;-)

Thanks for any help or advice you can give me.

polarch (deadflagblue) wrote :

@johnny

You mean a snapshot from alsa daily snapshots? or the new 1.0.17 release?
I'm thinking of trying the same though it annoys me that I'll bypass the
package management on something as basic as alsa..

Hi Guys,

Just wanted to let you know that beginning with the Intrepid Ibex 8.10 development cycle the linux-ubuntu-modules package actually merged with the linux kernel source package. Going forward any bug that would have been reported against linux-ubuntu-modules should now be reported against linux. I've gone ahead and opened the "linux" task for this report. However, it seems from Jose's comment - https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/192382/comments/98 this is no longer an issue for Intrepid. Since Jose is the original bug reporter I'm going to go ahead and mark this "Fix Released" for Intrepid. However, against Hardy I suspect this will not qualify for a Stable Release Update - http://www.ubuntu.com/testing. For anyone still experiencing issues or having different issues than what was originally reported, please open a new bug report. Thanks.

Changed in linux:
status: New → Fix Released
Changed in linux-ubuntu-modules-2.6.24:
status: Triaged → Won't Fix
Henrik Enblom (novus-enblom) wrote :

I'm not having this bug but stumbled on it when helping someone else, I haven't got time to read through all this, but I managed to get this error when playing with my own alsamixer (even thou my sound is working fine)

alsamixer -D hw:0 <- works as it should

alsamixer -D hw:1
alsamixer: function snd_ctl_open failed for hw:1: No such file or directory

perhaps there's just problems for some ppl trying to open a mixer for a non existent sound card.. where the defoult is stored I have no idea :) just thought it might help someone

satish (satishs85) wrote :

I am also facing the same problem... THE SYSTEM HANGS EVERY HALF AN HOUR...

Follwing is the syslog details:

Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Cannot find fallback mixer control "Mic".
Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Unable to load mixer: No such file or directory
Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 5 11:57:29 edcn24 pulseaudio[5881]: alsa-util.c: Unable to load mixer: No such file or directory

Changed in alsa-driver:
status: Confirmed → Invalid
Se6 (se6astien) wrote :

Hi,

I also have a ALC861 based integrated sound card:

lspci -vv | grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC861 Digital [ALC861 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The sound works ok, but not the mic input. (It can be heard in the speakers but I can not record it, or use it with skype).

I am eager to try:
sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

But in case it breaks the sound all together, I would like to know first how to reverse it if it does. Anyone knows the procedure?

Thanks,

Seb.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Leo (leoguglio22) on 2009-11-11
Changed in linux-ubuntu-modules-2.6.24 (Baltix):
status: New → Fix Released
Displaying first 40 and last 40 comments. View all 111 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers