Bug related to the new kernel version 5.3.0-42-generic

Bug #1868085 reported by Loic on 2020-03-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Hi all,

After an update of Ubuntu kernel (version 5.3.0-42-generic) I can't have sound any more. No soundcards are detected any I have a "dummy output" in the sound pannel in settings. Furthermore I can't resume from sleep anymore.

Output of ALSA Information script:

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Wed Mar 18 14:46:19 UTC 2020

!!Linux Distribution
!!------------------

Ubuntu 18.04.4 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 18.04.4 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.4 LTS" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" UBUNTU_CODENAME=bionic

!!DMI Information
!!---------------

Manufacturer: HP
Product Name: HP ZBook 15u G6
Product Version:
Firmware Version: R70 Ver. 01.03.04
Board Vendor: HP
Board Name: 8549

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/HPIC000C:00/status 15
/sys/bus/acpi/devices/HPQ6001:00/status 15
/sys/bus/acpi/devices/IFX0785:00/status 15
/sys/bus/acpi/devices/INT3400:00/status 15
/sys/bus/acpi/devices/INT3403:00/status 15
/sys/bus/acpi/devices/INT3403:01/status 15
/sys/bus/acpi/devices/INT340E:00/status 15
/sys/bus/acpi/devices/INT34BB:00/status 15
/sys/bus/acpi/devices/INT3F0D:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 15
/sys/bus/acpi/devices/LNXPOWER:02/status 1
/sys/bus/acpi/devices/LNXPOWER:03/status 1
/sys/bus/acpi/devices/LNXPOWER:05/status 1
/sys/bus/acpi/devices/LNXPOWER:06/status 1
/sys/bus/acpi/devices/LNXPOWER:07/status 1
/sys/bus/acpi/devices/LNXPOWER:08/status 1
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0B00:00/status 15
/sys/bus/acpi/devices/PNP0C02:00/status 3
/sys/bus/acpi/devices/PNP0C02:01/status 3
/sys/bus/acpi/devices/PNP0C02:05/status 3
/sys/bus/acpi/devices/PNP0C09:00/status 15
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0C:00/status 11
/sys/bus/acpi/devices/PRP00001:00/status 11
/sys/bus/acpi/devices/SYNA3092:00/status 15
/sys/bus/acpi/devices/USBC000:00/status 15
/sys/bus/acpi/devices/device:04/status 15
/sys/bus/acpi/devices/device:27/status 15
/sys/bus/acpi/devices/device:28/status 15
/sys/bus/acpi/devices/device:4c/status 15

!!Kernel Information
!!------------------

Kernel release: 5.3.0-42-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k5.3.0-42-generic
Library version: 1.1.3
Utilities version: 1.1.3

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Device [8086:9dc8] (rev 11)
 Subsystem: Hewlett-Packard Company Device [103c:8549]

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Mar 18 14:45 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Mar 18 14:44 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:270: no soundcards found...

ARECORD

arecord: device_list:270: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

ac97_bus
acpi_pad
acpi_thermal_rel
aes_x86_64
aesni_intel
amd_iommu_v2
amdgpu
autofs4
bluetooth
bnep
btbcm
btintel
btrtl
btusb
ccm
cfg80211
cmac
coretemp
crc32_pclmul
crct10dif_pclmul
cros_ec_core
cros_ec_ishtp
cryptd
crypto_simd
drm
drm_kms_helper
e1000e
ecc
ecdh_generic
fb_sys_fops
ghash_clmulni_intel
glue_helper
gpu_sched
hid
hid_generic
hid_multitouch
hid_sensor_als
hid_sensor_hub
hid_sensor_iio_common
hid_sensor_trigger
hp_wireless
hp_wmi
i2c_algo_bit
i2c_hid
i915
idma64
industrialio
industrialio_triggered_buffer
input_leds
int3400_thermal
int3403_thermal
int340x_thermal_zone
intel_cstate
intel_ish_ipc
intel_ishtp
intel_ishtp_hid
intel_ishtp_loader
intel_lpss
intel_lpss_pci
intel_pch_thermal
intel_powerclamp
intel_rapl_common
intel_rapl_msr
intel_rapl_perf
intel_soc_dts_iosf
intel_wmi_thunderbolt
ip_tables
irqbypass
iwlmvm
iwlwifi
joydev
kfifo_buf
kvm
kvm_intel
ledtrig_audio
libarc4
lp
mac80211
mac_hid
mc
mei
mei_hdcp
mei_me
nls_iso8859_1
nvme
nvme_core
parport
parport_pc
pinctrl_cannonlake
pinctrl_intel
ppdev
processor_thermal_device
psmouse
sch_fq_codel
serio_raw
snd
snd_compress
snd_hda_codec
snd_hda_codec_generic
snd_hda_codec_realtek
snd_hda_core
snd_hda_ext_core
snd_hda_intel
snd_hwdep
snd_intel_nhlt
snd_pcm
snd_pcm_dmaengine
snd_rawmidi
snd_seq
snd_seq_device
snd_seq_midi
snd_seq_midi_event
snd_soc_acpi
snd_soc_acpi_intel_match
snd_soc_core
snd_soc_dmic
snd_soc_hdac_hda
snd_soc_hdac_hdmi
snd_soc_skl
snd_soc_skl_hda_dsp
snd_soc_skl_ipc
snd_soc_skl_ssp_clk
snd_soc_sst_dsp
snd_soc_sst_ipc
snd_sof
snd_sof_intel_byt
snd_sof_intel_hda
snd_sof_intel_hda_common
snd_sof_intel_ipc
snd_sof_xtensa_dsp
snd_timer
sof_pci_dev
soundcore
sparse_keymap
syscopyarea
sysfillrect
sysimgblt
thunderbolt
ttm
typec
typec_ucsi
ucsi_acpi
uvcvideo
video
videobuf2_common
videobuf2_memops
videobuf2_v4l2
videobuf2_vmalloc
videodev
virt_dma
wmi
wmi_bmof
x86_pkg_temp_thermal
x_tables

!!ALSA/HDA dmesg
!!--------------

[ 0.283290] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.283291] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.283292] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
[ 7.939314] kfd kfd: skipped device 1002:6981, PCI rejects atomics
[ 7.948407] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[ 7.970493] audit: type=1400 audit(1584541914.692:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=646 comm="apparmor_parser"
--
[ 7.982308] hp_wmi: query 0x1b returned error 0x5
[ 7.983150] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake platform, aborting probe
[ 8.017315] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[ 8.089744] ATOM BIOS: SWBRT39678.001
--
[ 8.390546] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input20
[ 8.396287] snd_soc_skl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 8.410090] fbcon: i915drmfb (fb0) is primary device
--
[ 8.443044] hid-multitouch 0018:06CB:CD78.0002: input,hidraw0: I2C HID v1.00 Mouse [SYNA3092:00 06CB:CD78] on i2c-SYNA3092:00
[ 8.485902] HDMI HDA Codec ehdaudio0D2: Max dais supported: 3
[ 8.487038] snd_soc_skl 0000:00:1f.3: Direct firmware load for 9dc8-INTEL-CFL-ULT-538378241-tplg.bin failed with error -2
[ 8.487039] snd_soc_skl 0000:00:1f.3: tplg fw 9dc8-INTEL-CFL-ULT-538378241-tplg.bin load failed with -2, falling back to dfw_sst.bin
[ 8.487145] snd_soc_skl 0000:00:1f.3: Direct firmware load for dfw_sst.bin failed with error -2
[ 8.487146] snd_soc_skl 0000:00:1f.3: Fallback tplg fw dfw_sst.bin load failed with -2
[ 8.487147] snd_soc_skl 0000:00:1f.3: Failed to init topology!
[ 8.487148] snd_soc_skl 0000:00:1f.3: ASoC: failed to probe component -2
[ 8.487156] skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: failed to instantiate card -2
--
[ 311.331048] WARNING: CPU: 3 PID: 9416 at /build/linux-hwe-uR14Ux/linux-hwe-5.3.0/kernel/workqueue.c:3037 __flush_work 0x1cc/0x1e0
[ 311.331050] Modules linked in: ccm snd_hda_codec_realtek(-) snd_hda_codec_generic ledtrig_audio cmac snd_soc_skl_ssp_clk snd_soc_dmic bnep hid_multitouch mei_hdcp intel_rapl_msr sof_pci_dev snd_sof_intel_hda_common snd_sof_intel_hda snd_sof_intel_byt snd_sof_intel_ipc snd_sof snd_sof_xtensa_dsp x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm irqbypass snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_acpi_intel_match snd_soc_acpi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel snd_intel_nhlt snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_seq_midi nls_iso8859_1 aesni_intel snd_seq_midi_event snd_rawmidi aes_x86_64 crypto_simd cryptd glue_helper intel_cstate amdgpu intel_rapl_perf snd_seq snd_seq_device snd_timer snd input_leds iwlmvm joydev serio_raw mac80211 intel_wmi_thunderbolt uvcvideo hp_wmi sparse_keymap i915 btusb videobuf2_vmalloc btrtl
[ 311.331111] videobuf2_memops amd_iommu_v2 btbcm wmi_bmof videobuf2_v4l2 libarc4 soundcore gpu_sched btintel videobuf2_common ttm bluetooth videodev mc drm_kms_helper iwlwifi drm hid_sensor_als mei_me hid_sensor_trigger idma64 industrialio_triggered_buffer mei virt_dma kfifo_buf ecdh_generic hid_sensor_iio_common ecc i2c_algo_bit industrialio fb_sys_fops processor_thermal_device intel_lpss_pci syscopyarea cros_ec_ishtp sysfillrect cfg80211 cros_ec_core intel_rapl_common intel_pch_thermal sysimgblt intel_lpss ucsi_acpi intel_soc_dts_iosf typec_ucsi typec int3403_thermal int340x_thermal_zone mac_hid hp_wireless int3400_thermal acpi_thermal_rel acpi_pad sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_sensor_hub hid_generic intel_ishtp_loader intel_ishtp_hid nvme psmouse e1000e nvme_core thunderbolt intel_ish_ipc intel_ishtp i2c_hid hid wmi pinctrl_cannonlake video pinctrl_intel [last unloaded: snd_soc_hdac_hdmi]
[ 311.331176] CPU: 3 PID: 9416 Comm: modprobe Not tainted 5.3.0-42-generic #34~18.04.1-Ubuntu
--
[ 311.331232] cancel_delayed_work_sync 0x13/0x20
[ 311.331239] hdac_hda_dev_remove 0x19/0x20 [snd_soc_hdac_hda]
[ 311.331252] hda_codec_driver_remove 0x2b/0x70 [snd_hda_codec]
[ 311.331258] device_release_driver_internal 0xe0/0x1b0
--
[ 311.331272] driver_unregister 0x2c/0x40
[ 311.331283] hda_codec_driver_unregister 0xe/0x10 [snd_hda_codec]
[ 311.331297] realtek_driver_exit 0x10/0xcf0 [snd_hda_codec_realtek]
[ 311.331305] __x64_sys_delete_module 0x146/0x290
--
[ 311.331344] ---[ end trace 9a9dfdeb3b89c1cd ]---
[ 311.922944] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[ 311.932132] snd_soc_skl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 311.943201] skl_hda_dsp_generic skl_hda_dsp_generic: Unsupported HDAudio/iDisp configuration found
[ 311.943206] skl_hda_dsp_generic: probe of skl_hda_dsp_generic failed with error -22
--
[ 342.161735] amdgpu 0000:3a:00.0: GPU pci config reset
[ 807.814661] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake platform, aborting probe
[ 807.824617] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[ 807.833477] snd_soc_skl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 807.850083] skl_hda_dsp_generic skl_hda_dsp_generic: Unsupported HDAudio/iDisp configuration found
[ 807.850088] skl_hda_dsp_generic: probe of skl_hda_dsp_generic failed with error -22

Hui Wang (hui.wang) wrote :

5.3.0-43 is in -proposed now, please test -43 kernel.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Paolo Mainardi (paolomainardi) wrote :

I confirm the ACPI problems using the sof drivers starting from 5.3.0-40, is there something i can use to debug back from sleep issue ?

Loic (lquinet) wrote :

Hi all,

I resolved my problem thanks to this solution: https://www.linuxuprising.com/2018/06/fix-no-sound-dummy-output-issue-in.html .

I followed these instructions:

1. Edit /etc/modprobe.d/alsa-base.conf as root and add options snd-hda-intel dmic_detect=0
2. Edit /etc/modprobe.d/blacklist.conf as root and add blacklist snd_soc_skl at the end of the file
3. After making these changes, reboot your system.

Tested with 5.3.0-45-generic kernel.

Changed in alsa-driver (Ubuntu):
status: Incomplete → New
Si Dedman (si-dedman) wrote :

Thanks Loic, this worked for me on xubuntu 19.10 running kernel 5.3.0.59.53

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions