Gigabyte x570 Aorus Master with ALC1220 and ESS SABRE 9118 DAC Muted Front speakers 5.1

Bug #1861345 reported by Richard Anthony Horan on 2020-01-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 18.04.3 LTS
Kernel 5.5.0
pulseaudio:
  Installed: 1:11.1-1ubuntu7.4
X570 Aorus Master Motherboard. ALC1220 ESS Sabre sound.

I have surround 5.1 speakers and the Front Left and Right are Muted.
I have to unmute Headphones in alsamixer to hear sound from the front left and right speakers is the workaround.

This step should not be required for speakers 5.1 to work.
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.9
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: richard 2533 F.... pulseaudio
 /dev/snd/controlC1: richard 2533 F.... pulseaudio
 /dev/snd/controlC0: richard 2533 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2020-01-28 (2 days ago)
InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
MachineType: Gigabyte Technology Co., Ltd. X570 AORUS MASTER
Package: linux (not installed)
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-28-generic root=UUID=51fe9653-53b0-475f-836e-a1662c6d8b79 ro quiet splash amd_iommu=on vt.handoff=1
ProcVersionSignature: Ubuntu 5.3.0-28.30~18.04.1-generic 5.3.13
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-28-generic N/A
 linux-backports-modules-5.3.0-28-generic N/A
 linux-firmware 1.173.14
Tags: bionic
Uname: Linux 5.3.0-28-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirt lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/06/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F11
dmi.board.asset.tag: Default string
dmi.board.name: X570 AORUS MASTER
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: Default string
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF11:bd12/06/2019:svnGigabyteTechnologyCo.,Ltd.:pnX570AORUSMASTER:pvr-CF:rvnGigabyteTechnologyCo.,Ltd.:rnX570AORUSMASTER:rvrDefaultstring:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: Default string
dmi.product.name: X570 AORUS MASTER
dmi.product.sku: Default string
dmi.product.version: -CF
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

tags: added: bionic
affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1861345

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I have already tested it in the mainline kernel. I ran the command as told. Same problem persists in all kernels I have tried. Currently, tested on uname -r = 5.3.0-28-generic the mainline kernel for 18.04.3 LTS.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Sorry, I don't understand the difference between Kernels. I have the Ubuntu Kernel 5.5.1 installed from Ubuntu. Not the official Kernel from Kernel.org. I downgraded to the official kernel that works with 18.04 LTS that is installed by default for filling out this bug report. I am still uncertain with Ubuntu because have not been using it long as I have occasionally stopped using it because of hardware limitations with newer hardware.

So the mainline kernel from Kernel.org is not tested.

Kai-Heng Feng (kaihengfeng) wrote :

Can you please try kernel parameter "snd-hda-intel.model=dual-codecs"?

The kernel parameter "snd-hda-intel.model=dual-codecs" has no effect.

Kai-Heng Feng (kaihengfeng) wrote :

Please file an upstream bug at https://bugzilla.kernel.org/
Product: Drivers
Component: Sound(ALSA)

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

sudo alsactl store does not save the headphone volume so I have to re-adjust every boot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.