Microphone not detected Lenovo Yoga S940

Bug #1845797 reported by Daniele Dellafiore on 2019-09-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 19.10 as well as 19.04 do not detect the microphone in Lenovo Yoga S940

Attached the screen of gnome sound control panel.

Inxi output:

System: Host: ******** Kernel: 5.3.0-13-generic x86_64 bits: 64 Desktop: Gnome 3.34.0 Distro: Ubuntu 19.10 (Eoan Ermine)
Machine: Type: Laptop System: LENOVO product: 81Q7 v: Lenovo Yoga S940-14IWL serial: <root required>
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <root required> UEFI: LENOVO v: AKCN34WW date: 06/12/2019
CPU: Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP L2 cache: 8192 KiB
           Speed: 1161 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 1161 2: 1195 3: 1848 4: 976 5: 1041 6: 1209 7: 1061
           8: 2229
Audio: Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.3.0-13-generic
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: daniele 2239 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 19.10
InstallationDate: Installed on 2019-09-12 (17 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
MachineType: LENOVO 81Q7
Package: pulseaudio 1:13.0-1ubuntu1
PackageArchitecture: amd64
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-13-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-13-generic N/A
 linux-backports-modules-5.3.0-13-generic N/A
 linux-firmware 1.182
Tags: eoan
Uname: Linux 5.3.0-13-generic x86_64
UpgradeStatus: Upgraded to eoan on 2019-09-21 (8 days ago)
UserGroups: adm cdrom dip docker lpadmin microk8s plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 06/12/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: AKCN34WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Yoga S940-14IWL
dmi.modalias: dmi:bvnLENOVO:bvrAKCN34WW:bd06/12/2019:svnLENOVO:pn81Q7:pvrLenovoYogaS940-14IWL:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrLenovoYogaS940-14IWL:
dmi.product.family: Yoga S940-14IWL
dmi.product.name: 81Q7
dmi.product.sku: LENOVO_MT_81Q7_BU_idea_FM_Yoga S940-14IWL
dmi.product.version: Lenovo Yoga S940-14IWL
dmi.sys.vendor: LENOVO

Created attachment 282497
alsa-info.txt

It seems like this device has 5.1 speaker configuration: Front Left, Front Center, Front Left and LFE in soundbar placed in hinge; Rear Left and Rear Right on device bottom. Only Front Left and Front Right speakers are working (tested with 5.1.0-rc6). Remapping pin 0x17 to Dock Headphone enables Front Center (or LFE, not sure) speaker and also makes overall speaker volume higher but headphone jack volume lower so there's a trade in. Randomly messing with pins in hdaanalyzer wont help. I can provide any additional logs on request.

Created attachment 282499
`pactl list` output

Created attachment 282501
`fwts --all` results.log

There is also some discussion here about this: https://mailman.alsa-project.org/pipermail/alsa-devel/2018-November/142369.html

I wasn't able to figure out a suitable workaround for the time being, but hopefully someone more knowledgeable can.

Same problem here with that configuration (ALC298 + Dolby configuration), but with diferrent laptop model, Lenovo S940.

Alsa-info.sh log:

http://alsa-project.org/db/?f=701015751be757989bb93d70a9a06f7e89d64e24

Linux lnx 4.19.66-1-MANJARO #1 SMP PREEMPT Fri Aug 9 18:01:53 UTC 2019 x86_64 GNU/Lin

More logs:

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Cannon Point-LP High Definition Audio Controller [8086:9dc8] (rev 30)
card 0: PCH [HDA Intel PCH], device 0: ALC298 Analog [ALC298 Analog]
snd_hda_codec_hdmi 69632 1
snd_sof_intel_hda_common 73728 1 sof_pci_dev
snd_sof_intel_hda 20480 1 snd_sof_intel_hda_common
snd_sof 118784 4 snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc,sof_pci_dev
snd_hda_codec_realtek 126976 1
snd_hda_codec_generic 94208 1 snd_hda_codec_realtek
snd_soc_hdac_hda 24576 2 snd_sof_intel_hda_common,snd_soc_skl
ledtrig_audio 16384 2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_ext_core 36864 4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_soc_acpi_intel_match 28672 3 snd_sof_intel_hda_common,sof_pci_dev,snd_soc_skl
snd_soc_core 290816 4 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
snd_hda_intel 49152 8
snd_hda_codec 159744 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core 102400 10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hwdep 20480 1 snd_hda_codec
snd_pcm 139264 11 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd 110592 25 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm

Any ideas to solve this problem? Regards

tags: added: disco
tags: added: eoa
tags: added: eoan
removed: eoa

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1845797

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in pulseaudio (Ubuntu):
status: New → Confirmed

Same issue on a Lenovo Yoga S940, kernel 5.3.0-18-generic x86_64
Mic not working
Audio works but clearly not properly, volume is very low and feels like low-frequencies are not reproduced, as in "no subwoofer".

alsa-info -> http://alsa-project.org/db/?f=c74f7b1c3e266514faac4f90ec2f893a3bec1f98

Daniel van Vugt (vanvugt) wrote :

Yes, looks like the same audio chip. Same bug.

affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

Same issue on Lenovo Yoga C940, Ubuntu 19.10, kernel 5.3.0-23-generic x86_64. Mic not working, audio not working properly with missing speakers.

Alsa info -> http://alsa-project.org/db/?f=863a8059dba17f148fb2d3b5b1705d29bc900218

I have the same problem.
If someone tells me how to elicit the correct settings under Windows I can get them and try them out in Linux.
If someone tells me what possible settings might work under Linux (or tells me how to figure out what settings might work) I can try to find the right settings.

It seems that there are some I2S amplifiers on the path to speakers and the BIOS has only limited initialization. I will try to gather information for C930 from Lenovo, too.

I've got the same problem on a C940 with 5.4.3-050403-generic. Let me know if I can be of any help with details.

I was able to get sound working by adding `snd_hda_intel.dmic_detect=0` to grub command line, but still no microphone.

tags: removed: disco

This issue persists for me, on a C930 with 5.4.21. Adding `snd_hda_intel.dmic_detect=0` has no effect for me: there is sound, but only from the two front speakers. The rest of the speakers don't work.

Here's my alsa info, if it helps: http://alsa-project.org/db/?f=ab906a5a6eeeddc4926a6ad543c2d42d7a21ecdf

Let me know if there's a way I can help debug this.

This issue persists even after the latest (March 2020) BIOS update from Lenovo. I posted about this here on the Lenovo forums:

https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/After-latest-BIOS-update-audio-not-working-on-Yoga-C930/m-p/5009564

Is our only hope getting the Lenovo BIOS devs to release a fix? Can we fix this in the BIOS ourselves?

I rate the probability of ever hearing from Lenovo about this at around 0%.

Daniele Dellafiore (ildella) wrote :

I've recently upgraded to latest Lenovo Yoga S940, with Intel Core 7 10th gen.
With Focal Fossa, both audio and mic worked properly until a few days ago.

Now *sometimes* it loads with dummy audio and no mic at all.
Now it loaded with only audio and no mic.

It really seem random to me now.

There is this question that despite a different laptop, has a very similar config:
https://askubuntu.com/questions/1238563/no-sound-pulseaudio-ubuntu-20-04-but-sound-with-pulseaudio-uninstalled

In fact my outputs are:

5.4.0-31-generic

Codec: Realtek ALC298
Codec: Intel Icelake HDMI

00:1f.3 Multimedia audio controller: Intel Corporation Smart Sound Technology Audio Controller (rev 30)

**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC298 Analog [ALC298 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 12: HDMI 6 [HDMI 6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Finally:

$ pacmd list-cards
1 card(s) available.
    index: 0
 name: <alsa_card.pci-0000_00_1f.3>
 driver: <module-alsa-card.c>
 owner module: 7
 properties:
  alsa.card = "1"
  alsa.card_name = "HDA Intel PCH"
  alsa.long_card_name = "HDA Intel PCH at 0x6057170000 irq 164"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:1f.3"
  sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card1"
  device.bus = "pci"
  device.vendor.id = "8086"
  device.vendor.name = "Intel Corporation"
  device.product.id = "34c8"
  device.product.name = "Smart Sound Technology Audio Controller"
  device.form_factor = "internal"
  device.string = "1"
  device.description = "Built-in Audio"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"

Daniele Dellafiore (ildella) wrote :

New report generated and new bug reported here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1880766

As now is not mic not detected, is the whole card not detected.

Daniele Dellafiore (ildella) wrote :

I reverted to 5.4.0-29-generic from 5.4.0-31-generic and now sound and mic work ok.

Something in 5.4.0-31 which is the latest upgrade for Ubuntu 20.04, breaks stuff.

I can confirm that with all kernel versions shipped with Ubuntu 20.04 up to 5.4.0-29 but excluding 5.4.0-31, sound and mic work without problems on Lenovo S940

With all kernel versions shipped with Ubuntu 20.04 up to 5.4.0-29 but excluding 5.4.0-31, sound and mic work without problems on Lenovo S940 with Intel 10th gen.

The latest upgrade which is 5.4.0-31 breaks not only the mic but also the sound.

Kai-Heng Feng (kaihengfeng) wrote :

Can you please attach dmesg for both 5.4.0-29-generic and 5.4.0-31-generic? Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.