[HD-Audio Generic - HD-Audio Generic, playback] Bad quality 2.1 surround sound

Bug #1819567 reported by Antonio on 2019-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

using a (2010?) 2.1 surround Creative speaker but the sound seems to fall back to a generic stereo output with only left and right channels (using the green plug).

The subwoofer receives little sound and the left and right speakers receive the bulk of the sound. If I increase the sound level the bass gets almost muted. The Pulse Audio manager doesn't show also any 3rd channel (don't know if it was supposed to), only Left and Right.

It seems a problem with mixing, since the sound goes with the same level to the front left and right speakers and the subwoofer only gets a small part of it, and it gets worst as the sound level is increased on the hardware volume control since the speakers handle almost all sound ranges.

Tried to create Profiles and Mappings for an "analog-surround-21" and changed the LFE information on the usual config files, but nothing seems to work and I lack more deeply knowledge of how ALSA and Pulse Audio work to figure out how to implement a (up)mixing.

I Win7 the speakers worked great, but in the new MoBo and Ryzen CPU Win7 is no longer supported and I want to finally use Linux (X)Ubuntu.

This issue seems to have been tackled with previously here:
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1286021

-----

lsb_release -rd
Description: Ubuntu 18.04.2 LTS
Release: 18.04

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-46.49-generic 4.15.18
Uname: Linux 4.15.0-46-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: antonio 13557 F.... pulseaudio
 /dev/snd/controlC0: antonio 13557 F.... pulseaudio
CurrentDesktop: XFCE
Date: Tue Mar 12 02:06:24 2019
InstallationDate: Installed on 2019-01-10 (61 days ago)
InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: HD-Audio Generic - HD-Audio Generic
Symptom_Type: Volume slider, or mixer problems
Title: [HD-Audio Generic - HD-Audio Generic, playback] volume slider problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/19/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.10
dmi.board.name: B450M Pro4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.10:bd06/19/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnB450MPro4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Antonio (tonecas) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers