[Precision M4800, Realtek ALC3226, Green Headphone Out, Front] No sound at all

Bug #1786495 reported by Herminio on 2018-08-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I am head no sound from my headphone jack. Laptop speaker work fine. Tried 2 different headphones and still no sound. pavucontrol can see my headphone and I see the sound bar move but no sound comes out.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-30.32-generic 4.15.18
Uname: Linux 4.15.0-30-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: hhernandez 2083 F...m pulseaudio
 /dev/snd/controlC1: hhernandez 2083 F.... pulseaudio
 /dev/snd/controlC0: hhernandez 2083 F.... pulseaudio
CurrentDesktop: MATE
Date: Fri Aug 10 07:59:09 2018
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: hhernandez 2083 F.... pulseaudio
 /dev/snd/controlC0: hhernandez 2083 F.... pulseaudio
Symptom_Jack: Green Headphone Out, Front
Symptom_Type: No sound at all
Title: [Precision M4800, Realtek ALC3226, Green Headphone Out, Front] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/19/2015
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.name: 0V5GVY
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd05/19/2015:svnDellInc.:pnPrecisionM4800:pvr01:rvnDellInc.:rn0V5GVY:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Precision M4800
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Herminio (herminio-hernandezjr) wrote :
tnt1818 (tnt1818) wrote :

Try alsamixer, press F6 select HDA Intel PCH, then disable Auto-Mute. I attached my configuration on my M4800

Irek (monsoft) wrote :

I have this same issue with Dell M6800. It works sometimes and after reboot, it stop working.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Nic30 (nic30) wrote :

Same problem there, also Dell M4800, I am using latest ubuntu 18.10 and it was working until I installed latest nvidia-driver-418. I do not why. There is suspicious message in dmesg.
(If I uninstall the nvidia driver it is still not working and reinstalling of alsa-driver also did not help.)

[ 5.603947] resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000dc000-0x000dffff window]
[ 5.604084] caller os_map_kernel_space.part.9+0x84/0x90 [nvidia] mapping multiple BARs
[ 6.338946] resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000dc000-0x000dffff window]
[ 6.339056] caller os_map_kernel_space.part.9+0x84/0x90 [nvidia] mapping multiple BARs

It seems to me that everything is working just some GPIO actually does not enable the output. The system detects the headphones correctly.

Nic30 (nic30) wrote :

I just found the ultimate debug tool for Intel HDA, https://git.alsa-project.org/?p=alsa.git;a=tree;f=hda-analyzer;hb=HEAD and alsa-tools-gui maybe it will help someone

Nic30 (nic30) wrote :

I found the fix. It seems funny but it is really fault of nvidia-driver-xxx. It somehow modifies power settings of the system. I am using latest Ubuntu 19.04 with 5.0.0-11-generic kernel but exactly same problem did happen wit any previous Ubuntu version and also with recent versions of Fedora.

I added the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel enable_msi=1 enable=0,1 model=dell-headset-multi power_save=0 power_save_controller=N

# note that pulseaudio -k && sudo alsa force-reload was not sufficient I had to reboot system because the modules were in some wrong state and they did not unload successfully

1. the enable_msi=1 : interupt setting is there because there is no sound after suspend
2. enable=0,1 : I did disabled the intel hdmi, spdif (non PCM) sound cards because some programs just used the diferent card no matter what was selected in ubuntu desktop controls/alsa mixer and this was the most simple method to get it working (you can list your cards by aplay -l)
3. model=dell-headset-multi this is required otherwise you will hear only cracking if you play something
4. power_save=0 without this you will hear nothing or cracking

Note:
You may also need to run sudo apt-get install --reinstall dkms alsa-base pulseaudio to get the system in to initial state if you modified something recently.

Note:
Out of the box ubuntu installation worked just fine, but after reinstall of nvidia-driver-XXX (415->418) / kernel (if the nvidia driver is installed) the sound just stops working and there is no error msg anywhere (dmesg, syslog) and the output is seems to selected properly and the mute etc is set properly in alsamixer.
The problem is that the nvidia drivers somehow modifies the power settings and this breaks the audio.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers