[REGRESSION][chtrt5645 - chtrt5645, playback] libasound2 update broke sound

Bug #1772891 reported by Taddeo Manzi on 2018-05-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading libasound2, libasound-data, libasound-dev with the update of this morning, speakers result as "unplugged" and headphones result as "plugged" and do not work even when really plugged. I've downgraded those packages but still no sound.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
Uname: Linux 4.17.0-999-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0c: steven 1360 F...m pulseaudio
 /dev/snd/pcmC0D0p: steven 1360 F...m pulseaudio
 /dev/snd/controlC0: steven 1360 F.... pulseaudio
CurrentDesktop: GNOME
Date: Wed May 23 12:46:46 2018
InstallationDate: Installed on 2017-01-12 (495 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
PackageArchitecture: all
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:chtrt5645 failed
Symptom_Card: Audio interno - chtrt5645
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0c: steven 1360 F...m pulseaudio
 /dev/snd/pcmC0D0p: steven 1360 F...m pulseaudio
 /dev/snd/controlC0: steven 1360 F.... pulseaudio
Symptom_Type: No sound at all
Title: [chtrt5645 - chtrt5645, playback] No sound at all
UpgradeStatus: Upgraded to bionic on 2018-04-06 (46 days ago)
dmi.bios.date: 09/04/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X205TA.212
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X205TA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX205TA.212:bd09/04/2015:svnASUSTeKCOMPUTERINC.:pnX205TA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX205TA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: X
dmi.product.name: X205TA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
mtime.conffile..etc.modprobe.d.alsa-base.conf: 2018-02-16T15:02:32.152615

Taddeo Manzi (sinistristradali) wrote :
Taddeo Manzi (sinistristradali) wrote :

Solved with
sudo wget https://raw.githubusercontent.com/plbossart/UCM/master/chtrt5645/HiFi.conf -O /usr/share/alsa/ucm/chtrt5645/HiFi.conf
Why does not ubuntu team just use this file for alsa-data?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers