Ubuntu 18.04 No audio from speakers. Headphones working. Surface Pro 3

Bug #1770429 reported by Carlos Roque on 2018-05-10
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I updated my Surface Pro 3 From Ubuntu 17.10 to Ubuntu 18.04 (did a clean install) and the only audio working was from the headphone jack.
I tried all these:
[troubleshooting guide](https://help.ubuntu.com/community/SoundTroubleshootingProcedure)
[this answer](https://askubuntu.com/questions/117842/no-sound-from-speakers-but-headphones-work)
[another answer](https://askubuntu.com/questions/829520/ubuntu-16-04-no-sound-from-speakers-only-headphones-working)

I went back and tested the live CD and even the live cd has no audio through the speakers. so this must be related to 18.04. I never had sound issues before and under windows audio still works correctly.

here is my alsa iformation http://www.alsa-project.org/db/?f=8bf135db52610a603014779ef24041a491c8a32d

and here is how I fixed it:

renaming /etc/modprobe.d/alsa-base.conf to /etc/modprobe.d/alsa-base.bk , then rebooting the computer fixed the my speaker sound issue.

I then restored line by line in to /etc/modprobe.d/alsa-base.conf, rebooting between restored lines, until all lines were back.... and ... it still worked!
so I restored the original /etc/modprobe.d/alsa-base.conf and rebooted the computer and everything was still working....
so I am not sure what the problem was but is now fixed.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
Uname: Linux 4.16.7-041607-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: carlosr 2267 F.... pulseaudio
 /dev/snd/controlC0: carlosr 2267 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Thu May 10 10:15:29 2018
InstallationDate: Installed on 2018-04-27 (13 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/23/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3.11.2350
dmi.board.asset.tag: 0
dmi.board.name: Surface Pro 3
dmi.board.vendor: Microsoft Corporation
dmi.board.version: 1
dmi.chassis.asset.tag: 0
dmi.chassis.type: 9
dmi.chassis.vendor: Microsoft Corporation
dmi.chassis.version: 1
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3.11.2350:bd01/23/2018:svnMicrosoftCorporation:pnSurfacePro3:pvr1:rvnMicrosoftCorporation:rnSurfacePro3:rvr1:cvnMicrosoftCorporation:ct9:cvr1:
dmi.product.family: Surface
dmi.product.name: Surface Pro 3
dmi.product.version: 1
dmi.sys.vendor: Microsoft Corporation
mtime.conffile..etc.modprobe.d.alsa-base.conf: 2018-05-09T14:04:13.313882

Carlos Roque (carlosrroque) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
ardour (ardouronerous) wrote :

TigrisAltaica from Ubuntu Forums has reported a similar issue on a HP Pavilion Laptop, unfortunately, renaming /etc/modprobe.d/alsa-base.conf to /etc/modprobe.d/alsa-base.bk didn't fix the issue.

Here's the report: https://ubuntuforums.org/showthread.php?t=2396039

EDEMPCO (edemco) wrote :

I've done a fresh upgrade to 18.04 and had a "no sound" problem that I haven't found a solution to. I found this and have been using it to get the sound connected. Can't find the source again, unfortunately. Thought it might help to point to the problem. Reinstalling Alsa and Pulse; starting and stopping both; eliminating one or the other; did not work. The following identifies something and places "Built-in Audio Analog Stereo" into the sound output tab in Settings.

Open Terminal and type: pactl load-module module-detect

Selmi (selmi) wrote :

same problem when i upgraded from 18.04 to 18.10
pactl load-module module-detect helped

Selmi (selmi) wrote :

sorry, i was wrong, didn't helped.
i had no sound,. but this added just 'dummy output'
i must do pulseaudio -k && sudo alsa force-reload after each boot to make sound work

EDEMPCO (edemco) wrote :

Following up on my post, where I did a fresh upgrade to 18.04 ...

Since then, I've done a few simalar, FRESH, upgrades without a problem with sound. So, I went back to my own system and tried a few things; I was tired of having to open a terminal and copy "pactl ..." I tried:
1. Purged Pulseaudio in Terminal with: sudo apt-get remove --purge pulseaudio
2. Rebooted and had sound, but no sound control in the system tray.
3. Reinstalled Pulseaudio with: sudo apt install pulseaudio
4. Immediately had no sound without using: pactl load-module module-detect
5. Repeated step 1 & 2; had sound

Knowing that Pulseaudio is only a control app for ALSA and wanting control in the system tray, I installed QasMixer (an ALSA GUI) with: sudo apt-get install qasmixer I think the problem is with Pulseaudio and the inability to get it configured correctly on some machines. There doesn't seem to be a way of troubleshooting or an easy fix.

Now I have both sound and a controller again.

Shinebayar G (shinebayar) wrote :

Hello, After I upgraded my Xubuntu 16.04 to Xubuntu 18.04 with fresh install, I've lost my sound.
My laptop model is HP Pavilion G6
Unfortunately none of work arounds worked for me :'(

Currently only headphones are working and speakers doesn't work.
As you see on the attachment, Audo Mixer (Volume Control) thinks it's working as intended. I see my speakers as option there and the bar is moving up down when I play music.

@edemco's or @selmi's workaround didn't work for me as well as OP's too.

Someone please help me :(
Thank you.

brian mullan (bmullan) wrote :

Same problem ubuntu 18.04

ran pavucontrol and saw "line-out (unplugged)"

plug in my headphones and "line-out unplugged" changed to: line-out (plugged in)

brian mullan (bmullan) wrote :

more clues related to comment #9

if I run alsamixer I can toggle AUTO-MUTE from ENABLED to DISABLED and the SOUND SETTINGS
Choose a device for sound output switches between headphones output and Analog Stereo Output.

I did this 4-5 rapidly and now it seems that the SOUND SETTINGS Choose a device for sound output now appears to switch back/forth between headphones and Analog Stereo Out but when I plug in Headphones I hear audio from both speakers & headphones.

But as a temp workaround this is ok for me since if I use headphones I can turn off my speakers but if not using headphones (re not plugged in) my speakers work.

Mykyta Chkhaylo (nelaer) wrote :

Hi everyone :)
I've tried almost all guides (reinstalled ubuntu-18.04.2-desktop-amd64 3 times during my tries =_=). But nothing helped unfortunately.
After all I’ve just simply replaced /etc/modprobe.d/alsa-base.conf with the same I found in Puppy Linux (XenialPup64 7.5).

Also I've copied /etc/modprobe.d/alsa.conf from Puppy Linux directory to /etc/modprobe.d/ of Ubuntu and /etc/asound.state from Puppy Linux to /etc/ of Ubuntu, but I don't no whether it necessary or not. And I've modified /etc/pulse/default.pa and /etc/pulse/system.pa :

### Automatically load driver modules depending on the hardware available
#.ifexists module-udev-detect.so
#load-module module-udev-detect
#.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
#.endif

MSI GP63 8RE, Ubuntu 18.04.2 LTS installed alongside Windows 10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers