[80X7, Realtek ALC236, Mic, Internal] Sound is distorted Lenovo Yoga 720

Bug #1769936 reported by Asif Youssuff on 2018-05-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Happy to do further testing, fresh install of Bionic. Discovered this when trying to do a video conference using the built in mic and was able to verify the issue by installing gnome-sound-recorder.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: asif 2213 F...m pulseaudio
 /dev/snd/controlC0: asif 2213 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Tue May 8 11:58:37 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-04-28 (9 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:PCH successful
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Mic, Internal
Symptom_PulseAudioRecordingTest: PulseAudio recording test through plughw:PCH successful
Symptom_Type: Digital clip or distortion, or "overdriven" sound
Title: [80X7, Realtek ALC236, Mic, Internal] Sound is distorted
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/08/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: 4MCN31WW(V2.03)
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 31
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo YOGA 720-15IKB
dmi.modalias: dmi:bvnLENOVO:bvr4MCN31WW(V2.03):bd03/08/2018:svnLENOVO:pn80X7:pvrLenovoYOGA720-15IKB:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct31:cvrLenovoYOGA720-15IKB:
dmi.product.family: YOGA 720-15IKB
dmi.product.name: 80X7
dmi.product.version: Lenovo YOGA 720-15IKB
dmi.sys.vendor: LENOVO

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :

FWIW, I tried the Position_fix quirking suggestions here: https://wiki.ubuntu.com/Audio/PositionReporting and didn't see any improvement.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
manfreed (manfreed) wrote :

I can confirm this. I tried to record myself speaking and it was as if everything were overamplified to the point that only distorted noise can be heard.

Lowering the mic volume helps. Setting it to "base" in puslseaudio volume control results in audible dialog with just a bit of noise in the background. Still, my voice felt too quiet, and the quality is not the best, so it's far from an ideal solution, just a workaround until a fix comes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers