[System Product Name, Realtek ALC1220, Pink Mic, Rear] Underruns, dropouts or crackling sound

Bug #1716654 reported by Gargoyle
This bug affects 18 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Won't Fix

Bug Description

Have checked under windows (same computer in dual-boot & same headset), and the sound is crystal clear, so 99% sure this is not a hardware problem.

Motherboard is ASUS Crosshair Hero 6.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
 /dev/snd/controlC3: paul 2587 F.... pulseaudio
 /dev/snd/controlC0: paul 2587 F.... pulseaudio
 /dev/snd/controlC1: paul 2587 F.... pulseaudio
 /dev/snd/controlC2: paul 2587 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Tue Sep 12 11:48:05 2017
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:Generic successful
Symptom_Card: HD-Audio Generic - HD-Audio Generic
Symptom_Jack: Pink Mic, Rear
Symptom_PulseAudioRecordingTest: PulseAudio recording test through plughw:Generic successful
Symptom_Type: Underruns, dropouts, or "crackling" sound
Title: [System Product Name, Realtek ALC1220, Pink Mic, Rear] Underruns, dropouts or crackling sound
UpgradeStatus: Upgraded to artful on 2017-08-31 (11 days ago)
dmi.bios.date: 07/28/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1501
dmi.board.asset.tag: Default string
dmi.board.name: CROSSHAIR VI HERO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1501:bd07/28/2017:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnCROSSHAIRVIHERO:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
mtime.conffile..etc.modprobe.d.alsa-base.conf: 2017-09-12T11:37:48.670242

Revision history for this message
Gargoyle (g-rgoyle) wrote :
Revision history for this message
Gargoyle (g-rgoyle) wrote :

Example audio created with "arecord -f cd".

From participants on various chat programs, the distortion is worse than it sounds here, so I'm trying to figure out if I can get a second test recorded via pulseaudio and not ALSA directly (I understand that is what arecord does).

Revision history for this message
Sebastian (sjug) wrote :

I've experienced this issue with a half dozen different A350/X370/X399 boards which all use AC1220. The mic noise is extraordinary and no amount of tweaking pulseaudio seems to resolve it. Has anyone had any success?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Revision history for this message
Stephen (d557charger) wrote :

I am also affected by this bug.

my system uses these codecs
/proc/asound/card0/codec#0:Codec: ATI R6xx HDMI
/proc/asound/card1/codec#0:Codec: Realtek ALC1220

on an Asus Prime x370a Pro motherboard with a ryzen 1600X.

This problem was first observed in Ubuntu 16.04.3, with kernel 4.4 and the 1201 bios for this board.

The board is now running 3401, and Ubuntu 17.10, in order to have access to a more recent kernel.

I installed the hwe update to 16.04 first, bringing my kernel version to 4.10 or 4.11, but it made the login screen and all terminals distorted and unreadable, so I was unable to test in that state - a state repeated after the clean install of 17.10, but which I found was due to ubuntu trying to set an ultra wide resolution to my 4k monitor, and being unable to display 4k i I corrected by switching from HDMI to Display Link Cable.

In the prior configuration I confirmed that the distortion occurred over the HDMI to my monitor speakers, as well as over the analog jack output. In my case, the distortion sounds identical to the recording made by Gargoyle above, and seemed to come and go in 16.04.3. using pulseaudio -k in a terminal gets rid of the problem for 10 minutes to several hours (or, perhaps it comes and goes away on its own and i miss it).

In addition, if it is of consequence, I had been running Ubuntu 16.04 since launch on a Gigabyte X58A-UD3R board's sound with no problems. After swapping the board to the Asus prime X370a pro 3 weeks ago, this problem appeared.

Revision history for this message
Stephen (d557charger) wrote :

I wanted to add to the above, while the crackling was heavily present for youtube, an mp3 played in clementine, and an mp4 video file in smplayer, I ran ubuntu-bug -s audio, and the test tones were all clear, except for a brief moment of static at the very last second. I ran the test twice to confirm, and I reconfirmed that the crackling status was still present in all other sources. As above, typing pulseaudio -k and waiting a few seconds before restarting audio sources fixes it for an indeterminate amount of time.

Revision history for this message
Dennis Mungai Lin.Jr. (brainiarc7) wrote :

Use this workaround which disables timer-based scheduling, which is the root cause of the glitchy audio:

PulseAudio uses timer-based audio scheduling instead of the traditional, interrupt-driven approach by default. This tends to expose issues in some ALSA drivers, such as this glitch (observed on a Clevo P751DM2-G under heavy load, for instance).

To turn timer-based scheduling off add tsched=0 in /etc/pulse/default.pa:

Edit /etc/pulse/default.pa:


load-module module-udev-detect tsched=0


Then restart the PulseAudio server:

 pulseaudio -k
 pulseaudio --start

Note that if you are using Intel's IOMMU and experience glitches and/or skips, add intel_iommu=igfx_off to your kernel command line and regenerate the grub configuration as shown:

sudo update-grub

And reboot to test your changes.

Revision history for this message
Le rems (rums) wrote :

I am also affected by sound crackling and sometime distortion since i swapped motherboard for an ASUS X470 prime pro. It is present permanently on microphone but sometimes affects other sources and applications.
The workaround above in the comments did not fix it for me.

Description: Ubuntu 18.04.1 LTS

Revision history for this message
Evan DeBiasse (4ih3r0) wrote :

I am affected by this bug. If I'm not mistaken all the individuals affected by this bug are using AMD Ryzen? I see that the codec appears to also be the AC1220. I'm using Asus x470-f gaming motherboard. I've tried ALL the fixes on arch wiki (this include the tsched=0 fix in the pulse audio config file) There is always someone in these threads that seems to think that should work and disregards the problem as it does seem to work for others with this issue. I'm wondering if it isn't a ryzen issue? I'm on a Ryzen 7 1700. I'm hoping to find a fix soon because this is quite annoying as I use voice chat regularly for a multitude of reasons.

Revision history for this message
Vlad Lipskiy (eswcvlad) wrote :

Same: ASUS Prime x470-pro, Ryzen 7 2700X, 4.18.0 kernel. Cracking sound on the mic/line-in on ALC1220. The only thing, that somewhat helped, is increasing the default-fragment-size-msec to 75+ at /etc/pulse/daemon.conf. But it is a workaround, and it doesn't remove the cracking fully.

Revision history for this message
Tyler Brown (condoulo) wrote :

This also impacts me. ASRockx 399 Taichi, AMD Threadripper 1950x, and this is impacting the mic/line in on the ALC1220 chipset. None of the workarounds worked on my end. I ended up having to use some USB dongle for audio input until this is resolved.

Revision history for this message
Mario Valenzuela (mariovalpa) wrote :

I have the same issue on AsRock x370 Taichi with Ryzen 1700. The rear audio output (green) hisses and crackles a lot on left channel, none of the workarounds worked. Tested on Ubuntu 17.10 and 18.04

Revision history for this message
Henk717 (henk717) wrote :

Having the same issue on the MSI X370 Gaming Pro Carbon, audio is fine but the microphone is having weird behavior that differs depending on configuration.

When audacity is launched it will trigger the bug that increases the recording speed to be insanely high pitched and fast. Prior to using audacity i will hear a robotic noise while speaking that is also present as a robotic echo.

Making use of the tsched=0 the robotic distortion is gone but replaced with severe crackling that over time becomes less severe but still very notable.

The following is an export of the alsa source.

    index: 1
 name: <alsa_input.pci-0000_21_00.3.analog-stereo>
 driver: <module-alsa-card.c>
 state: RUNNING
 suspend cause:
 priority: 9039
 volume: front-left: 32768 / 50% / -18,06 dB, front-right: 32768 / 50% / -18,06 dB
         balance 0,00
 base volume: 6554 / 10% / -60,00 dB
 volume steps: 65537
 muted: no
 current latency: 0,22 ms
 max rewind: 0 KiB
 sample spec: s16le 2ch 48000Hz
 channel map: front-left,front-right
 used by: 1
 linked by: 1
 configured latency: 2,50 ms; range is 0,50 .. 1837,33 ms
 card: 1 <alsa_card.pci-0000_21_00.3>
 module: 8
  alsa.resolution_bits = "16"
  device.api = "alsa"
  device.class = "sound"
  alsa.class = "generic"
  alsa.subclass = "generic-mix"
  alsa.name = "ALC1220 Analog"
  alsa.id = "ALC1220 Analog"
  alsa.subdevice = "0"
  alsa.subdevice_name = "subdevice #0"
  alsa.device = "0"
  alsa.card = "1"
  alsa.card_name = "HD-Audio Generic"
  alsa.long_card_name = "HD-Audio Generic at 0xfe900000 irq 64"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:21:00.3"
  sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:21:00.3/sound/card1"
  device.bus = "pci"
  device.vendor.id = "1022"
  device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
  device.product.id = "1457"
  device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
  device.string = "front:1"
  device.buffering.buffer_size = "352768"
  device.buffering.fragment_size = "176384"
  device.access_mode = "mmap+timer"
  device.profile.name = "analog-stereo"
  device.profile.description = "Analog Stereo"
  device.description = "Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo"
  alsa.mixer_name = "Realtek ALC1220"
  alsa.components = "HDA:10ec1220,1462da32,00100003"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"
  analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: yes)
    device.icon_name = "audio-input-microphone"
  analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
    device.icon_name = "audio-input-microphone"
  analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)

Very notable here is the buffer size which falls short of the required buffer size 44800 while in Windows the card can go up to 24-bit , 192000 without having to resort to a third party driver.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 17.10 (artful) reached end-of-life on July 19, 2018.

See this document for currently supported Ubuntu releases:

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

If you are using Ubuntu 18.04 then please open a new bug with more current system details.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Henk717 (henk717) wrote :

Daniel, over the span of this thread users have been experiencing this on 18.04, the topic contains information regarding users (Including myself) testing this on 18.04 and effects all distro's i know because of a bug in the current version of the snd_hda_intel driver.

The related open kernel issue can be found here : https://bugzilla.kernel.org/show_bug.cgi?id=195303 .
While i haven't tested for its presence in Ubuntu 18.10 the bug was still present in 18.04 earlier this week as confirmed by a discord friend who found my voice distorted in the way this bug describes. Using a newer kernel on 18.04 does not fix the issue as the issue has not yet been addressed on a driver / pulseaudio level.

Revision history for this message
Luca Osvaldo Mastromatteo (lukycrociato) wrote :

I'm getting the same on ALC892

Revision history for this message
Alexander Heuer (evilphish) wrote :

Same issue on 18.04 with ALC1220

Revision history for this message
João Ornelas (jpqornelas) wrote :

Exactly the same issue on 18.04. Why was this closed?

Revision history for this message
Benjamin Krippner (edenknight) wrote :

Same on

Audio device [0403]: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller [1022:780d] (rev 01)
ALC887-VD Analog [ALC887-VD Analog]

Distributor ID: neon
Description: KDE neon User Edition 5.17
Release: 18.04
Codename: bionic

Is it really only fixable via kernel? The Kernel Update i see has only had effect on some SFX Cards? The Kernel seems far away too. 5.3 is a while until i get there with the User Distro.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.