[HDA-Intel - HDA Intel PCH, playback] Playback problem

Bug #1630860 reported by wjl on 2016-10-06
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Debian)
New
Undecided
Unassigned

Bug Description

Lenovo Thinkpad P50 with docking station

Issues: Headphone jack on station not detected; no sound (works without docking station)
Issues: Sound via HDMI on station not detected; no sound (works without docking station)

Since all outputs are routed via the Thunderbolt chip, my guess is that it's related to the pin setup (lenovo-dock) in Alsa. Without the dock, everything works, headphone/mic jack on the P50 itself is hotplug (switches from speaker to headphones right away).

Screenshots (with and without docking station) attached.

Thanks and LG,
Wolfgang

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-38.57~14.04.1-generic 4.4.19
Uname: Linux 4.4.0-38-generic x86_64
NonfreeKernelModules: symap_custom_dkms_x86_64 nvidia
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: wjl 2943 F.... pulseaudio
 /dev/snd/controlC0: wjl 2943 F.... pulseaudio
CurrentDesktop: Unity
Date: Wed Oct 5 14:14:02 2016
InstallationDate: Installed on 2016-09-10 (24 days ago)
InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: HDA NVidia - HDA NVidia
Symptom_Type: Only some of outputs are working
Title: [HDA-Intel - HDA Intel PCH, playback] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/10/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: N1EET52W (1.26 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20EQS1EH0B
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN1EET52W(1.26):bd05/10/2016:svnLENOVO:pn20EQS1EH0B:pvrThinkPadP50:rvnLENOVO:rn20EQS1EH0B:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20EQS1EH0B
dmi.product.version: ThinkPad P50
dmi.sys.vendor: LENOVO
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2016-10-04T12:48:36.270399

wjl (wolfgang-lonien) wrote :
wjl (wolfgang-lonien) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Paul (paulnotpaul) wrote :

I also have this problem. I have a Lenovo P50 with the Lenovo Thinkpad Workstation Dock (40A50230US) and the sound does not work when I use the dock.

I have:

Ubuntu 14.04.5 LTS

4.4.0-38-generic

wjl (wolfgang-lonien) wrote :

Still valid with kernel 4.4.0-45-generic which I've got today.

Bob (caltinay) wrote :

Kernel 4.7.6-1 on Debian also affected.

Andreas Sperber (netcookie) wrote :

As Paul I have this issue with a Lenovo P50 and the Dock.

Kernel is 4.4.0-57-generic with a Ubuntu 16.04.1 LTS.

Does anybody know when to expect a solution to this problem? It's really annoying working under those conditions!

Bob (caltinay) wrote :

Still not working with kernel 4.8.15-2 on Debian.

coppermine (usptact) wrote :

Still not working with kernel 4.9.12 on Ubuntu 16.10. Lenovo Thinkpad P50

coppermine (usptact) wrote :

I added the following line to /etc/modules files (use sudo):

snd-hda-codec-realtek

And get the audio working, both speakers and headphones. When the OS starts, there is a noticeable crack in speakers....

Bob (caltinay) wrote :

coppermine, are you referring to the dock or the laptop headphone jack?
I am now on kernel 4.9.6-3 in Debian and the dock's jack is still not working.
I have checked and the snd-hda-codec-realtek module is in fact loaded and used.

Raz (razzz) wrote :

I'm having the same issue. Running Ubuntu 16.04.2 LTS with kernel 4.8.0-45-generic. Audio jack on laptop works fine, but the audio jack on dock doesn't work at all.

Stephen (enzed-rollins) wrote :

I'll throw my hat in as well as someone who is experiencing this issue.

I don't have many technical details to share, since I'm not sure what would be helpful (or, frankly, where to find it), but I can share some behavioral insight:

- While not docked, my laptop's speakers work fine. The headphone jack works fine. Plugging in my headphones toggles some sound settings, as observed when I have my speakers muted, but I plug in my headphones and my audio automatically unmutes (in pactl, I can observe the port switching between analog-output-speaker and analog-output-headphones when I do this)
- While docked, my laptop's speakers work fine, and the headphone jack on my laptop also works. The behavior is identical to the undocked behavior. However, when I plug my headphones into the dock, my laptop speakers go silent but no sound goes through my headphones. Additionally, my active port does not change, as observed in pactl

Mike Røntved (mikeyr) wrote :

Same issue as #13 running Ubuntu 16.04 with kernel 4.10.0-37-generic, no issues in Windows 10.

Bruno Katzengold (katzengold) wrote :

same here
ubuntu 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers