[MS-7349, Nvidia MCP67 HDMI, Digital Out, HDMI] Sound is distorted

Bug #1617118 reported by GeeMac on 2016-08-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

At first I did an upgrade from 14.04 LTS via the screen pop-up asking if I wanted to upgrade to 16.04, of course I clicked yes. First bad move.
I took a almost perfect HTPC Media system down to a almost unusable system. I thought it was due to a bad upgrade so I proceeded to do a new install via CD. Second bad move. I did not back up all my audio settings in 14.04.
I usually run a media program called Kodi(XBMC), but I haven't yet gotten to that since I tried Youtube and Netflix and found that the audio was fuzzy and distorted.
My system consists of an older computer with HDMI directly driving a Vizio 45 inch TV. Again, this has worked fine with 14.04. I do remember having to change my sample rate within Kodi, but not with any Browser video streaming such as Youtube, Netflix or any other paid premium channels that I have.

Now to the point of the matter.
Here is what is on my system now.
Linux HTPC 4.4.0-34-generic #53-Ubuntu SMP Wed Jul 27 16:06:39 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Dual core AMD cpu, 4Gig of ram

Here is a link to my Alsa information http://pastebin.com/3J7aT0BD
Here is another link to my Pulse daemon.conf http://pastebin.com/gXVeYK9T
The only thing I tried with the daemon.conf was removing the rem ; from the sample rate area and swapped the rates around. I tried the default settings first then swapped the 48000 with the 41000. No change. Apparently this is not the area to make the change. My findings some time back with the distortion witin Kodi, it was due to the sample rate being too high or too low driving the HDMI audio to the TV. Sorry I cannot remember which.
When in Kodi when I had this issue under 14.4, it was contained to Kodi only no other programs.
As of 16.04 this audio distortion is mainly all browser streaming. As of the last I checked both Firefox and Chrome has distorted audio. VLC and other media players seem to be okay.

Sorry for this long winded post.

I hope all this information will help in correcting this issue in 16.04..
Thanks
GEE

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
Uname: Linux 4.4.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gee 2932 F.... pulseaudio
 /dev/snd/controlC1: gee 2932 F.... pulseaudio
CurrentDesktop: GNOME-Flashback:Unity
Date: Thu Aug 25 21:56:20 2016
InstallationDate: Installed on 2016-08-20 (5 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:NVidia failed
Symptom_Card: Built-in Audio - HDA NVidia
Symptom_Jack: Digital Out, HDMI
Symptom_Type: Digital clip or distortion, or "overdriven" sound
Title: [MS-7349, Nvidia MCP67 HDMI, Digital Out, HDMI] Sound is distorted
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/19/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: CaptiveWorks CW-3000HD V2.37
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7349
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrCaptiveWorksCW-3000HDV2.37:bd03/19/2008:svnMSI:pnMS-7349:pvr1.0:rvnMSI:rnMS-7349:rvr1.0:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: MS-7349
dmi.product.version: 1.0
dmi.sys.vendor: MSI

GeeMac (htpc2013) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
GeeMac (htpc2013) wrote :

Small Update...

This may have helped a bit, but the distortion is still there. As stated above I swapped the 48000 with the 41000 after removing the rem(;) in daemon.conf.
Or it just could be my hearing.... ;)

Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers