[ICH - Intel 82801AA-ICH, playback] No sound at all

Bug #1605797 reported by ano on 2016-07-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ALSA driver
Fix Released
Unknown
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

New ubuntu install on 2016-07-22; latest version.
Running as virtualbox guest on latest OS X.
Sound card recognized on mac, but not on guest.
No sound in or out.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bobo 2690 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri Jul 22 19:00:19 2016
InstallationDate: Installed on 2016-07-22 (0 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:I82801AAICH failed
Symptom_Card: Built-in Audio - Intel 82801AA-ICH
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bobo 2690 F.... pulseaudio
Symptom_Type: No sound at all
Title: [ICH - Intel 82801AA-ICH, playback] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

ano (anoesisaudio) wrote :
ano (anoesisaudio) wrote :

OP here- forgot to mention, attempted use of ardour4, which found alsa to be stopped. Pressed start button & it did. Then it failed.

Tried youtube video in firefox. Failed there too.

Tried a dozen or so ideas from Internet forums to no avail.

Thank you for your attention.

Raymond (superquad-vortex2) wrote :

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/tree/sound/pci/intel8x0.c

static struct snd_pci_quirk intel8x0_clock_list[] = { SND_PCI_QUIRK(0x0e11, 0x008a, "AD1885", 41000), SND_PCI_QUIRK(0x1014, 0x0581, "AD1981B", 48000), SND_PCI_QUIRK(0x1028, 0x00be, "AD1885", 44100), SND_PCI_QUIRK(0x1028, 0x0177, "AD1980", 48000), SND_PCI_QUIRK(0x1028, 0x01ad, "AD1981B", 48000), SND_PCI_QUIRK(0x1043, 0x80f3, "AD1985", 48000), { } /* terminator */

The alsa driver hardcode to use 48000Hz for dell 0x1028,0x0177

But virtualbox emulated only support 44100Hz

Raymond (superquad-vortex2) wrote :

!!AC97 Codec information !!--------------------------- --startcollapse-- 0-0/0:
Analog Devices AD1980
PCI Subsys Vendor: 0x1028
PCI Subsys Device: 0x0177

ano (anoesisaudio) wrote :

Thank you Raymond for looking into this.

Another thing that may be helpful: I removed a working vdi with Ubuntu guest o/s (version 15.XXX) running on the same host (current OS X).

In that guest, which also ran in VirtualBox, I had no problems with sound at all & I had installed a few other softwares (Audacity, some python tools,etc.).

In the new guest, the only non-standard software is Ardour4 and there is no difference between the sound ability now and prior to installing that.

ano (anoesisaudio) wrote :

Update - there is more to this than just sound.

youtube videos are not playing at the right speed and are playing fast/choppy.

I installed the "restricted" codecs, but that has not helped.

Really mysterious since there can't be a small number of people running the same setup as this.

Mac, OS X 10.11.6
Virtual box 5.1.2 r108956
Ubuntu 16.04 LTS

Raymond (superquad-vortex2) wrote :

https://www.virtualbox.org/report/27?sort=modified&asc=0&page=1

It is because virtualbox change enumerated ac97 from stac9200 in virtualbox 4.x to ad1980 in virtualbox 5.x

Raymond (superquad-vortex2) wrote :

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1487168

The emulated ac97 codec is different from the real ac97 codecs on dell dimension 8400

ano (anoesisaudio) wrote :

Ok,that makes sense. I reinstalled an older version of VirtualBox and recreated the Ubuntu install and it works as expected now.

Having said that, I am testing Parallels as I am hoping to waste less time in the future (crosses fingers, toes, whatever). I hate to feed into their business model (subscription service), but VirtualBox's decisions appear to be only half thought through from my point of view.

Thank you very much Raymond. You are a good person.

Have a good day. :)

ano (anoesisaudio) wrote :

For anyone who sees this later, I opened ticket #15673 with VirtualBox. https://www.virtualbox.org/ticket/15673

Raymond (superquad-vortex2) wrote :

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1065812

The real ad1980 support 5.1

Extended ID : codec=0 rev=0 AMAP LDAC SDAC CDAC DSA=0 DRA VRA
Extended status : LDAC SDAC CDAC VRA
PCM front DAC : 48000Hz PCM
Surr DAC : 48000Hz
PCM LFE DAC : 48000Hz
PCM ADC : 44100Hz

but enumerated ad1980 support stereo

Extended ID : codec=0 rev=2 DSA=0 VRM VRA
Extended status : VRM VRA PCM
front DAC : 48000Hz
PCM ADC : 44100Hz
PCM MIC ADC : 48000Hz

Raymond (superquad-vortex2) wrote :

AD18XX configuration Unchained : 0x1000,0x0000,0x0000 Chained : 0x0000,0x0000,0x0000

The enumerated codec response incorrectly and appear as three codecs

AD18XX configuration Unchained : 0x1000,0x4000,0x2000 Chained : 0x0000,0x0000,0x0000

Raymond (superquad-vortex2) wrote :

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/intel8x0.c?id=2b3b5485aa96d18b0025dfb2bc92c824dc81a780

ALSA: intel8x0: implement ac97_clock whitelist
The AC97 clock detection is not accurate in some cases. This patch adds
an initial whitelist for audio devices gathered from RedHat's bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=441087

As a side effect, white-listing might speedup kernel booting (AC97 clock
measuring code is not activated).

Raymond (superquad-vortex2) wrote :

[ 6.559582] snd_intel8x0 0000:00:05.0: white list rate for 1028:0177 is 48000

Changed in alsa-driver:
status: Unknown → New
Raymond (superquad-vortex2) wrote :

static struct snd_pcm_hardware snd_intel8x0_stream = { .info = (SNDRV_PCM_INFO_MMAP | SNDRV_PCM_INFO_INTERLEAVED | SNDRV_PCM_INFO_BLOCK_TRANSFER | SNDRV_PCM_INFO_MMAP_VALID | SNDRV_PCM_INFO_PAUSE | SNDRV_PCM_INFO_RESUME), .formats = SNDRV_PCM_FMTBIT_S16_LE,
.rates = SNDRV_PCM_RATE_48000,
.rate_min = 48000,
.rate_max = 48000,
.channels_min = 2, .channels_max = 2,
.buffer_bytes_max = 128 * 1024, .period_bytes_min = 32, .period_bytes_max = 128 * 1024, .periods_min = 1, .periods_max = 1024, .fifo_size = 0, };

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Changed in alsa-driver:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.