[X555UA, Realtek ALC256, Mic, Internal] No sound at all

Bug #1596381 reported by seb on 2016-06-27
This bug affects 23 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
viorel zambreanu

Bug Description

Internal mic doesn't work for Asus X555UA, Codec: Realtek ALC256

speakers work, it's just the mic not working.

sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x5003
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x6003
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x5200
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x6200
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x503f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x603f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_POWER_STATE 0
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_POWER_STATE 0

8 lines make mic working until reboot.

thx a lot for

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
 /dev/snd/pcmC0D0c: ubuntu 1983 F...m pulseaudio
 /dev/snd/controlC0: ubuntu 1983 F.... pulseaudio
CasperVersion: 1.376
CurrentDesktop: Unity
Date: Sun Jun 26 23:56:46 2016
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:PCH failed
Symptom_AlsaRecordingTestStderr: a r e c o r d : p c m _ r e a d : 2 0 3 2 : r e a d e r r o r : I n p u t / o u t p u t e r r o r
Symptom_Card: Built-in Audio - HDA Intel PCH
 /dev/snd/pcmC0D0c: ubuntu 1983 F...m pulseaudio
 /dev/snd/controlC0: ubuntu 1983 F.... pulseaudio
Symptom_Jack: Mic, Internal
Symptom_Type: No sound at all
Title: [X555UA, Realtek ALC256, Mic, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/23/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X555UA.206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X555UA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX555UA.206:bd01/23/2016:svnASUSTeKCOMPUTERINC.:pnX555UA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX555UA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X555UA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

seb (seba-schopfer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium

Same problem here. Asus X555UB laptop with same sound card.

Orhun (doganorhun16) wrote :

Same problem for my Asus K555UB laptop same hardware

Igor (demchai) wrote :

Sane for my Asus X555UB , the codec is Realtek ALC256

Eren (edemirbas53) wrote :

Same for my Asus K555UB. I can't find the ALC256 codec on the HD-Audio-Models.txt.gz btw if it helps.

Eren (edemirbas53) wrote :

MY mistake, it's there sorry :B

Same problem ASUS E502SA + ALC256

Fix manual with:

"gksudo gedit /etc/modprobe.d/alsa-base.conf"

add bottom:
"options snd-hda-intel model=laptop-dmic"

And reboot.

"gksudo gedit /etc/modprobe.d/alsa-base.conf"
"options snd-hda-intel model=laptop-dmic"

Did not work on my X555U, which is the notebook model described in the title.

#8 comment solved my problem on Asus X555UB.

MIFAS (mmifas) wrote :

Yes, It's working. I'm using with Sound Switcher Indicator. But this should be fixed on upcoming release. Every time we can't go and edit these files. Please give us fixed update

Changed in alsa-driver (Ubuntu):
assignee: nobody → viorel zambreanu (viorelz)
Daniel Jose (danieldsj) wrote :

The workaround worked for me on an Asus ZenBook Max x541u.

whysea (whysea) wrote :

same problem on Asus R541UV, and workaround worked as well

Comment #8 worked for me too. Thank you! I'm on an Asus E402S with internal soundcard model Realtek ALC256. I'm running elementaryOS Loki.

Girasola (rocio-palacio) wrote :

Thanks #8, problem solved :-)

mohican (mohican) wrote :

Solution from post #8 works partially for me : Asus R556UB, with Linux Mint 18

Thanks to it I do now have input sound from webcam mic and output sound from internal speakers.
However I do not have output sound from external headphone.

To be noted : when rebooting from Windows 10 (dual-boot) sound is lost. To recover : shutdown and restart the GNU/Linux OS.

Kai Xu (xukai92) wrote :

Hi everyone,

How can I undo the 8 lines, i.e. make the hda-verb to the default setting?

Tried it on another ASUS model but doesn't work. Just want undo it.

Phil (x541u) wrote :

Hey Guys..noobie here so please be gentle.

I have a Asus X541U ... duel booting Ubuntu Studio 16.04 and Windows 10

Everything works fine in Windows....when i boot up Ubuntu and sign into Skype, I can't get the mic working. Same with other recording programs (Ie Audacity)
I need to run JACK and IDJC as well with it...

Please any help would be amazing...everyone around me thinks I'm speaking a different language


mohican (mohican) wrote :

Welcome Phil,
did you try the fix from post #8 ?
and rebooting from Linux (not from Windows) as I suggest in my post #16.

Yaroslav (slava-dr) wrote :

Hello everyone.
Notebook ASUS X541s, audio chipset ALC256, audio jack output combined with microphone input . Kubuntu 16.04.2 LTS. Have a sound output, but microphone not working.
Solution in post #8 help me bring to work built-in microphone. But when I'm switch to external headset microphone, it doesn't work, it say microphone (Unplugged).
How can I start using external headset microphone? (Headset tested itself on other PC and it's working fine).
Thanks for any help.

David Ford (djfordz-q) wrote :

use this in /etc/modprobe.d/alsa-base.conf
`options snd-hda-intel model=laptop-dmic,headset-mic`
and the internal mic and headset mic will work.

Yaroslav (slava-dr) wrote :

to David Ford (djfordz-q) thank for help, but it doesn't make external mic to work
I've setup option:
`options snd-hda-intel model=laptop-dmic,headset-mic`
and reboot notebook - doesn't help, internal working, external not.

Searching an internet, help to find a solution that works.
So then I've install "alsa-tools-gui" launch "HDAJackRetask", select codec ALC256,
checked "Show unconnected pins" then check pin ID: 0x19 and select "Microphone" then hit "Apply now".
Started pavucontrol for checks and it work.
Both of them built-in, and external headset microphone works now.
So launch "HDAJackRetask" and make a permanent change, hit "Install boot override"
After reboot it work for all users on notebook.

P.S. As for other models and codecs it may be other pins number in "HDAJackRetask" utility.

Artur0us (artur0us) on 2017-06-18
description: updated
kostyarin (k-i-r) wrote :

Me too ASUS X555UQ, ALC255.

MIFAS (mmifas) wrote :

This issue has been fixed on latest kernel version 4.12.

Hello I have a problem, my latop is an Asus450U has HDA Intel PCH, Chip: Realtek ALC256. I had a problem with the microphone and line No. 8 gave the solution to this, but I've found that does not recognize the two internal speakers, only works the right speaker. And in the same way does not recognize the two headphones, only recognizes the left. I have played with Alsamixer but no configuration has helped, nor the pavucontrol.

Johannes Winter (yova) wrote :

Followed slava-dr tipps, but didn't manage to get external mic working on asus x555ua.

Any more tips on how to connect "unconnected pins" ?

Install kernel 4.15.5

On Mar 2, 2018 7:54 PM, "Johannes Winter" <email address hidden>

> Followed slava-dr tipps, but didn't manage to get external mic working
> on asus x555ua.
> Any more tips on how to connect "unconnected pins" ?
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1596381
> Title:
> [X555UA, Realtek ALC256, Mic, Internal] No sound at all
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+
> bug/1596381/+subscriptions

I have the same problem on my Asus Zenbook UX430UA (Realtek ALC295) although I have "5.3.0-40-generic" linux kernel version with Ubuntu 18.04. Comment #8 solved my problem but with "options snd-hda-intel model=laptop-dmic" in my alsa conf, up and down volume don't change the speakers volume.

I can only mute the speakers with 0 volume, but I get the same volume level with 1% volume than the one I get with 100%

With "options snd-hda-intel model=auto" or "options snd-hda-intel model=alc295" I get the expected behaviour from the speakers but no record of the internal microphone. I have already tried combining auto/alc295 with laptop-dmic but I get the behaviour of the first option I write (like as it were alone)

I thought this was fixed, maybe I am doing something wrong.

I have the same problem on Asus Zenbook UX430UA (Realtek ALC295) in Ubuntu 18.04 with 5.3.0-40-generic linux kernel version.

Comment #8 fix's worked for me but now I get the same volume level from my laptop speakers with 1% volume level, than the one I get with 100% volume level. The only thing that I can change from volume controls is that with 0% volume level, the speakers are muted.

I have tried with "options snd-hda-intel model=auto,laptop-dmic" but I get the expected behaviour with model=auto (speakers works great but no audio recording from laptop microphone). With "options snd-hda-intel model=laptop-dmic,auto" I get the same behaviour that the one I get with "model=laptop-dmic" only (microphone working but volume control doing nothing).

I thought this was fixed, but maybe I'm doing something wrong.

I was able to solve the control volume thing but the root problem still there. If someone gets to this point I will show you my solution.

I realized (in alsamixer) that I was able to change the speakers volume controlling PCM device instead of Master one. So I searched about that and found that you can make pulseaudio to control another device. All the information is in here: https://askubuntu.com/questions/15069/how-do-i-change-the-way-ubuntu-adjusts-my-volume-mixer-levels

However, I think this should be fixed. Thank you for your help ^^

I have Asus ROG GX501VIK laptop with same issue.
Device: Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]

Solution from comment #8 worked like a charm.

Lenovo Ideapad 300 15Ibr - With Linux microphone work with strong noise and very hard to hear me. But with Windows 7 microphone worked perfect. I tried all of the solutions from this topic - nothing helps

I was able to fully fix the issue of the microphone not working on my UX430UA by doing this:

Original source linked in that forum post:

Huawei Matebook 13 with Arch Linux - when I add "options snd_hda_intel model=alc255-asus" as recommended in a forum posts above, headset is detected and works, but when I use external microphone only (without headphones) it is detected as headset anyway and I cannot talk to people and hear then at the same time.

On my ASUS Rog GL703VD-GC028T Notebook, I was able to use both microphone and sound adding the line
options snd-hda-intel model=laptop-dmic,headset-mic,auto
to /etc/modprobe.d

and modifing the line
#load-module module-alsa-sink control=xxx
load-module module-alsa-sink control=PCM
and modifying the line
load-module module-udev-detect
load-module module-udev-detect ignore_dB=1
to /etc/pulse/default.pa file

I'm not sure all the modifications are essential. Check the ubuntu sound setting for output
Built-in Audio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers