Thinkpad T460 & Ultra Dock - No audio output on dock plug

Bug #1568576 reported by Ryan on 2016-04-10
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ALSA driver
New
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Thinkpad T460, Ultra dock, 2 channel speakers connected to dock. 4.4.0-18 Kernel / 16.04.

When the laptop is docked & speakers are connected to the dock audio connector, I get no audio outpout from the dock audio connector.

Looks like the same issue as reported in:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1385680

However the pin quirks appear to be different for the T*60 series of laptops.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Robert (l-launchpad-net-9) wrote :

Same problem here on a Thinkpad T460p and Ultra Dock. I'm using kernel 4.1.15.

Ryan (carbonfreeze) wrote :

I've recently updated to a mainline kernel build (4.7.0 201608021801) and the audio output from the dock is working now.

Krisztian Poos (rocky-poos) wrote :

4.13.0

Same issue on T47p and ultradock, ubuntu, x64, 4.13.0.

Is there any workaround? I did not find anything..

Regards,
K.

Krisztian Poos (rocky-poos) wrote :

T470p, sorry for the mistype.

Peter Levi (peterlevi) wrote :

Same here with T470p
(uname -a: "Linux pl 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux")

Stephan (mautier3) wrote :

Same here with L470
(uname -a: 4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux )

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers