gst-base 1.7 update created background buzzing noise with audioconvert

Bug #1539700 reported by Doug McMahon on 2016-01-29
30
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gst-plugins-base
Fix Released
Critical
alsa-driver (Ubuntu)
Undecided
Unassigned
goobox (Ubuntu)
Undecided
Unassigned
gst-plugins-base1.0 (Ubuntu)
High
Unassigned

Bug Description

Also affects cdplayer (goobox).
 Is not seen in audacious or vlc at all (using default audio of pulse
Test case: insert audio cd, play in rhymbox or cdplayer
What happens: significant background buzzing

May be gstreamer issue?

Attached is simple recording of what Rb is outputting.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-1.15-generic 4.4.0
Uname: Linux 4.4.0-1-generic x86_64
ApportVersion: 2.19.4-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: doug 1652 F.... pulseaudio
 /dev/snd/pcmC1D0p: doug 1652 F...m pulseaudio
 /dev/snd/controlC1: doug 1652 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri Jan 29 12:00:33 2016
InstallationDate: Installed on 2016-01-14 (14 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160114)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Speaker, Internal
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: High background noise, or volume is too low
Title: [20217, Realtek ALC282, Speaker, Internal] Background noise or low volume
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/18/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 74CN44WW(V3.05)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: VIQY0Y1
dmi.board.vendor: LENOVO
dmi.board.version: 31900058STD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad Y510P
dmi.modalias: dmi:bvnLENOVO:bvr74CN44WW(V3.05):bd09/18/2013:svnLENOVO:pn20217:pvrLenovoIdeaPadY510P:rvnLENOVO:rnVIQY0Y1:rvr31900058STD:cvnLENOVO:ct10:cvrLenovoIdeaPadY510P:
dmi.product.name: 20217
dmi.product.version: Lenovo IdeaPad Y510P
dmi.sys.vendor: LENOVO

Doug McMahon (mc3man) wrote :
Kev Bowring (flocculant) wrote :

Seems so, I had attached an audio recording to the orig. report, look
above, sounds similar

On 01/29/2016 01:10 PM, flocculant wrote:
> Is it like this? https://sendvid.com/sa7b0i4n
>

Results of some suggested gst commands -
gst-launch-1.0 cdparanoiasrc mode=1 ! audioconvert ! audioresample ! alsasink # bad
gst-launch-1.0 cdparanoiasrc mode=1 ! audioconvert ! audioresample ! pulsesink # bad

gst-launch-1.0 cdiocddasrc mode=1 ! audioconvert ! audioresample ! pulsesink # bad
gst-launch-1.0 cdiocddasrc mode=1 ! audioconvert ! audioresample ! alsasink # good

Kev Bowring (flocculant) wrote :

Ok - so possibly not just audio cd's given I see similar without any cd hardware at all, similarly not the clementine issue I reported (bug 1537184)

I've been having the issue for a couple of weeks - possibly related to gst changes - changelogs show changes at about the time I saw the issue first, though just assumed it was clementine in dev version at the time.

bag, good and ugly saw changes 5/6th Jan, base 11th Jan

Doug McMahon (mc3man) wrote :

Clementine's issue here is it uses wrong sample rate

Raymond (superquad-vortex2) wrote :

[15087.605353] ufs: ufs_fill_super(): bad magic number
[15087.607466] hfs: can't find a HFS filesystem on dev sda1
[15088.493763] EXT4-fs (sdb4): VFS: Can't find ext4 filesystem
[15088.494766] EXT4-fs (sdb4): VFS: Can't find ext4 filesystem
[15088.495725] EXT4-fs (sdb4): VFS: Can't find ext4 filesystem
[15088.496784] FAT-fs (sdb4): bogus number of reserved sectors
[15088.496787] FAT-fs (sdb4): Can't find a valid FAT filesystem
[15088.500312] XFS (sdb4): Invalid superblock magic number
[15088.502630] FAT-fs (sdb4): bogus number of reserved sectors
[15088.502633] FAT-fs (sdb4): Can't find a valid FAT filesystem
[15088.505591] VFS: Can't find a Minix filesystem V1 | V2 | V3 on device sdb4.
[15088.506810] hfsplus: unable to find HFS+ superblock

Joseph Wakeling (webdrake) wrote :

AFAICT this also affects CD ripping via e.g. Rhythmbox: the resulting audio files contain the horrendous buzz.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in goobox (Ubuntu):
status: New → Confirmed
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Changed in rhythmbox (Ubuntu):
importance: Undecided → High
tags: added: rls-x-incoming
affects: rhythmbox (Ubuntu) → gstreamer1.0 (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thanks, do you have crossfading enabled in rb edit->preferences->playback? Does it do it without it?

Will Cooke (willcooke) wrote :

I have enabled and disabled cross fading and it made no difference.

Kev Bowring (flocculant) wrote :

I found if I enabled crossfade then played audio it worked, took a reboot to get the issue.

ftr - removing gstreamer1.0-plugins-base 1.7.1-1ubuntu1 and installing the wily version gstreamer1.0-plugins-base_1.6.0-1ubuntu1 the issue of 'buzzing' disappears.

Same with the clementine playback issue I reported in the older bug I reported at 1537184

summary: - Audio cd's play with background buzzing
+ gst-base 1.7 update created background buzzing noise with audioconvert
Changed in alsa-driver (Ubuntu):
status: Confirmed → Invalid
Changed in goobox (Ubuntu):
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :
Changed in gstreamer1.0 (Ubuntu):
status: Confirmed → Triaged
affects: gstreamer1.0 (Ubuntu) → gst-plugins-base1.0 (Ubuntu)
Changed in gst-plugins-base:
importance: Unknown → Critical
status: Unknown → Confirmed
Nazar Mokrynskyi (nazar-pc) wrote :

I can confirm, downgraded package to 1.6.3-1ubuntu1 and Clementine now plays fine.

Changed in gst-plugins-base:
status: Confirmed → Incomplete
Changed in gst-plugins-base:
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in gst-plugins-base1.0 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.