[20BVCTO1WW, Realtek ALC3232, Black Headphone Out, Right] Underruns, dropouts or crackling sound

Bug #1534434 reported by Marc-Andre Meloche on 2016-01-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Hello, i'm currently having the same issue on a Thinkpad T450, with Ubuntu 15.10 and 15.04

I connect my headphones to the headphone jack, when i connect the headphone jack in the headphone port, i get the same cracking, popping sound as startup and shutdown/reboot.

So, when i boot, i get a cracking, popping sound that overpowers the headphones, it still occurs when i shutdown the laptop or reboot.

The output of alsa-info.sh gives me a different codec instead of the proposed fix information
0x10ec0292 0x17aa5036 0

i have
0x10ec0292 0x17aa5034 0

I tried the fix with both 0x17aa5036 and 0x17aa5034, on Ubuntu 15.10 and 15.04 without luck, the symptom stays, the cracking sound appears at startup and shutdown.

I tried fedora 23 and i still have the issue.

Probably caused by the same issue, i get a static noise in the both headphones if i mute it goes away

Thanks for your help.

Almost similar issue as specified here

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1502155

Detailed info :
Description: Ubuntu 15.10
Release: 15.10

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.2.0-23.28-generic 4.2.6
Uname: Linux 4.2.0-23-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: madmantm 1370 F.... pulseaudio
                      madmantm 1916 F.... alsamixer
 /dev/snd/controlC0: madmantm 1370 F.... pulseaudio
CurrentDesktop: GNOME
Date: Thu Jan 14 22:18:30 2016
InstallationDate: Installed on 2016-01-15 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Black Headphone Out, Right
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: Underruns, dropouts, or "crackling" sound
Title: [20BVCTO1WW, Realtek ALC3232, Black Headphone Out, Right] Underruns, dropouts or crackling sound
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/23/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: JBET55WW (1.20 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20BVCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJBET55WW(1.20):bd12/23/2015:svnLENOVO:pn20BVCTO1WW:pvrThinkPadT450:rvnLENOVO:rn20BVCTO1WW:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20BVCTO1WW
dmi.product.version: ThinkPad T450
dmi.sys.vendor: LENOVO

tags: added: latest-bios-1.20
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Peter McSmith (billwong1234) wrote :

i have the same issue, brand new thinkpad t450, the soundcracking is quite displeasing.

description: updated

i have additional information, by modifying settings in PowerTop i was able to reproduce the sound i hear while the machine is rebooting, including plugging my headphones in the jack.

By switching the option at "Enable Audio Code Power Management" at Good, i hear the sound and the static doesn't stop, at Bad it stops, however when i insert the jack i still hear the sound.

The switching in powertop does the following

GOOD
echo ' ' > ' /sys/module/snd_hda_intel/parameters/power_save

BAD
echo '1' > ' /sys/module/snd_hda_intel/parameters/power_save

Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium

i can confirm that the issue is not present in ubuntu 14.04.3

tags: added: regression-release
Raymond (superquad-vortex2) wrote :

Try hda-analyzer to mute the signal from node 0x0b in those amp in at node 0x0c and 0x0d

Node 0x0c [Audio Mixer] wcaps 0x20010b: Stereo Amp-In Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1 Amp-In vals: [0x00 0x00] [0x00 0x00] Connection: 2 0x02 0x0b

 Node 0x0d [Audio Mixer] wcaps 0x20010b: Stereo Amp-In Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1 Amp-In vals: [0x00 0x00] [0x00 0x00] Connection: 2 0x03 0x0b

Hello Raymond, i have tried what you said, and i noticed something.

I tried hda-analyzer, as mentionned, checked Node[0x1a] PIN

In the Widget Control, if i uncheck the IN option, i get the noise i mentioned earlier.

I attached a screenshot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers