[USB-Audio - USBStreamer, playback] No sound at all

Bug #1526569 reported by jaescala on 2015-12-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

USBStreamer worked fine the first time I connected it to my Bodhi Linux computer 8 channels in, 8 channels out connected to a Yamaha 03d with the adat expansion card.

Next day I tried again and nothing no input, no output. Alsamixer only recognize TWO controls: master playback and master capture, unmute master and check on capture did nothing.

I decided to test with a windows computer and USBStreamer B works perfect so I did a fresh Ubuntu Mate 15.10 installation to my computer. Once I finished to install everything (JACK, etc) I plugged the USBStreamer B to the computer and It worked perfect 8 channels IN 8 channels OUT..

But next day the same thing NO SOUND IN-NO SOUND OUT. But now I unmuted alsamixer Master PLAY and checked CAPTURE and only got CAPTURE, NO PLAY.

If I plug the USBStreamer B for the first time it works perfect, but after that It doesn't..

Description: Ubuntu 15.10
Release: 15.10
alsa-base : 1.0.25+dfsg-0ubuntu5 (wily)
alsa-utils : 1.0.29-0ubuntu1 (wily)

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.2.0-19.23-lowlatency 4.2.6
Uname: Linux 4.2.0-19-lowlatency x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: vonsai 1754 F.... pulseaudio
 /dev/snd/controlC0: vonsai 1754 F.... pulseaudio
CurrentDesktop: MATE
Date: Tue Dec 15 17:31:04 2015
InstallationDate: Installed on 2015-12-14 (1 days ago)
InstallationMedia: Ubuntu-MATE 15.10 "Wily Werewolf" - Release amd64 (20151021)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:USBStreamer failed
Symptom_Card: USB-Audio - USB2.0-MIDI
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: vonsai 1754 F.... pulseaudio
 /dev/snd/controlC0: vonsai 1754 F.... pulseaudio
Symptom_Type: No sound at all
Title: [USB-Audio - USBStreamer, playback] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/12/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.6
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: A88XI AC (MS-7913)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.6:bd12/12/2014:svnMSI:pnMS-7913:pvr1.0:rvnMSI:rnA88XIAC(MS-7913):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7913
dmi.product.version: 1.0
dmi.sys.vendor: MSI

jaescala (jaescala00) wrote :
jaescala (jaescala00) wrote :

I found what the problem was...

It seem that when you plug the USBStreamer B for the first time the asound.state does not have any channel mapping so it creates one for the first time and read it the next time when the computer boot and alsa start.

I erase the information of USBStreamer on asound.state, reload alsa and I worked.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 15.10 (wily) reached end-of-life on July 28, 2016.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in alsa-driver (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers