[20ANCTO1WW, Realtek ALC3232, Black Headphone Out, Left] No sound at all when headset plugged in

Bug #1508826 reported by Dan Watkins on 2015-10-22
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Sounds works fine through the internal speakers, but once I plug a headset or headphones (I tried two things, in case one was broken) in to the audio out, I get nothing.

Looking in alsamixer, plugging the headset in mutes the 'Speaker' output and unmutes the 'Headphone' output, and restores the Master volume to its previous headset-in value. Unplugging the headset does the opposite (mutes 'Headphone'; unmutes 'Speaker'), as I would expect.

This was working on vivid, so a definite regression, I think.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: daniel 5155 F.... pulseaudio
 /dev/snd/controlC0: daniel 5155 F.... pulseaudio
Date: Thu Oct 22 09:37:39 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-09-04 (412 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_DevicesInUse:
 Error: command ['pkexec', 'fuser', '-v', '/dev/snd/by-path', '/dev/snd/hwC1D0', '/dev/snd/pcmC1D0c', '/dev/snd/pcmC1D0p', '/dev/snd/controlC1', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D8p', '/dev/snd/pcmC0D7p', '/dev/snd/pcmC0D3p', '/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 127: polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
 Error executing command as another user: Not authorized

 This incident has been reported.
Symptom_Jack: Black Headphone Out, Left
Symptom_Type: No sound at all
Title: [20ANCTO1WW, Realtek ALC3232, Black Headphone Out, Left] No sound at all
UpgradeStatus: Upgraded to wily on 2015-10-21 (0 days ago)
dmi.bios.date: 05/21/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GLET70WW (2.24 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20ANCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50512 STD
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGLET70WW(2.24):bd05/21/2014:svnLENOVO:pn20ANCTO1WW:pvrThinkPadT440p:rvnLENOVO:rn20ANCTO1WW:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20ANCTO1WW
dmi.product.version: ThinkPad T440p
dmi.sys.vendor: LENOVO

Dan Watkins (daniel-thewatkins) wrote :
Dan Watkins (daniel-thewatkins) wrote :

I notice fuser errored out; here is what it produces for me if I run it now:

% fuser -v /dev/snd/by-path /dev/snd/hwC1D0 /dev/snd/pcmC1D0c /dev/snd/pcmC1D0p /dev/snd/controlC1 /dev/snd/hwC0D0 /dev/snd/pcmC0D8p /dev/snd/pcmC0D7p /dev/snd/pcmC0D3p /dev/snd/controlC0 /dev/snd/seq /dev/snd/timer
                     USER PID ACCESS COMMAND
/dev/snd/controlC1: daniel 5155 F.... pulseaudio
                     daniel 6097 F.... alsamixer
/dev/snd/controlC0: daniel 5155 F.... pulseaudio

Raymond (superquad-vortex2) wrote :
Download full text (3.3 KiB)

58.996604] WARNING: CPU: 3 PID: 1891 at /build/linux-AxjFAn/linux-4.2.0/drivers/gpu/drm/i915/intel_crt.c:146 hsw_crt_pre_enable+0x7d/0x80 [i915]()
[ 58.996605] SPLL already enabled
[ 58.996606] Modules linked in: rfcomm ipt_REJECT nf_reject_ipv4 ebtable_filter ebtables ip6table_filter ip6_tables xt_addrtype xt_conntrack veth aufs xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack binfmt_misc xt_tcpudp bridge stp llc iptable_filter ip_tables x_tables bnep arc4 nls_iso8859_1 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev btusb iwlmvm btrtl media btbcm btintel bluetooth mac80211 intel_rapl snd_hda_codec_hdmi iosf_mbi x86_pkg_temp_thermal snd_hda_codec_realtek intel_powerclamp coretemp snd_hda_codec_generic iwlwifi input_leds joydev serio_raw cfg80211 thinkpad_acpi snd_seq_midi snd_hda_intel rtsx_pci_ms nvram memstick snd_hda_codec snd_seq_midi_event snd_hda_core
[ 58.996639] snd_rawmidi snd_hwdep mei_me mei snd_pcm ie31200_edac shpchp lpc_ich edac_core snd_seq wmi snd_seq_device kvm_intel snd_timer snd kvm soundcore mac_hid cuse parport_pc ppdev lp parport autofs4 btrfs drbg ansi_cprng algif_skcipher af_alg dm_crypt raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq raid1 raid0 multipath linear hid_microsoft hid_generic usbhid hid rtsx_pci_sdmmc crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw i915 gf128mul glue_helper ablk_helper cryptd psmouse i2c_algo_bit drm_kms_helper ahci e1000e libahci drm ptp rtsx_pci pps_core video
[ 58.996673] CPU: 3 PID: 1891 Comm: Xorg Not tainted 4.2.0-16-generic #19-Ubuntu
[ 58.996674] Hardware name: LENOVO 20ANCTO1WW/20ANCTO1WW, BIOS GLET70WW (2.24 ) 05/21/2014
[ 58.996675] 0000000000000000 0000000015d91e38 ffff880437d1fa58 ffffffff817e8c09
[ 58.996678] 0000000000000000 ffff880437d1fab0 ffff880437d1fa98 ffffffff8107b3c6
[ 58.996679] 0000000000000046 ffff880434f00000 ffff880434c52100 ffff880435dee000
[ 58.996681] Call Trace:
[ 58.996687] [<ffffffff817e8c09>] dump_stack+0x45/0x57
[ 58.996691] [<ffffffff8107b3c6>] warn_slowpath_common+0x86/0xc0
[ 58.996693] [<ffffffff8107b455>] warn_slowpath_fmt+0x55/0x70
[ 58.996707] [<ffffffffc024d04d>] hsw_crt_pre_enable+0x7d/0x80 [i915]
[ 58.996719] [<ffffffffc0237108>] haswell_crtc_enable+0x418/0xa90 [i915]
[ 58.996730] [<ffffffffc0233fb6>] __intel_set_mode+0x916/0xb60 [i915]
[ 58.996742] [<ffffffffc023ad16>] intel_crtc_set_config+0x2b6/0x580 [i915]
[ 58.996753] [<ffffffffc004fee5>] ? drm_mode_create+0x25/0x60 [drm]
[ 58.996761] [<ffffffffc00494c6>] drm_mode_set_config_internal+0x66/0x100 [drm]
[ 58.996769] [<ffffffffc004db29>] drm_mode_setcrtc+0x3e9/0x500 [drm]
[ 58.996775] [<ffffffffc003e495>] drm_ioctl+0x125/0x610 [drm]
[ 58.996777] [<ffffffff8123e696>] ? fsnotify+0x316/0x4a0
[ 58.996784] [<ffffffffc004d740>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
[ 58.996788] [<ffffffff812108a5>] do_vfs_ioctl+0x295/0x480
[ 58.996790] [<ffffffff81087f61>] ? __set_task_blocked+0x41/0xa0
[ 58.996792] [<ffffffff81210b09>] SyS_ioctl+0x79/0x90
[...

Read more...

Raymond (superquad-vortex2) wrote :

/sys/class/sound/hwC1D0/init_pin_configs:
0x12 0x90a60130
0x13 0x40000000
0x14 0x90170110
0x15 0x0321101f
0x16 0x411111f0
0x18 0x411111f0
0x19 0x411111f0
0x1a 0x03a11020
0x1b 0x411111f0
0x1d 0x40738105
0x1e 0x411111f0

/sys/class/sound/hwC1D0/driver_pin_configs:
0x16 0x21211010
0x19 0x21a11010

/sys/class/sound/hwC1D0/user_pin_configs:

/sys/class/sound/hwC1D0/init_verbs:

!!ALSA/HDA dmesg
!!------------------

[ 54.322076] Non-volatile memory driver v1.3
[ 54.325349] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 54.326591] thinkpad_acpi: ThinkPad ACPI Extras v0.25
--
[ 54.344189] iwlwifi 0000:03:00.0: loaded firmware version 25.30.13.0 op_mode iwlmvm
[ 54.347454] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3232: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 54.347458] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 54.347460] snd_hda_codec_realtek hdaudioC1D0: hp_outs=2 (0x16/0x15/0x0/0x0/0x0)
[ 54.347462] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 54.347464] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 54.347466] snd_hda_codec_realtek hdaudioC1D0: Dock Mic=0x19
[ 54.347468] snd_hda_codec_realtek hdaudioC1D0: Mic=0x1a
[ 54.347471] snd_hda_codec_realtek hdaudioC1D0: Internal Mic=0x12

control.21 {
  iface CARD
  name 'Speaker Phantom Jack'
  value true
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.22 {
  iface CARD
  name 'Dock Headphone Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.23 {
  iface CARD
  name 'Headphone Jack'
  value true
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }

headphone jack is plugged but doc headphone is not unpluged

Raymond (superquad-vortex2) wrote :

Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',1
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]

seem dock headphone use headphone playback switch index=0

and headphone use headphone playback switch index=1

Dan Watkins (daniel-thewatkins) wrote :

Booting in to the last kernel I was using on vivid didn't fix the problem.

Raymond (superquad-vortex2) wrote :

the driver expect the first headphone pin is the headset

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda?id=73bdd597823e2231dc882577dbbaf8df92fe1775

static void alc_update_headset_mode(struct hda_codec *codec)
{
  struct alc_spec *spec = codec->spec;
   hda_nid_t mux_pin = spec->gen.imux_pins[spec->gen.cur_mux[0]];
  hda_nid_t hp_pin = spec->gen.autocfg.hp_pins[0];

https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers

alsa sound

you need to swap the order of two headphone pins

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Áron (rony-wnh) on 2015-10-22
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
Raymond (superquad-vortex2) wrote :

https://bugzilla.kernel.org/show_bug.cgi?id=99721

you should follow up the bug if it is not fixed

Raymond (superquad-vortex2) wrote :

https://bugzilla.kernel.org/attachment.cgi?id=179441&action=diff

- { 0x16, 0x21211010 }, /* dock headphone */
+ { 0x16, 0x2121101f }, /* dock headphone */

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete

Same problem here after update to Wily. Fixed by following this guide:

http://unix.stackexchange.com/questions/218108/no-output-from-headphones-jack-occasionally-although-system-displays-output

and adding "options snd-hda-intel model=tpt440-dock" to /etc/modprobe.d/alsa-base.conf.

Version info: Kernel 4.2.0-16-generic #19-Ubuntu SMP and alsa-base 1.0.25+dfsg-0ubuntu5.

This is not related to a docking station, and I have a TP440p. Reported this to the original kernel bug.

Áron (rony-wnh) wrote :

@daniel-r-schmidt

Tried all steps, but sadly it's still not working for me.
My kernel is identical, and ALSA reports a version of 1.0.29.

I don't have a dock for my t440p.

Áron (rony-wnh) wrote :

My t440p is the optimus version with both an Intel and an NVIDIA GK208M [GeForce GT 730M] GPU.

Currently the only combination where I have sound is with the NVIDIA card enabled and using both workarounds (alsa-base.conf and hda-jack-retask.fw).

I'm using the default i915 driver and the nvidia 352.41 binary driver.

Same thinkpad here. I figured out in the meantime that the headphones must not be plugged in on boot; otherwise they won't work until the next complete power down. If I boot without headphones, however, it works fine.

If you have Alsa 1.0.29 already, you could try the patches from here https://bugzilla.kernel.org/show_bug.cgi?id=99721 (comment 8/9).

Following Raymond's advice in #7, I have swapped the pins using hdajackretask and now have working headphone audio and mic. When I initially plugged the headset in, things were muted, so I had to go in to alsamixer to sort that out.

$ cat /lib/firmware/hda-jack-retask.fw
[codec]
0x10ec0292 0x17aa220e 0

[pincfg]
0x12 0x90a60130
0x13 0x40000000
0x14 0x90170110
0x15 0x222140af
0x16 0x0321403f
0x18 0x411111f0
0x19 0x21a11010
0x1a 0x03a11020
0x1b 0x411111f0
0x1d 0x40738105
0x1e 0x411111f0

[model]
auto

andrae (ndrgrimm) on 2015-10-27
no longer affects: alsa-driver
andrae (ndrgrimm) wrote :

Thinkpad t440p with prime configuration. Same problem with headphone audio.

I resolve it with an upgrade of the bios form 1.14 to 2.35.

p.s. The problem showed with windows 10, too.

iplaman (iplaman) wrote :

Thinkpad T440p with prime configuration. Same problem with headphone audio.
BIOS : GLET74WW (2.28 )
The issue doesn't occur on first boots, only after reboots.
I've tried the hdajackretask workaround and it didn't work, not sure what i'm missing.(had the same addresses in sys/class)

Can someone try to check if they can reproduce this behavior?
I'll try upgrading the bios version and update the results

iplaman (iplaman) wrote :

Update to previous comment
Regardless to boot #
Booting with headphones connected - bug reproduced
Booting with headphones not connected - bug doesn't reproduce

Same issue, it also only works when the headphones aren't plugged in during boot. I don't have a docking station. The hdajackretask change didn't help either. Thinkpad W540

Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Mario Emmenlauer (emmenlau) wrote :

None of the solutions above work for me. I don't have a dock, just the headset jack on T440p.

baizon (baizon) wrote :

Same for me. Nothing did work. Always when i plug my headset in, it gets detected, but then immediately switches back to the speakers.

dnord (dnord) wrote :

I'm no longer having this problem on 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.