Audiotrak MAYA U5 not fully supported

Bug #1471790 reported by Mariusz on 2015-07-06
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I have a problem with usb-audio Audiotrack Maya U5 on Ubuntu 14.04.2:

Steps to reproduce:
1) Try to play a sound
2) You can either get a sound out of the speakers or not which is random
3) Stop the sound and wait ~5 seconds for the device to suspend (light on device stops blinking)
4) You are back at point 2

Another way to reproduce it:
1) Try to play a sound
2) If the sound is not playing open pavucontrol try to change profile between analog stereo output and digital stereo output several times until it “clicks” and you get a sound through one of this outputs

With analog speakers connected sound should be playing only with analog output and it should not reset outputs upon device suspend.

This problem started after I upgraded firmware from Audiotrack's website (http://audiotrack.net/en/download/421) to RELEASE 10. I tried to downgrade firmware but with no luck.

Other problem is that there are no inputs – either digital, line in or microphone in pavucotrol.

I tried several kernels from 3.2 to 4.1 and this bug is present at all that I tested.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.16.0-41.57~14.04.1-generic 3.16.7-ckt11
Uname: Linux 3.16.0-41-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: drkp 1515 F...m pulseaudio
 /dev/snd/controlC1: drkp 1515 F.... pulseaudio
 /dev/snd/controlC0: drkp 1515 F.... pulseaudio
CurrentDesktop: Unity
Date: Mon Jul 6 13:49:07 2015
InstallationDate: Installed on 2015-07-01 (4 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
PackageArchitecture: all
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/19/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F1
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Q77M-D2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF1:bd04/19/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnQ77M-D2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Mariusz (knoife-1) wrote :
jollaman999 (jollaman999-r) wrote :

I have a exactly same problem in ubuntu 15.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
jollaman999 (jollaman999-r) wrote :

I solved this problem by this method.

Download attachment file in Windows machine.
(It contains Release F firmware with Release 10's Firmware Upload tool. There was a problem with original Release F upload tool.)

Connect MAYA U5 to Windows machine and flash firmware.

Get it back to Ubuntu machine.

Comment this line in two files.
load-module module-suspend-on-idle

sudo vi /etc/pulse/default.pa
sudo vi /etc/pulse/system.pa

Reboot your Ubuntu machine.

Hope this work!

Mariusz (knoife-1) wrote :

Thank you so much for your answer!

This method solved the problem for me. Analog output works now as expected, same with microphone input. One thing that I couldn't get to work is line in input.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers