[SATELLITE P50t-B-112, Realtek ALC284, Speaker, Internal] No sound at all

Bug #1398971 reported by Fernando on 2014-12-03
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

My sound card is not working under Ubuntu 14.10

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: maria 2473 F.... pulseaudio
 /dev/snd/controlC1: maria 2473 F.... pulseaudio
                      maria 12484 F.... alsamixer
CurrentDesktop: Unity
Date: Wed Dec 3 21:26:29 2014
InstallationDate: Installed on 2014-11-29 (4 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Audio Interno - HDA Intel PCH
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: maria 2473 F.... pulseaudio
 /dev/snd/controlC1: maria 2473 F.... pulseaudio
                      maria 12484 F.... alsamixer
Symptom_Jack: Speaker, Internal
Symptom_Type: No sound at all
Title: [SATELLITE P50t-B-112, Realtek ALC284, Speaker, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/03/2014
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 1.10
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: VG20SQ
dmi.board.vendor: TOSHIBA
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnTOSHIBA:bvr1.10:bd04/03/2014:svnTOSHIBA:pnSATELLITEP50t-B-112:pvrPSPNVE-01G00FCE:rvnTOSHIBA:rnVG20SQ:rvrTobefilledbyO.E.M.:cvnTOSHIBA:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: SATELLITE P50t-B-112
dmi.product.version: PSPNVE-01G00FCE
dmi.sys.vendor: TOSHIBA

Fernando (fcuencamargalef) wrote :
Fernando (fcuencamargalef) wrote :

Hello,

  I followed these instructions: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

 And I've tried the latest alsa package without success.

  Any ideas, can I try to configure or install something else?

  It is very annoying have a new laptop and cannot use Ubuntu with it :'(

Thanks to all,
   Fernando

Fernando (fcuencamargalef) wrote :

Suddenly now it works.

An Alsa package update?

I have not tested well before?

I have no idea.

But now it works.

After getting the sound work in configuration test, I also needed to install sound plugins:
  sudo apt-get install libasound2-plugins:i386

To make the sound work also in firefox and Chrome.

lucianj (lucianjelea) wrote :

Worked for me as well.. the solution described by Fernando. Thanks.

Ferda (fsuarezj) wrote :
Download full text (4.7 KiB)

I have tried the instructions Fernando said: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

As they are not daily DKMS packages for Unicorn I have installed the Trusty ones but it does not work yet :( The only thing it's working are my headphones, but not the speakers which work properly in Windows.

When I do "pacmd list-sinks" I get unknown availability for the speakers, any ideas?

Welcome to PulseAudio! Use "help" for usage information.
>>> 2 sink(s) available.
    index: 0
 name: <alsa_output.pci-0000_00_03.0.hdmi-stereo>
 driver: <module-alsa-card.c>
 flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
 state: IDLE
 suspend cause:
 priority: 9950
 volume: 0: 101% 1: 101%
         0: 0,38 dB 1: 0,38 dB
         balance 0,00
 base volume: 100%
              0,00 dB
 volume steps: 65537
 muted: no
 current latency: 281,74 ms
 max request: 64 KiB
 max rewind: 64 KiB
 monitor source: 0
 sample spec: s16le 2ch 44100Hz
 channel map: front-left,front-right
              Stereo
 used by: 0
 linked by: 0
 configured latency: 371,52 ms; range is 0,50 .. 371,52 ms
 card: 0 <alsa_card.pci-0000_00_03.0>
 module: 5
 properties:
  alsa.resolution_bits = "16"
  device.api = "alsa"
  device.class = "sound"
  alsa.class = "generic"
  alsa.subclass = "generic-mix"
  alsa.name = "HDMI 0"
  alsa.id = "HDMI 0"
  alsa.subdevice = "0"
  alsa.subdevice_name = "subdevice #0"
  alsa.device = "3"
  alsa.card = "1"
  alsa.card_name = "HDA Intel HDMI"
  alsa.long_card_name = "HDA Intel HDMI at 0xf7c14000 irq 50"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:03.0"
  sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card1"
  device.bus = "pci"
  device.vendor.id = "8086"
  device.vendor.name = "Intel Corporation"
  device.product.id = "0c0c"
  device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
  device.form_factor = "internal"
  device.string = "hdmi:1"
  device.buffering.buffer_size = "65536"
  device.buffering.fragment_size = "32768"
  device.access_mode = "mmap+timer"
  device.profile.name = "hdmi-stereo"
  device.profile.description = "Digital Stereo (HDMI)"
  device.description = "Built-in Audio Digital Stereo (HDMI)"
  alsa.mixer_name = "Intel Haswell HDMI"
  alsa.components = "HDA:80862807,80860101,00100000"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"
 ports:
  hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
   properties:
    device.icon_name = "video-display"
 active port: <hdmi-output-0>
  * index: 1
 name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
 driver: <module-alsa-card.c>
 flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
 state: SUSPENDED
 suspend cause: IDLE
 priority: 9959
 volume: 0: 58% 1: 58%
         0: -14,25 dB 1: -14,25 dB
         balance 0,00
 base volume: 100%
              0,00 dB
 volume steps: 65537
 muted: no
 current latency: 0,00 ms
 max request: 0 KiB
 max rewind: 0 KiB
 monitor source: 1
 sample spec: s16le 2ch 44100Hz
 channel map: front-left,front-right
              Stereo
 used by: 1
 linked by: 1
 configured latency: 0,00 ms; range is 0,50 .. 371,52 ms
...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Ron (rshimshock) wrote :

I can confirm the same issue with a Toshiba Satellite P50t-B and Realtek ALC284. I had no sound coming from internal speakers, but there was sound from the headphone jack. I followed the instructions described by Fernando, and the daily ALSA update package fixed the problem. Thanks for posting about this! I'm running Ubuntu 14.04.2 LTS, and the issue occurs on this version too.

A few additional points worth mentioning. The ALSA daily build snapshots (https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages) are a bit confusing. I used the 14.04.1 LTS version, which is titled, "oem-audio-hda-daily-lts-utopic-dkms-0.201503191631~ubuntu14.04.1". The series is "Trusty" and listed under 14.04.1, but it's name is "lts-utopic"? I'm assuming this should be "lts-trusty."

Also I notice today that there is a .deb package accessible from the main Audio Develpment Team page for 14.04 LTS. This was not the case a couple of days ago. At that time, the build status was shown as a red "X", since new packages are not built daily for every release. For others dealing with this issue, it might be necessary to look through the completed builds list (https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+builds?build_state=built) to find the most recent successful build for your version.

One final comment is there seems to be a conflict with the ALSA update and VLC, or possibly PulseAudio and VLC. If VLC is installed, I lose the ability to control volume from the keyboard. It is still possible to make volume changes from the audio menus and screens. If VLC is removed, ability to control volume from the keyboard returns.

Ron (rshimshock) wrote :

After further research, the loss of the keyboard volume control is not due to an interaction with VLC.

I'm not sure why, but the keyboard volume control fails to load on some occasions during boot-up. I restarted the computer, and the keyboard volume control has returned.

Dngrsone (dngrsone) wrote :

Same problem with Toshiba Satellite P55t-B5154 running Mint 17 KDE (64-bit).

Fernando's fix worked for me as well.

Ron, I think the keyboard volume control problem is separate. For the past month (since I installed Mint on this laptop) I have not had sound, so I cannot say anything about the volume controls, however, I have noticed that the Screen Brightness keyboard controls are intermittent. I believe my backlighting control is as well.

There is a Bug report here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1302885

Don't know if it is related to mine, since I am running KDE, but there you go.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers