Dell XPS 9333 Headset jack not correctly detected

Bug #1299549 reported by Eddie Dunn on 2014-03-29
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ALSA driver
Unknown
Unknown
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Plug a headset of the TRRS kind into your headset jack on the laptop.
2. Get bugged by the annoying "Unknown Audio Device" dialog _every single time_.

Expected behavior:

Ubuntu should just "know" that it's a headset jack. Barring this, the dialog should remember my last choice, and stop bugging me, needlessly.

The codec on this computer is:

$ grep -r Realtek /proc/asound/card*
/proc/asound/card1/codec#0:Codec: Realtek ALC3661

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: eddie 2137 F.... pulseaudio
 /dev/snd/controlC0: eddie 2137 F.... pulseaudio
CurrentDesktop: Unity
Date: Sat Mar 29 19:40:24 2014
InstallationDate: Installed on 2014-03-09 (19 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140309)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Title: PCI/internal sound card not detected
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/11/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0GFTRT
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd12/11/2013:svnDellInc.:pnXPS139333:pvr:rvnDellInc.:rn0GFTRT:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: XPS13 9333
dmi.sys.vendor: Dell Inc.

Eddie Dunn (eddie-dunn) wrote :
Raymond (superquad-vortex2) wrote :

[ 3.859742] sound hdaudioC1D0: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 3.859747] sound hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.859750] sound hdaudioC1D0: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[ 3.859752] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[ 3.859755] sound hdaudioC1D0: mono: mono_out=0x0
[ 3.859757] sound hdaudioC1D0: inputs:
[ 3.859760] sound hdaudioC1D0: Headphone Mic=0x19
[ 3.859762] sound hdaudioC1D0: Headset Mic=0x1b
[ 3.859765] sound hdaudioC1D0: Internal Mic=0x12

seem ultrabook have only one headset jack

can it be retasked as headphone or mic ?

how about dell usb 3.0 super speed video docking station ?

1 x headphones - output - mini-phone stereo 3.5 mm
1 x microphone - input - mini-phone 3.5 mm

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Eddie Dunn (eddie-dunn) wrote :

Not sure what more you want me to report. I've followed the guide on http://voices.canonical.com/david.henningsson/2014/03/07/headset-jacks-on-newer-laptops/ and I tried setting both options snd-hda-intel model=dell-headset-multi and options snd-hda-intel model=dell-headset-dock.

You are correct that there is only a headset jack on this laptop.

Raymond (superquad-vortex2) wrote :

you have to ask the author, the jack controls only have read access and no write access

any application in user space cannot change the value of the controls

control.17 {
  iface CARD
  name 'Headphone Mic Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.18 {
  iface CARD
  name 'Headset Mic Phantom Jack'
  value true
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }

http://bazaar.launchpad.net/~unity-settings-daemon-team/unity-settings-daemon/trunk/view/head:/plugins/media-keys/what-did-you-plug-in/pa-backend.c

Raymond (superquad-vortex2) wrote :

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda/hda_auto_parser.c?id=cb420b1186e0090f24137855e14e6f3bf7cb769d

it is strange that headphone Mic Jack is added

this usually mean the one and only one Jack can be either used as headphone or Mic for those netbook

do the user manual mention that it support convention mic ?

Raymond (superquad-vortex2) wrote :

your alsa-info are imcomplete since it did not contain info of driver pins in sysfs

do the driver really set node with sequence number 0xc to headphone Mic ?

Node 0x19 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
  Control: name="Headphone Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals: [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals: [0x80 0x80]
  Pincap 0x0000373c: IN OUT HP Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=00, enabled=0
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 3
     0x0c* 0x0d 0x0e

Raymond (superquad-vortex2) wrote :

if your notebook really support headset, headphone and Mic jack

why do headphone, headset mic and headphone Mic at three different pin complex

Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Control: name="Headphone Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Headphone Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Headset Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=3, ofs=0
  Control: name="Headset Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=3, ofs=0
  Control: name="Beep Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Control: name="Beep Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals: [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x18 0x18] [0x80 0x80]
  Connection: 6
     0x18 0x19 0x1a 0x1b 0x1d 0x14

Eddie Dunn (eddie-dunn) wrote :

I have tried plugging in a headset, headphones, and a mic. All of them work as expected, given the right selection in sound settings. Knowing anything about correct drivers, nodes, sequence numbers and pins are beyond my knowledge, unfortunately.

With a headset plugged in, however, there is a problem with hearing "white noise", which I think is connected with the fact that it picks up noise from the headset mic. That is another bug, though.

Raymond (superquad-vortex2) wrote :

from the viewpoint of user, the driver should initial the Jack as same said the icon near the Jack and provide a headphone Jack mode switch for the user to change the nature of this Jack

users are unlikely to know that the function of the Jack can be changed by control (e.g. capture source to select internal Mic can retask the Jack fro Mic to headphone)

Raymond (superquad-vortex2) wrote :

you can use hda-analyzer to mute the Amp-in from node 0x0b ( headset Mic signal through from 0x0b)

  Amp-In vals: [0x00 0x00] [0x80 0x80]

Node 0x0c [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals: [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x02 0x0b

Eddie Dunn (eddie-dunn) wrote :

I'm not sure I understand you correctly. Are you saying my request for a setting to prevent the "Unknown Audio Device" from popping up every single time is unreasonable?

Also, I can't find a program called `hda-analyzer` in the repos.

Dan Poler (l-dan) wrote :

I don't get the unknown audio popup but the integral microphone is not detected when a headset is plugged in.
Tried the couple of suggested modprobe options in the article Eddie linked, to no avail.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.