hdmi audio is sped up/high pitched[Gazelle Professional, Intel Haswell HDMI, Digital Out, HDMI] Playback problem

Bug #1288004 reported by John Clark on 2014-03-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned
alsa-driver (Debian)
New
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 13.10
Not sure which package
Sound comes through hdmi sounding like a chipmunks tune.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: alsa-base 1.0.25+dfsg-0ubuntu4
ProcVersionSignature: Ubuntu 3.11.0-17.31-generic 3.11.10.3
Uname: Linux 3.11.0-17-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Tue Mar 4 18:21:58 2014
MarkForUpload: True
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:MID failed
Symptom_Card: Built-in Audio - HDA Intel MID
Symptom_Jack: Digital Out, HDMI
Symptom_Type: None of the above
Title: [Gazelle Professional, Intel Haswell HDMI, Digital Out, HDMI] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/15/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.03.03RS76
dmi.board.asset.tag: Tag 12345
dmi.board.name: Gazelle Professional
dmi.board.vendor: System76, Inc.
dmi.board.version: gazp9
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: System76, Inc.
dmi.chassis.version: gazp9
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.03.03RS76:bd01/15/2014:svnSystem76,Inc.:pnGazelleProfessional:pvrgazp9:rvnSystem76,Inc.:rnGazelleProfessional:rvrgazp9:cvnSystem76,Inc.:ct9:cvrgazp9:
dmi.product.name: Gazelle Professional
dmi.product.version: gazp9
dmi.sys.vendor: System76, Inc.

John Clark (clark-johna) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Raymond (superquad-vortex2) wrote :

did the driver still waiting for grpahic driver to provide a valid ELD or lost ELD after suspend/resume ?

[ 1073.774332] HDMI: ELD buf size is 0, force 128
[ 1073.774364] HDMI: invalid ELD data byte 0
[ 1073.774420] HDMI: ELD buf size is 0, force 128
[ 1073.774455] HDMI: invalid ELD data byte 0
[ 1091.246483] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[ 1091.246957] hda_codec: invalid CONNECT_LIST verb 7[1]:0
[ 1174.002749] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[ 1174.003216] hda_codec: invalid CONNECT_LIST verb 7[1]:0
[ 1216.837078] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[ 1216.837546] hda_codec: invalid CONNECT_LIST verb 7[1]:0
[ 1242.876476] hda_codec: invalid CONNECT_LIST verb 5[1]:0
[ 1242.876958] hda_codec: invalid CONNECT_LIST verb 7[1]:0

nshepperd (nshepperd) wrote :
Peter Curtis (pdcurtis) wrote :

Neil Shepperd was too modest to say he produced a quick workaround in https://bugzilla.kernel.org/show_bug.cgi?id=74861. This simple simple fix works for me on a Chillblast Defiant mini laptop which has Haswell/Optimus Architecture, Core i7 Processor and nVidia GTX 765M graphics running Mint 17 (equivalent to 14.04).

The quick fix is to pass i915.disable_power_well=0 on the kernel command line which works around the problem, letting audio play at the correct speed again. After confirmation one can modify /etc/default/grub to make it permanent. Hopefully the commit will soon be reversed.

Changed in system76:
status: New → Fix Released
Jason Gerard DeRose (jderose) wrote :

Marked as fixed release for System76 as the 14.04.5 release of the system76-driver includes a grub line fix for this:

http://bazaar.launchpad.net/~system76-dev/system76-driver/trunk/view/head:/debian/changelog

David (rudder2) wrote :

I can confirm that after hours of serching the internet and trying fixes that passing i915.disable_power_well=0 on the kernel command line works around the problem, letting audio play at the correct speed again.

I'm running a Shuttle SZ87R6 with Intel Core i7-4770K Intel Z87 Chipset using on board video and audio. The HDMI and Optical out is going to a Pioneer Suround Sound System before the HDMI continues on to my projector.

The S/PDIF works perfectly all the time but only has 2 channel audio which is annoying so I wanted to use the HDMI of course.

I'm running KUbuntu 14.04 Trusty.

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete

This issue has sat incomplete for more than 60 days now. I'm going to close it as invalid. Please feel free re-open if this is still an issue for you. Thank you.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.